Firefox logo

Starting with March 7, when Mozilla is scheduled to release Firefox 52, all plugins built on the old NPAPI technology will stop working in Firefox, except for Flash, which Mozilla plans to support for a few more versions.

NPAPI stands for Netscape Plugins API and is an ancient plugins infrastructure inherited from the old Netscape browser on which Mozilla built Firefox.

The time of NPAPI has passed

The NPAPI backbone allowed Firefox to support features not embedded in web standards themselves. In the early days of the Internet, when browsers were simple pieces of software, this meant movies, songs, games, and others.

For this, developers and companies created plugins that adapted technologies such as Flash, Java, Silverlight, audio and movie codecs, and allowed them to work inside Firefox.

These plugins helped the web move forward, but as time advanced, the Internet's standards groups developed standalone Web APIs and technologies to support most of these features without the need of special plugins.

Today, audio and video streaming are supported by HTML5 itself, while games can be built with a vast array of technologies, all without the need of Java, Flash, or Silverlight.

Those technologies are now ancient, and so is the Firefox plugin infrastructure they're built to work on.

Mozilla announced the death of NPAPI plugins in 2015

Mozilla announced initial plans to deprecate the NPAPI plugins backbone in October 2015, as most of the plugins weren't needed anymore. Its main argument was that the NPAPI codebase dragged Firefox development and that most plugins introduced unnecessary security risks.

Initially, Mozilla planned to remove support for all NPAPI plugins except Flash at the end of 2016, but a second announcement made in July 2016 pushed the cutoff date to 2017, as Mozilla focused on other more important tasks, such as the launch of e10s and WebExtensions.

According to Firefox software engineer Mike Kaply, the NPAPI cutoff official date is now March 7, 2017, when Mozilla will release Firefox 52.

NPAPI plugins will continue to work in Firefox ESR 52

With v52's release, all NPAPI-based plugins except Flash will stop working in Firefox. The old NPAPI plugins will continue to work in the Firefox ESR (Extended Support Release) 52, but will eventually be deprecated in ESR 59.

Kaply has also published a series of Firefox hacks that users can make and switch to the ESR branch if they want to continue to use NPAPI plugins for a few more versions.

With this major change, Mozilla is taking one more step closer to shedding all the ancient code from Firefox's codebase.

In the past two years, Mozilla has embarked on a mammoth project to revamp Firefox's entire codebase, and has added multi-process support (e10s), switched to a new add-ons system (WebExtensions), and has slowly started to replace small pieces of Firefox's Gecko engine with Rust-based components.

UPDATE: A previous version of this article incorrectly stated that NPAPI plugins will be removed completely in Firefox ESR 53. This has been corrected to Firefox ESR 59.