<!doctype html>
<html lang="en-us">
<head>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N3FCGQ');</script>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<link href='https://fonts.googleapis.com/css?family=Roboto:400,100,300,500,700,900' rel='stylesheet' type='text/css'>

<link href="https://www.bleepstatic.com/css/redesign/bootstrap.css" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/main.css?v=3.29.17.1" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/home.css" rel="stylesheet" type="text/css" media="screen"><link href="https://www.bleepstatic.com/css/redesign/news.css?v=31017.2" rel="stylesheet" type="text/css" media="screen,print">
<link rel="stylesheet" href="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.css?v=2.1.5" type="text/css" media="screen" />

<meta name="Owner" content="Lawrence Abrams/BleepingComputer.com" />
<link rel="shortcut icon" href="https://www.bleepstatic.com/favicon/bleeping.ico" />
<meta property="og:site_name" content="BleepingComputer" />
<meta property="og:locale" content="en_us" />
<meta name="application-name" content="BleepingComputer" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//www.bleepstatic.com' />
<title>Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug</title>
<meta name="Keywords" content="computers, windows, linux, mac, support, tech support, spyware, malware, virus, security, Apple, Bluetooth, Cryptography, Encryption, Intel,virus removal, malware removal, computer help, technical support" />
<meta name="description" content="A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors." />
<meta name="abstract" content="A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors." />
<link rel="canonical" href="https://www.bleepingcomputer.com/news/security/many-bluetooth-implementations-and-os-drivers-affected-by-crypto-bug/" />
<link rel="prev" href="https://www.bleepingcomputer.com/news/security/attacks-on-oracle-weblogic-servers-detected-after-publication-of-poc-code/" />
<link rel="next" href="https://www.bleepingcomputer.com/news/microsoft/microsoft-released-windows-10-insider-update-to-build-177131002-to-test-servicing-pipeline/" />
<meta name="news_keywords" content="Apple, Bluetooth, Cryptography, Encryption, Intel, Security, InfoSec, Computer Security">
<meta property="og:url" content="https://www.bleepingcomputer.com/news/security/many-bluetooth-implementations-and-os-drivers-affected-by-crypto-bug/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug" />
<meta property="og:description" content="A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors." />
<meta property="og:image" content="https://www.bleepstatic.com/content/posts/2018/07/23/Bluetooth-crypto-bug.png" />
<meta property="og:image:secure_url" content="https://www.bleepstatic.com/content/posts/2018/07/23/Bluetooth-crypto-bug.png" />
<meta property="fb:app_id" content="517620508265293" />
<meta property="og:image:width" content="455" />
<meta property="og:image:height" content="1250" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@BleepinComputer" />
<meta name="twitter:creator" content="@BleepinComputer" />
<meta name="twitter:title" content="Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug" />
<meta name="twitter:description" content="A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors." />
<meta name="twitter:image" content="https://www.bleepstatic.com/content/posts/2018/07/23/Bluetooth-crypto-bug.png" />
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "headline": "Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug",
    "name": "Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "id": "https://www.bleepingcomputer.com/news/security/many-bluetooth-implementations-and-os-drivers-affected-by-crypto-bug/"
    },
    "description": "A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors.",
    "image": {
        "@type": "ImageObject",
        "url": "https://www.bleepstatic.com/content/posts/2018/07/23/Bluetooth-crypto-bug.png",
        "width": 1250,
        "height": 455
    },
    "author": {
        "@type": "Person",
        "name": "Catalin Cimpanu",
        "url": "https://www.bleepingcomputer.com/author/catalin-cimpanu/"
    },
    "keywords": ["Apple","Bluetooth","Cryptography","Encryption","Intel","Security","InfoSec, Computer Security"],
    "datePublished": "2018-07-24T01:00:00-04:00",
    "dateModified": "2018-07-25T16:00:11-04:00",
    "publisher": {
        "@type": "Organization",
        "name": "BleepingComputer.com",
        "url": "https://www.bleepingcomputer.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.bleepstatic.com/images/site/logo.png",
            "width": 287,
            "height": 24
        }
    }
}
</script>
<link href="https://plus.google.com/+bleepingcomputer" rel="publisher" />
<LINK REL="alternate" TITLE="Bleeping Computer's News" HREF="https://www.bleepingcomputer.com/feed/" TYPE="application/rss+xml">
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/jquery-1.11.1.min.js"></script>
<script type="text/javascript" async src="https://www.bleepstatic.com/js/redesign/bleep.js?t=1532593985"></script>
<script async type="text/javascript" src="https://www.bleepstatic.com/js/redesign/news.js"></script>
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  googletag.cmd.push(function() {
    
    googletag.defineSlot('/1006593/ROS_Side_2', [[300, 600], [300, 250]], 'div-gpt-ad-1474727680612-0').addService(googletag.pubads());

    googletag.defineSlot('/1006593/News_Sidebar_Sticky', [[300, 600], [300, 250]], 'div-gpt-ad-1509143326963-0').addService(googletag.pubads());
 
    googletag.defineSlot('/1006593/Onscroll_VET_Unit', [1, 1], 'div-gpt-ad-1508955865673-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type="text/javascript" id="nsgpt" data-channel="homepage" data-oop="" src="//cdn.nsstatic.net/ns/bleepingcomputer.com.js" async="true"></script>

<script data-cfasync='false' type='text/javascript'>
        window.apd_options = { 'websiteId': 5971, 'runFromFrame': false };
        (function() {
                var w = window.apd_options.runFromFrame ? window.top : window;
                if(window.apd_options.runFromFrame && w!=window.parent) w=window.parent;
                if (w.location.hash.indexOf('apdAdmin') != -1){if(typeof(Storage) !== 'undefined') {w.localStorage.apdAdmin = 1;}}
                var adminMode = ((typeof(Storage) == 'undefined') || (w.localStorage.apdAdmin == 1));
                w.apd_options=window.apd_options;
                var apd = w.document.createElement('script'); apd.type = 'text/javascript'; apd.async = true;
                apd.src = '//' + (adminMode ? 'cdn' : 'ecdn') + '.firstimpression.io/' + (adminMode ? 'fi.js?id=' + window.apd_options.websiteId : 'fi_client.js') ;
                var s = w.document.getElementsByTagName('head')[0]; s.appendChild(apd);
        })();</script>

</head>
<body>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N3FCGQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id='div-gpt-ad-1508955865673-0' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1508955865673-0'); });
</script>
</div>
<div class="bc_wrapper">

<header>
<div class="container">
<div class="row">
<div class="col-md-4">
<a class="bc_logo" href="https://www.bleepingcomputer.com/"><img src="https://www.bleepstatic.com/images/site/logo.png" width="287" height="24" alt="logo"></a>
</div>
<div class="col-md-8">
<ul class="bc_social_icons">
<li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
<li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
<li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
<li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
</ul>
<div class="bc_search_box">
<form action="https://www.bleepingcomputer.com/search/">
<input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228" />
<input type="hidden" name="cof" value="FORID:10" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="search" name="q" placeholder="Search Site" />
</form>
<script async type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
</div>
<div class="bc_login">
<input type="submit" value="Login" class="bc_login_btn">
<input type="submit" value="Sign up" class="bc_signup_btn" onclick="window.location='https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register';" />
</div>
</div>
</div>
</div>

<nav class="bc_navigation">
<div class="container">
<span id="toggle-nav" class="toggle-site-nav">
<span></span>
</span>
<div class="site-nav" id="nav" role="navigation">
<ul class="bc_social_icons bc_mob">
<li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
<li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
<li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
<li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
</ul>
<div class="bc_search_box bc_mob">
<form action="https://www.bleepingcomputer.com/search/">
<input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228" />
<input type="hidden" name="cof" value="FORID:10" />
<input type="hidden" name="ie" value="UTF-8" />
 <input type="search" name="q" placeholder="Search Site" />
</form>
<script async type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
</div>
<div class="bc_login bc_mob">
<input type="submit" value="Login" class="bc_login_btn">
<input type="submit" value="Sign up" class="bc_signup_btn">
</div>
<ul class="nav-menu">
<li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/">News</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#nfeatured" role="tab" data-toggle="tab">Featured</a></li>
<li><a href="#nlatest" role="tab" data-toggle="tab">Latest</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="nfeatured">
<ul>
<li>
<a href="https://www.bleepingcomputer.com/news/government/senator-asks-us-government-to-remove-flash-from-federal-sites-computers/" class="nmic">
<img src="https://www.bleepstatic.com/content/hl-images/2016/12/14/thumb/211x130_Flash.jpg" alt="Senator Asks US Government to Remove Flash From Federal Sites, Computers Image">
<p>Senator Asks US Government to Remove Flash From Federal Sites, Computers</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/security/dhs-warns-of-impending-cyber-attacks-on-erp-systems/" class="nmic">
<img src="https://www.bleepstatic.com/content/hl-images/2018/01/04/thumb/211x130_DHS.png" alt="DHS Warns of Impending Cyber-Attacks on ERP Systems Image">
<p>DHS Warns of Impending Cyber-Attacks on ERP Systems</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/technology/eu-fines-asus-philips-pioneer-130-million-for-online-price-fixing/" class="nmic">
<img src="https://www.bleepstatic.com/content/posts/2018/07/25/thumb/211x130_Asus.jpg" alt="EU Fines Asus, Philips, Pioneer $130 Million for Online Price Fixing Image">
<p>EU Fines Asus, Philips, Pioneer $130 Million for Online Price Fixing</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/security/malware-author-building-death-botnet-using-old-avtech-flaw/" class="nmic">
<img src="https://www.bleepstatic.com/content/posts/2018/07/24/thumb/211x130_Death-botnet.png" alt="Malware Author Building " Death" Botnet Using Old AVTech Flaw Image">
<p>Malware Author Building "Death" Botnet Using Old AVTech Flaw</p>
</a>
</li>
</ul>
</div>
<div role="tabpanel" class="tab-pane" id="nlatest">
<ul>
<li>
<a href="https://www.bleepingcomputer.com/news/microsoft/windows-10-insider-build-17723-redstone-5-and-build-18204-redstone-6-released-heres-whats-new/" class="nmic">
<img src="https://www.bleepstatic.com/content/hl-images/2017/03/03/thumb/0_windows-10-insider-preview.jpg" alt="Windows 10 Insider Build 17723 (Redstone 5) & Build 18204 (Redstone 6) Released. Here's Whats New! Image">
<p>Windows 10 Insider Build 17723 (Redstone 5) & Build 18204 (Redstone 6) Released. Here's Whats New!</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/security/twitter-removes-143-000-apps-that-violated-companys-policy/" class="nmic">
<img src="https://www.bleepstatic.com/content/hl-images/2018/05/03/thumb/211x130_Twitter.png" alt="Twitter Removes 143,000 Apps That Violated Company's Policy Image">
<p>Twitter Removes 143,000 Apps That Violated Company's Policy</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/security/ransomware-infection-cripples-shipping-giant-coscos-american-network/" class="nmic">
<img src="https://www.bleepstatic.com/content/posts/2018/07/25/thumb/211x130_container-ship.jpg" alt="Ransomware Infection Cripples Shipping Giant COSCO's American Network Image">
<p>Ransomware Infection Cripples Shipping Giant COSCO's American Network</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/microsoft/outlookcoms-new-design-is-now-rolling-out-to-some-accounts/" class="nmic">
<img src="https://www.bleepstatic.com/content/posts/2018/07/25/thumb/211x130_outlook_com-dark-mode.jpg" alt="Outlook.com's New Design Is Now Rolling Out to Some Accounts Image">
<p>Outlook.com's New Design Is Now Rolling Out to Some Accounts</p>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
<li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/download/">Downloads</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#dlatest" role="tab" data-toggle="tab">Latest</a></li>
<li><a href="#most" role="tab" data-toggle="tab">Most Downloaded</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="dlatest">
<ul>
<li>
<a href="https://www.bleepingcomputer.com/download/360-total-security/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/1/197-360-total-security.jpg" alt="360 Total Security Image">
<p class="center">360 Total Security</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/download/skype-classic/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/1/196-skype-classic.jpg" alt="Skype Classic Image">
<p class="center">Skype Classic</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/download/gpu-z/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/1/195-gpu-z.jpg" alt="GPU-Z Image">
<p class="center">GPU-Z</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/download/insanecrypt-desucrypt-decrypter/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/1/194-insanecrypt-desucrypt-decrypter.jpg" alt="InsaneCrypt (desuCrypt) Decrypter Image">
<p class="center">InsaneCrypt (desuCrypt) Decrypter</p>
</a>
</li>
</ul>
</div>
<div role="tabpanel" class="tab-pane" id="most">
<ul>
<li>
<a href="/download/adwcleaner/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/0/96-adwcleaner.jpg" alt="AdwCleaner Image">
<p class="center">AdwCleaner</p>
</a>
</li>
<li>
<a href="/download/combofix/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/0/9-combofix.jpg" alt="ComboFix Image">
<p class="center">ComboFix</p>
</a>
</li>
<li>
<a href="/download/rkill/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/0/8-rkill.jpg" alt="RKill Image">
<p class="center">RKill</p>
</a>
</li>
<li>
<a href="/download/junkware-removal-tool/" class="nmic">
<img src="https://www.bleepstatic.com/download/nav-header-images/0/98-junkware-removal-tool.jpg" alt="Junkware Removal Tool Image">
<p class="center">Junkware Removal Tool</p>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
<li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#vlatest" role="tab" data-toggle="tab">Latest</a></li>
<li><a href="#vmost" role="tab" data-toggle="tab">Most Viewed</a></li>
<li><a href="#ransomware" role="tab" data-toggle="tab">Ransomware</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="vlatest">
<ul>
<li>
<a href="/virus-removal/remove-whiteclick-or-white-click-toolbar" class="nmic">
<img src="https://www.bleepstatic.com/removal-guides/w/white-click-toolbar/white-click-toolbar-thmb-350.jpg" alt="Remove the WhiteClick or the White Click Toolbar Image">
<p>Remove the WhiteClick or the White Click Toolbar</p>
</a>
</li>
<li>
<a href="/virus-removal/remove-browsing-secure-pup" class="nmic">
<img src="https://www.bleepstatic.com/removal-guides/b/browsing-secure/scheduled-task-thmb-350.jpg" alt="Remove the Browsing Secure PUP Image">
<p>Remove the Browsing Secure PUP</p>
</a>
</li>
<li>
<a href="/virus-removal/remove-smart-pc-care-pup" class="nmic">
<img src="https://www.bleepstatic.com/removal-guides/s/smart-pc-care/smart-pc-care-thmb-350.jpg" alt="Remove the Smart PC Care PUP Image">
<p>Remove the Smart PC Care PUP</p>
</a>
</li>
<li>
<a href="/virus-removal/remove-revservicesx-bitcoin-miner-trojan" class="nmic">
<img src="https://www.bleepstatic.com/removal-guides/r/RevServicesX/RevServicesX-folder-thmb-350.jpg" alt="Remove the RevServicesX Bitcoin Miner Trojan Image">
<p>Remove the RevServicesX Bitcoin Miner Trojan</p>
</a>
</li>
</ul>
</div>
<div role="tabpanel" class="tab-pane" id="vmost">
<ul>
<li>
<a href="/virus-removal/remove-security-tool" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/s/securitytool/security-tool-thmb-350.jpg" alt="Remove Security Tool and SecurityTool (Uninstall Guide) Image">
<p>Remove Security Tool and SecurityTool (Uninstall Guide)</p>
</a>
</li>
<li>
<a href="/virus-removal/uninstall-antivirus-2009" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/a/antivirus-2009/antivirus-2009-thmb-350.jpg" alt="How to remove Antivirus 2009 (Uninstall Instructions) Image">
<p>How to remove Antivirus 2009 (Uninstall Instructions)</p>
</a>
</li>
<li>
<a href="/virus-removal/remove-vundo-virtumonde" class="nmic">
<img src="https://www.bleepstatic.com/images/site/navigation/generic-chalkboard-211x130.jpg" alt="How to Remove WinFixer / Virtumonde / Msevents / Trojan.vundo Image">
<p>How to Remove WinFixer / Virtumonde / Msevents / Trojan.vundo</p>
</a>
</li>
<li>
<a href="/virus-removal/remove-tdss-tdl3-alureon-rootkit-using-tdsskiller" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/tools/tdsskiller/tdsskiller-start-thmb-350.jpg" alt="How to remove Google Redirects or the TDSS, TDL3, or Alureon rootkit using TDSSKiller Image">
<p>How to remove Google Redirects or the TDSS, TDL3, or Alureon rootkit using TDSSKiller</p>
</a>
</li>
</ul>
</div>
<div role="tabpanel" class="tab-pane" id="ransomware">
<ul>
<li>
<a href="/virus-removal/locky-ransomware-information-help" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/l/locky/locky-header-thmb-350.png" alt="Locky Ransomware Information, Help Guide, and FAQ Image">
<p>Locky Ransomware Information, Help Guide, and FAQ</p>
</a>
</li>
<li>
<a href="/virus-removal/cryptolocker-ransomware-information" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/c/cryptolocker/CryptoLocker-thmb-350.jpg" alt="CryptoLocker Ransomware Information Guide and FAQ Image">
<p>CryptoLocker Ransomware Information Guide and FAQ</p>
</a>
</li>
<li>
<a href="/virus-removal/cryptorbit-ransomware-information" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/c/cryptorbit/howdecrypt-thmb-350.gif" alt="CryptorBit and HowDecrypt Information Guide and FAQ Image">
<p>CryptorBit and HowDecrypt Information Guide and FAQ</p>
</a>
</li>
<li>
<a href="/virus-removal/cryptodefense-ransomware-information" class="nmic">
<img src="https://www.bleepstatic.com/swr-guides/c/CryptoDefense/how_decrypt-html-thmb-350.jpg" alt="CryptoDefense and How_Decrypt Ransomware Information Guide and FAQ Image">
<p>CryptoDefense and How_Decrypt Ransomware Information Guide and FAQ</p>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
<li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#tlatest" role="tab" data-toggle="tab">Latest</a></li>
<li><a href="#popular" role="tab" data-toggle="tab">Popular</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="tlatest">
<ul>
<li>
<a href="/tutorials/how-to-enable-dark-mode-theme-in-windows-10/" class="nmic">
 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/7/351-dark-theme-enabled.jpg" alt="How to Enable the Dark Mode Theme in Windows 10 Image">
<p>How to Enable the Dark Mode Theme in Windows 10</p>
</a>
</li>
<li>
<a href="/tutorials/how-to-change-your-twitter-password/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/7/350-new-password-entered.jpg" alt="How to Change Your Twitter Password Image">
<p>How to Change Your Twitter Password</p>
</a>
</li>
<li>
<a href="/tutorials/how-to-setup-login-verification-in-twitter/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/349-account-settings.jpg" alt="How to Setup Login Verification in Twitter Image">
<p>How to Setup Login Verification in Twitter</p>
</a>
</li>
<li>
<a href="/tutorials/how-to-use-cortana-as-your-virtual-assistant-in-windows/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/348-hey-cortana.png" alt="How to Use Cortana As Your Virtual Assistant in Windows Image">
<p>How to Use Cortana As Your Virtual Assistant in Windows</p>
</a>
</li>
</ul>
</div>
<div role="tabpanel" class="tab-pane" id="popular">
<ul>
<li>
<a href="/tutorials/how-to-start-windows-in-safe-mode/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/61-startup-settings.png" alt="How to start Windows in Safe Mode Image">
<p>How to start Windows in Safe Mode</p>
</a>
</li>
<li>
<a href="/tutorials/how-to-remove-a-trojan-virus-worm-or-malware/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/2/101-Cerber-wallpaper.png" alt="How to remove a Trojan, Virus, Worm, or other Malware Image">
<p>How to remove a Trojan, Virus, Worm, or other Malware</p>
</a>
</li>
<li>
<a href="/tutorials/show-hidden-files-in-windows-7/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/3/151-show-hidden-files.jpg" alt="How to show hidden files in Windows 7 Image">
<p>How to show hidden files in Windows 7</p>
</a>
</li>
<li>
<a href="/tutorials/how-to-see-hidden-files-in-windows/" class="nmic">
<img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/62-hidden-files.jpg" alt="How to see hidden files in Windows Image">
<p>How to see hidden files in Windows</p>
</a>
 </li>
</ul>
</div>
</div>
</div>
</div>
</li>
<li class="bc_dropdown"><a href="https://deals.bleepingcomputer.com/">Deals</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#dcategories" role="tab" data-toggle="tab">Categories</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="dcategories">
<ul>
<li>
<a href="https://deals.bleepingcomputer.com/deals/elearning?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
<img src="https://www.bleepstatic.com/images/deals/elearning-nav.jpg" alt="eLearning Image">
<p align='center'>eLearning</p>
</a>
</li>
<li>
<a href="https://deals.bleepingcomputer.com/deals/certifications?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
<img src="https://www.bleepstatic.com/images/deals/it-certification-nav.jpg" alt="IT Certification Courses Image">
<p align='center'>IT Certification Courses</p>
</a>
</li>
<li>
<a href="https://deals.bleepingcomputer.com/deals/gear-gadgets?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
<img src="https://www.bleepstatic.com/images/deals/gear-gadgets-nav.jpg" alt="Gear &amp; Gadgets Image">
<p align='center'>Gear + Gadgets</p>
</a>
</li>
<li>
<a href="https://deals.bleepingcomputer.com/collections/tag-cyber-security?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
<img src="https://www.bleepstatic.com/images/deals/security-nav.jpg" alt="Security Image">
<p align='center'>Security</p>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
<li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
<li class="bc_dropdown bc_more_nav"><a id="more_dd" href="#">More</a>
<ul id="bc_more-nav" class="bc_more_submenu">
<li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
<li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
<li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
<li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
<li><a href="https://www.bleepingcomputer.com/forums/t/679076/the-bleepingcomputer-official-discord-chat-server-come-join-the-fun/">Chat on Discord</a></li>
<li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
 </ul>
</li>
</ul>
</div>
</div>
</nav>
</header>

<section class="cz-oa-wrapp">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="cz-toa-wrapp">
<div data-ns="billboard" data-pos="atf" data-collapse="true"></div>
</div>
</div>
</div>
</div>
</section>
<section>
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="cz-breadcrumb-outer-wrapp">
<div class="cz-breadcrumb-left-area">
<div class="cz-breadcrumb">
<ul itemscope itemtype="https://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="https://www.bleepingcomputer.com/" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/" itemprop="item">News</a></span><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/security/" itemprop="item">Security</a></span><meta itemprop="position" content="3" /></li><li class="active" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><span itemprop="name">Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug</span></li>
</ul>
</div>
</div>
<div class="cz-breadcrumb-right-area">
<div class="cz-like-wrapper">
<ul>
<li><div class="addthis_sharing_toolbox"></div></li>
<li class="cz-print-icon"><a href="#">&nbsp;</a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</section>

<section class="bc_main_content">
<div class="container">
<div class="row">
<div class="col-md-8">
<div class="cz-main-left-section">
<div class="article_section">
<h2>Many Bluetooth Implementations and OS Drivers Affected by Crypto Bug</h2>
<div class="cz-news-story-title-section">
<div class="cz-news-title-left-area">
By <h6><a rel='author' href='https://www.bleepingcomputer.com/author/catalin-cimpanu/' class='author'><span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name">Catalin Cimpanu</span></span></a></h6>
</div>
<meta itemprop="articleSection" content="Security">
<div class="cz-news-title-right-area">
<ul>
<li class="cz-news-date">July 24, 2018</li>
<li class="cz-news-time">01:00 AM</li>
<li class="cz-news-comment"><a href="#comment_form">0</a></li>
</ul>
</div>
</div>
<div class="articleBody">
<p style="text-align:center"><img alt="Bluetooth logo" height="455" src="https://www.bleepstatic.com/content/posts/2018/07/23/Bluetooth-crypto-bug.png" width="1250" /></p>
<p>A cryptographic bug affects the Bluetooth implementations and operating system drivers of Apple, Broadcom, Intel, Qualcomm, and possibly other hardware vendors.</p>
<p>This bug occurs because Bluetooth-capable devices do not sufficiently validate encryption parameters used during &quot;secure&quot; Bluetooth connections. More precisely, pairing devices do not sufficiently validate elliptic curve parameters used to generate public keys during a Diffie-Hellman key exchange.</p>
<p>This results in a weak pairing that may allow a remote attacker to obtain the encryption key used by a device and recover data sent between two devices paired in a &quot;secure&quot; Bluetooth connection.</p>
<h2>Both Bluetooth and Bluetooth LE affected</h2>
<p>Both the Bluetooth standard&#39;s &quot;Secure Simple Pairing&quot; process and Bluetooth LE&#39;s &quot;Secure Connections&quot; pairing process are affected.</p>
<p>Two scientists from the Israel Institute of Technology, Lior Neumann and Eli Biham, discovered the vulnerability, tracked as <a href="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5383" rel="nofollow" target="_blank">CVE-2018-5383</a>, and detailed on this <a href="https://www.cs.technion.ac.il/~biham/BT/" rel="nofollow" target="_blank">website</a> and this <a href="https://www.cs.technion.ac.il/~biham/BT/bt-fixed-coordinate-invalid-curve-attack.pdf" rel="nofollow" target="_blank">research paper</a>.</p>
<p>CERT/CC has sent out a <a href="https://www.kb.cert.org/vuls/id/304725" rel="nofollow" target="_blank">security advisory</a> last night with the following explanation for the vulnerability:</p>
<div style="background:#eeeeee; border:1px solid #cccccc; padding:5px 10px">Bluetooth utilizes a device pairing mechanism based on elliptic-curve Diffie-Hellman (ECDH) key exchange to allow encrypted communication between devices. The ECDH key pair consists of a private and a public key, and the public keys are exchanged to produce a shared pairing key. The devices must also agree on the elliptic curve parameters being used. Previous work on the &quot;Invalid Curve Attack&quot; showed that the ECDH parameters are not always validated before being used in computing the resulted shared key, which reduces attacker effort to obtain the private key of the device under attack if the implementation does not validate all of the parameters before computing the shared key.<br />
<br />
In some implementations, the elliptic curve parameters are not all validated by the cryptographic algorithm implementation, which may allow a remote attacker within wireless range to inject an invalid public key to determine the session key with high probability. Such an attacker can then passively intercept and decrypt all device messages, and/or forge and inject malicious messages.</div>
<h2>Some big vendors affected</h2>
<p>Apple, Broadcom, Intel, and Qualcomm have confirmed that Bluetooth implementations and OS drivers are affected. <a href="https://www.kb.cert.org/vuls/id/CHEU-AV5MHR" rel="nofollow" target="_blank">Apple</a>, <a href="https://www.kb.cert.org/vuls/id/CHEU-AV5MHL" rel="nofollow" target="_blank">Broadcom</a>, and <a href="https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00128.html" rel="nofollow" target="_blank">Intel</a> have deployed fixes for the bug. A Qualcomm spokesperson told Bleeping Computer via email that they have deployed fixes as well.</p>
<p>Microsoft said its devices are not affected. CERT/CC experts were not able to determine if Android, Google devices, or the Linux kernel are affected.</p>
<p>The Bluetooth Special Interest Group (SIG), the organization that oversees the development of Bluetooth standards, has issued a <a href="https://www.bluetooth.com/news/unknown/2018/07/bluetooth-sig-security-update" rel="nofollow" target="_blank">statement</a> in regards to the vulnerability.</p>
<div style="background:#eeeeee; border:1px solid #cccccc; padding:5px 10px">For an attack to be successful, an attacking device would need to be within wireless range of two vulnerable Bluetooth devices that were going through a pairing procedure. The attacking device would need to intercept the public key exchange by blocking each transmission, sending an acknowledgment to the sending device, and then injecting the malicious packet to the receiving device within a narrow time window. If only one device had the vulnerability, the attack would not be successful.</div>
<p>The organization says it has now updated the official Bluetooth specification to require that all pairing devices validate all parameters used for key-based encrypted Bluetooth connections.</p>
<p>Researchers and Bluetooth SIG said they weren&#39;t aware of any in-the-wild attacks where this vulnerability might have been used. The good news is that the attacker needs to be near the victim when he/she is pairing a Bluetooth device, a process that occurs very rarely, and can&#39;t be forced via a deauth operation. Furthermore, if one of the two devices participating in a paring operation have received a patch, then the attack won&#39;t work anymore.</p>
<p>The updates for CVE-2018-5383 should be expected as OS updates or driver updates (for desktops, laptops, and smartphones), or firmware updates (in the case of IoT/smart devices).</p>
<p><span style="font-size:12px"><em>Article updated with information on Intel and Qualcomm fixes.</em></span></p>
<div class="cz-related-article-wrapp">
<h3>Related Articles:</h3>
<p><a href="https://www.bleepingcomputer.com/news/apple/macos-breaks-your-opsec-by-caching-data-from-encrypted-hard-drives/" class="ras">macOS Breaks Your OpSec by Caching Data From Encrypted Hard Drives</a></p><p><a href="https://www.bleepingcomputer.com/news/microsoft/microsoft-adds-post-quantum-cryptography-to-an-openvpn-fork/" class="ras">Microsoft Adds Post-Quantum Cryptography to an OpenVPN Fork</a></p><p><a href="https://www.bleepingcomputer.com/news/security/researchers-detail-new-cpu-side-channel-attack-named-spectrersb/" class="ras">Researchers Detail New CPU Side-Channel Attack Named SpectreRSB</a></p><p><a href="https://www.bleepingcomputer.com/news/security/new-spectre-11-and-spectre-12-cpu-flaws-disclosed/" class="ras">New Spectre 1.1 and Spectre 1.2 CPU Flaws Disclosed</a></p><p><a href="https://www.bleepingcomputer.com/news/security/open-mongodb-database-exposes-mobile-games-money-laundering-operation/" class="ras">Open MongoDB Database Exposes Mobile Games Money Laundering Operation</a></p>
</div>
</div>
</div>
<div class="asa">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-3249370012249755";
/* News - After Story */
google_ad_slot = "5975899204";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>
<div class="cz-news-tags-wrap">
<ul>
<li><a href="https://www.bleepingcomputer.com/tag/apple/">Apple</a></li>
<li><a href="https://www.bleepingcomputer.com/tag/bluetooth/">Bluetooth</a></li>
<li><a href="https://www.bleepingcomputer.com/tag/cryptography/">Cryptography</a></li>
<li><a href="https://www.bleepingcomputer.com/tag/encryption/">Encryption</a></li>
<li><a href="https://www.bleepingcomputer.com/tag/intel/">Intel</a></li>
</ul>
</div>
<div class="cz-news-like-wrapp">
<div class="addthis_toolbox addthis_default_style addthis_32x32_style">
<div class="cz-news-like-left-area">
<ul>
<li><a class="addthis_button_facebook"></a></li>
<li><a class="addthis_button_twitter"></a></li>
<li><a class="addthis_button_google_plusone_share"></a></li>
<li><a class="addthis_button_linkedin"></a></li>
</ul>
</div>
<div class="cz-news-like-right-area">
<ul>
<li><a class="addthis_button_email"></a></li>
<li class="cz-lg-print-icon"><a href="#"></a></li>
</ul>
</div>
</div>
</div>
<div class="cz-full-bio-wrapp">
<div class="cz-full-bio-img-wrapp">
<a style="background-image:url('https://www.bleepstatic.com/author/photos/e1bde5ed1bb1075346983638c8e177b2.png');" class="author-img" href="https://www.bleepingcomputer.com/author/catalin-cimpanu/"></a>
</div>
<div class="cz-full-bio-content-wrapp">
<h5><a href="https://www.bleepingcomputer.com/author/catalin-cimpanu/" target="_blank">Catalin Cimpanu</a> <span> <a href="mailto:catalin@bleepingcomputer.com"><i class="fa fa-envelope email"></i></a> <a href="https://twitter.com/campuscodi" target="_blank"><i class="fa fa-twitter twitter"></i></a></span></h5>
Catalin Cimpanu is the Security News Editor for Bleeping Computer, where he covers topics such as malware, breaches, vulnerabilities, exploits, hacking news, the Dark Web, and a few more. Catalin previously covered Web & Security news for Softpedia between May 2015 and October 2016. The easiest way to reach Catalin is via his XMPP/Jabber address at campuscodi@xmpp.is. For other contact methods, please visit Catalin's author page.
</div>
</div>
<div class="cz-story-navigation">
<ul>
<li><a href="https://www.bleepingcomputer.com/news/security/attacks-on-oracle-weblogic-servers-detected-after-publication-of-poc-code/"><i class="fa fa-chevron-left"></i> Previous Article </a></li>
<li><a href="https://www.bleepingcomputer.com/news/microsoft/microsoft-released-windows-10-insider-update-to-build-177131002-to-test-servicing-pipeline/">Next Article <i class="fa fa-chevron-right"></i></a></li>
</ul>
</div>
<div class="cz-post-comment-wrapp">
<h5>Post a Comment <span><a href="https://www.bleepingcomputer.com/forum-rules/" target="_blank">Community Rules</a></span></h5>
<div class="cz-comment-loggin-wrapp">
<h6>You need to login in order to post a comment</h6>
<input type="submit" value="Login" class="bc_login_btn cz-green-bttn">
<p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
</div>
</div>
<div class="cz-related-article-wrapp">
<h3>You may also like:</h3>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-0920899300397823" data-ad-slot="4359266829"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>

<div class="col-md-4 bc_right_sidebar">
<div class="s-ou-wrap">
<div data-ns="portrait" data-pos="atf" data-collapse="true"></div>
</div>

<div id="tvp-gallery"></div>

<div id="pop_stories">
<div class="cz-line-heading"><div class="cz-line-heading-inner">Popular Stories</div></div>
<ul>
<li>
<a class="pns" href="https://www.bleepingcomputer.com/offer/deals/get-over-90-percent-off-a-windscribe-pro-vpn-lifetime-subscription-deal/">
<div class="bc_pop_story_img)">
<img src="https://www.bleepstatic.com/content/posts/2017/08/14/thumb/292x176_windscribe.jpg">
</div>
<p>Get Over 90% off a Windscribe Pro VPN Lifetime Subscription Deal</p>
</a>
</li>
<li>
<a class="pns" href="https://www.bleepingcomputer.com/news/microsoft/windows-10-cumulative-updates-kb4340917-kb4338817-and-kb4338827-released/">
<div class="bc_pop_story_img)">
<img src="https://www.bleepstatic.com/content/hl-images/2017/04/06/thumb/292x176_Windows-Update.jpg">
</div>
<p>Windows 10 Cumulative Updates KB4340917, KB4338817 and KB4338827 Released</p>
</a>
</li>
</ul>
</div>
<div class="s-ou-wrap">

<div id='div-gpt-ad-1474727680612-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1474727680612-0'); });
</script>
</div>
</div>
<div class="bc_news_letter_sidebar">
<h4>Newsletter Sign Up</h4>
<p>To receive periodic updates and news from <a href="/">BleepingComputer</a>, please use the form below. </p>
<form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
<input type="email" name="EMAIL" placeholder="Email Address...">
<div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div>
<input type="submit" value="Submit" class="bc_sub_btn">
 </form>
</div>
<div class="s-ou-wrap" id="pinned">
<div id='div-gpt-ad-1509143326963-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1509143326963-0'); });
</script>
</div>
</div>
</div>
</div>
</div>
</section>

<section class="cz-boa-wrapp">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="cz-advertise-wrapp">
<script type="text/javascript"><!--
 google_ad_client = "ca-pub-3249370012249755";
 /* Homepage - Bottom */
 google_ad_slot = "1089300124";
 google_ad_width = 728;
 google_ad_height = 90;
 //-->
 </script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>
</div>
</div>
</div>
</section>

<footer id="footer">
<div class="container">
<div class="row">
<div class="col-md-4">
<h5>Newsletter Sign Up</h5>
<form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
<input type="email" name="EMAIL" placeholder="Email Address...">
<div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div
>
<input type="submit" value="Submit" class="bc_sub_btn">
</form>
<ul class="bc_social_icons">
<li>Follow us:</li>
<li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
<li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
<li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
<li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
<li><a href="https://www.bleepingcomputer.com/feed/"><span class="fa fa-rss"></span></a></li>
</ul>
</div>
<div class="col-md-2">
<h5>Main Sections</h5>
<ul>
<li><a href="https://www.bleepingcomputer.com/">News</a></li>
<li><a href="https://www.bleepingcomputer.com/download/">Downloads</a></li>
<li><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a></li>
<li><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a></li>
<li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
<li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
<li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
<li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
</ul>
</div>
<div class="col-md-2">
<h5>Community</h5>
<ul>
<li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
<li><a href="https://www.bleepingcomputer.com/forum-rules/">Forum Rules</a></li>
<li><a href="https://www.bleepingcomputer.com/forums/t/679076/the-bleepingcomputer-official-discord-chat-server-come-join-the-fun/">Chat</a></li>
</ul>
</div>
<div class="col-md-2">
<h5>Useful Resources</h5>
<ul>
<li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
<li><a href="https://www.bleepingcomputer.com/sitemap/">Sitemap</a></li>
</ul>
</div>
<div class="col-md-2">
<h5>Company</h5>
<ul>
 <li><a href="https://www.bleepingcomputer.com/about/">About BleepingComputer</a></li>
<li><a href="https://www.bleepingcomputer.com/contact/">Contact Us</a></li>
<li><a href="https://www.bleepingcomputer.com/advertise/">Advertising</a></li>
<li><a href="https://www.bleepingcomputer.com/write-for-bleepingcomputer/">Write for BleepingComputer</a></li>
<li><a href="https://www.bleepingcomputer.com/rss-feeds/">Social & Feeds</a></li>
<li><a href="https://www.bleepingcomputer.com/changelog/">Changelog</a></li>
</ul>
</div>
</div>
</div>
<div class="bc_footer_bottom">
<div class="container">
<div class="row">
<div class="col-md-6">
<p><a href="https://www.bleepingcomputer.com/terms-of-use/">Terms of Use</a> - <a href="https://www.bleepingcomputer.com/privacy/"> Privacy Policy</a></p>
</div>
<div class="col-md-6 bc_copyright">
<p>Copyright @ 2003 - 2018 <a href="https://www.bleepingcomputer.com/"> Bleeping Computer<sup>&reg;</sup> LLC </a> - All Rights Reserved</p>
</div>
</div>
</div>
</div>
</footer>
</div>


<div class="bc_goto_top">
<a href="#"><i class="fa fa-chevron-up"></i></a>
</div>


<div class="bc_popup">
<div class="bc_login_form">
<a class="bc_popup_close" href="javascript:;" title="Close"></a>
<h4>Login</h4>
<form action="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;do=process&amp;return=https://www.bleepingcomputer.com/" method="post">
<div class="bc_form_feild">
<label for="ips_username">Username</label>
<input type="text" id="ips_username" name="ips_username">
</div>
<div class="bc_form_feild">
<label for="ips_password">Password</label>
<input type="password" id="ips_password" name="ips_password">
</div>
<div class="bc_form_feild">
<div class="bc_remember">
<input id="remember" type="checkbox" name="rememberMe" value="None" checked="checked">
<label for="remember"></label>
<span>Remember Me</span>
</div>
<div class="bc_anon">
<input id="anonymous" type="checkbox" name="anonymous" value="None">
<label for="anonymous"></label>
<span>Sign in anonymously</span>
</div>
</div>
<div class="bc_btn_wrap">
<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />
<input type="submit" value="Login" class="bc_sub_btn">
<a href="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;serviceClick=twitter&amp;return=https://www.bleepingcomputer.com/news/security/many-bluetooth-implementations-and-os-drivers-affected-by-crypto-bug/" class="bc_twitter_btn"><img src="https://www.bleepstatic.com/images/site/login/twitter.png" width="28" height="24" alt="Sign in with Twitter"> Sign in with Twitter</a>
<hr />
<p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
</div>
</form>
</div>
</div>


<script async type="text/javascript" src="https://www.bleepstatic.com/js/redesign/bootstrap.js"></script>
<script>
    window.__TVPage__ = window.__TVPage__ || {};
    __TVPage__.config = __TVPage__.config || {};
    __TVPage__.config['sidebar-dynamic'] = {

        channel: {
            id: "81979997",
            
        },
        targetEl: "tvp-gallery",
        
        products_info_tooltip: true,
        products_message: "Based on the video you are watching, we think you might be interested in one or more " +
            "of these products. Clicking in this box will show you results from providers who can fulfill your " +
            "request. We may be compensated by some of these providers.",
        products_headline_text: "Sponsored Products",
                no_products_banner: function() {
            return "<div data-ns='leaderboard' data-pos='' data-collapse='true'></div>";
        },
        title_text: "<span>Recommended Videos</span><span style=\"background-color:#eaeaea;height:5px;" +
            "width:28%;display:block;position:absolute;right:0;top:35%;transform:translateY(-50%);\"></span>"
    };
</script>
<script async src='//videos-bleepingcomputers-com.tvpagecdn.com/tvpwidget/sidebar-dynamic/index.js'></script>
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.js?v=2.1.5"></script>
<script type="text/jscript">
$(document).ready(function(e) {
    $('.articleBody img').not('a>img').not('.contrib_but>img').click(function(e) {
        e.preventDefault();
                 $.fancybox({'href' : $(this).attr('src')});
    });
});
</script>
<script src="//www.bleepstatic.com/js/fixto/fixto.min.js"></script>
<script type="text/javascript">
$(document).ready(function(){

var content = $('.cz-main-left-section');
var sidebar = $('.bc_right_sidebar');
var count = 0;
var myTimer;

function setEqualContainer() {
        var getContentHeight = content.outerHeight();
        var getSidebarHeight = sidebar.outerHeight();

        if ( getContentHeight > getSidebarHeight ) {
                sidebar.css('min-height', getContentHeight);
        }

        if ( getSidebarHeight > getContentHeight ) {
                content.css('min-height', getSidebarHeight);
        }
}

// creating the timer which will run every 500 milliseconds
// and will stop after the container will be loaded
// ...or after 15 seconds to not eat a lot of memory

myTimer = setInterval( function() {
        count++;

        if ( $('.testContainer').length == 0 ) {
                setEqualContainer();
        } else {
                setEqualContainer();
                clearInterval(myTimer);
        }

        if ( count == 15) {
                clearInterval(myTimer);
        }
}, 500);

        $('#pinned').fixTo('.bc_right_sidebar', {
                 top: 129
        });

        $('#more_dd').click(function (e) {
          e.preventDefault()
        });

        $('.bc_goto_top a').click(function(){
        $("html, body").animate({ scrollTop: 0 }, 600);
        return false;
        });
        jQuery('.bc_login_btn').on('click', function() {
    jQuery('.bc_popup').fadeIn("slow");
  });
        jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });

});
</script>
<script type="text/javascript">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</script>
<script type="text/javascript">
$('.cz-print-icon, .cz-lg-print-icon').click(function(e) {
    e.preventDefault();
    var divToPrint = document.getElementById('.article_section'); 
    var mywindow = window.open('','','left=0,top=0,width=950,height=600,toolbar=0,scrollbars=0,status=0,addressbar=0');

    var is_chrome = Boolean(mywindow.chrome);
    mywindow.document.write($( ".article_section" ).html());
    mywindow.document.close(); // necessary for IE >= 10 and necessary before onload for chrome

    if (is_chrome) {
        mywindow.onload = function() { // wait until all resources loaded 
            mywindow.focus(); // necessary for IE >= 10
            mywindow.print();  // change window to mywindow
            mywindow.close();// change window to mywindow
        };
    }
    else {
        mywindow.document.close(); // necessary for IE >= 10
        mywindow.focus(); // necessary for IE >= 10
        mywindow.print();
        mywindow.close();
    }

    return true;
});
</script>
<script type="text/javascript">

var loginhash = '880ea6a14ea49e853634fbdc5015a024';
var main_nav_hide_flag = true;
var scrollTop =0;
var main_nav_hide_timer = '';

function call_main_nav_hide()
{
 if(main_nav_hide_flag && scrollTop >=100)
 {
  $('header').addClass("nav-up");
 }
}
var cz_header_pos = $('header').offset().top;
$(window).scroll(function() {
	$('header').each(function(){
	var cz_top_of_window = $(window).scrollTop()-100;
		if (cz_top_of_window > cz_header_pos) {			
			$('.bc_goto_top').fadeIn("slow");
		} else {
			$('.bc_goto_top').fadeOut("slow");			
		}
	});

});
var prevScrollTop = 0;
$(window).scroll(function(event){
    scrollTop = $(this).scrollTop();

    if ( scrollTop < 0 ) {
        scrollTop = 0;
    }
    if ( scrollTop > $('body').height() - $(window).height() ) {
        scrollTop = $('body').height() - $(window).height();
    }

    if (scrollTop >= prevScrollTop && scrollTop) {
        $('header').addClass("nav-up");
    } else {
	if (scrollTop >=100)
	{
	 $('header').removeClass("nav-up"); 
	 main_nav_hide_timer = setTimeout("call_main_nav_hide()",5000);
	}
	else
	{
	 $('header').removeClass("nav-up");
	 clearInterval(main_nav_hide_timer);
	}
    }

    prevScrollTop = scrollTop;
});
$(document).ready(function(){	
	$('#more_dd').click(function (e) {
	  e.preventDefault()
	});

	$('.bc_goto_top a').click(function(){
	$("html, body").animate({ scrollTop: 0 }, 600);
	return false;
	});
	jQuery('.bc_login_btn').on('click', function() { 
    jQuery('.bc_popup').fadeIn("slow");
  });
	jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });
  

});
$('#bc_drop_tab a').hover(function (e) {
  e.preventDefault()
  $(this).tab('show')
})

$(document).mouseup(function (e)
{
    var container = $(".bc_login_form");

    if (!container.is(e.target) // if the target of the click isn't the container...
        && container.has(e.target).length === 0 && $('.bc_popup').css('display') =='block') // ... nor a descendant of the container
    {
        jQuery('.bc_popup').fadeOut("slow");
    }
});
if($(window).width() < 767)
{ 
	$(".nav-menu").on('click','li', function(){
	$(this).toggleClass('active').siblings().removeClass('active');
 })
}
</script>
<section class="cz-popup">
<div class="cz-popup-wrapp">
<a class="cz-popup-close" href="javascript:;" title="Close"> <i class="fa fa-times"></i> </a>
<h4>Reporter</h4>
<div class="cz-popup-inner-wrapp">
<h6>Help us understand the problem. What is going on with this comment?</h6>
<form>
<input type="hidden" id="comment-id-report" value="0">
<ul>
<li>
<label><input type="radio" name="comment-report-reason" value="Spam">Spam</label>
</li>
<li>
<label><input type="radio" name="comment-report-reason" value="Abusive or Harmful">Abusive or Harmful</label>
</li>
<li>
<label><input type="radio" name="comment-report-reason" value="Inappropriate content">Inappropriate content</label>
</li>
<li>
<label><input type="radio" name="comment-report-reason" value="Strong language">Strong language</label>
</li>
<li>
<label><input type="radio" name="comment-report-reason" value="Other">Other</label>
</li>
<li id="comment-report-other-reason-wrap" style="display:none;">
<textarea rows="2" cols="2" id="comment-report-other-reason"></textarea>
</li>
</ul>
<p><a href="https://www.bleepingcomputer.com/posting-guidelines/">Learn more</a> about what is not allowed to be posted.</p>
</form>
</div>
<div class="cz-popup-bottom-wrapp">
<div class="cz-popup-report-submiting" style="display:none;">Submitting...</div>
<a href="#" class="cz-next-btn comment-report-submit-btn">SUBMIT</a>
</div>
</div>
</section>
<noscript id="deferred-styles">
        
	<link href="https://www.bleepstatic.com/css/redesign/font-awesome.css" rel="stylesheet" type="text/css" media="all">
    </noscript>
<script>
      var loadDeferredStyles = function() {
        var addStylesNode = document.getElementById("deferred-styles");
        var replacement = document.createElement("div");
        replacement.innerHTML = addStylesNode.textContent;
        document.body.appendChild(replacement)
        addStylesNode.parentElement.removeChild(addStylesNode);
      };
      var raf = requestAnimationFrame || mozRequestAnimationFrame ||
          webkitRequestAnimationFrame || msRequestAnimationFrame;
      if (raf) raf(function() { window.setTimeout(loadDeferredStyles, 0); });
      else window.addEventListener('load', loadDeferredStyles);
    </script>
<script type="text/javascript" async src="//s9.addthis.com/js/300/addthis_widget.js#pubid=ra-561517d2c7f964d6&domready=1"></script>
</body>
</html>