<!doctype html>
<html lang="en-us">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<!-- Fonts -->
<link href='https://fonts.googleapis.com/css?family=Roboto:400,100,300,500,700,900' rel='stylesheet' type='text/css'>

<!-- Style sheet -->
<link href="https://www.bleepstatic.com/css/redesign/font-awesome.css" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/bootstrap.css" rel="stylesheet" type="text/css" media="all">

<link href="https://www.bleepstatic.com/css/redesign/main.css" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/home.css" rel="stylesheet" type="text/css" media="screen"><link href="https://www.bleepstatic.com/css/redesign/news.css" rel="stylesheet" type="text/css" media="screen,print">
<link rel="stylesheet" href="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.css?v=2.1.5" type="text/css" media="screen" />

<!-- Meta -->
<meta name="Owner" content="Lawrence Abrams/BleepingComputer.com" />
<link rel="shortcut icon" href="https://www.bleepstatic.com/favicon/bleeping.ico" />
<meta http-equiv="Pragma" content="no-cache" />
<META NAME="ROBOTS" CONTENT="NOODP" />
<meta property="og:site_name" content="BleepingComputer" />
<meta property="og:locale" content="en_us" />
<meta name="application-name" content="BleepingComputer"/>
<title>KillDisk Ransomware Now Targets Linux, Prevents Boot-Up, Has Faulty Encryption</title>
<meta name="Description" content="Researchers have discovered a Linux variant of the KillDisk ransomware, which itself is a new addition to the KillDisk disk wiper malware family, previously used only to sabotage companies by randomly deleting data and altering files." />
<meta name="Abstract" content="Researchers have discovered a Linux variant of the KillDisk ransomware, which itself is a new addition to the KillDisk disk wiper malware family, previously used only to sabotage companies by randomly deleting data and altering files." />
<meta name="Keywords" content="computers, windows, linux, mac, support, tech support, spyware, malware, virus, security, KillDisk, Linux, Ransomware,virus removal, malware removal, computer help, technical support" />
<link rel="canonical" href="https://www.bleepingcomputer.com/news/security/killdisk-ransomware-now-targets-linux-prevents-boot-up-has-faulty-encryption/" />
<link rel="prev" href="https://www.bleepingcomputer.com/news/hardware/google-and-samsung-release-touchscreen-enabled-chromebook-that-runs-android-apps/" />
<link rel="next" href="https://www.bleepingcomputer.com/news/security/number-of-hijacked-mongodb-databases-is-going-up-as-more-hackers-are-flocking-in/" />
<meta name="news_keywords" content="KillDisk, Linux, Ransomware, Security, InfoSec, Computer Security">

<meta property="og:type" content="article" />
<meta property="og:title" content="KillDisk Ransomware Now Targets Linux, Prevents Boot-Up, Has Faulty Encryption" />
<meta property="og:url" content="https://www.bleepingcomputer.com/news/security/killdisk-ransomware-now-targets-linux-prevents-boot-up-has-faulty-encryption/" />
<meta property="og:image" content="https://www.bleepstatic.com/content/posts/2017/01/05/KillDisk-Linux.png" />
<meta property="og:description" content="Researchers have discovered a Linux variant of the KillDisk ransomware, which itself is a new addition to the KillDisk disk wiper malware family, previously used only to sabotage companies by randomly deleting data and altering files." />
<meta property="fb:app_id" content="517620508265293" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@BleepinComputer" />
<meta name="twitter:creator" content="@BleepinComputer" />
<meta name="twitter:title" content="KillDisk Ransomware Now Targets Linux, Prevents Boot-Up, Has Faulty Encryption" />
<meta name="twitter:description" content="Researchers have discovered a Linux variant of the KillDisk ransomware, which itself is a new addition to the KillDisk disk wiper malware family, previously used only to sabotage companies by randomly deleting data and altering files." />
<meta name="twitter:image" content="https://www.bleepstatic.com/content/posts/2017/01/05/KillDisk-Linux.png" />

<link href="https://plus.google.com/112790257026281352252" rel="publisher" />
<LINK REL="alternate" TITLE="Bleeping Computer's News" HREF="https://www.bleepingcomputer.com/feed/" TYPE="application/rss+xml">

<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/jquery-1.11.1.min.js"></script>
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/bleep.js?t=1483854174"></script>


<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/news.js"></script>
<script type="text/javascript" id="nsgpt" data-channel="homepage" src="//cdn.nsstatic.net/ns/bleepingcomputer.com.js" async="true" data-oop=""></script>

<!--BEGIN FIRSTIMPRESSION TAG -->
<script data-cfasync='false' type='text/javascript'>
	window.apd_options = { 'websiteId': 5971, 'runFromFrame': false };
	(function() {
		var w = window.apd_options.runFromFrame ? window.top : window;
		if(window.apd_options.runFromFrame && w!=window.parent) w=window.parent;
		if (w.location.hash.indexOf('apdAdmin') != -1){if(typeof(Storage) !== 'undefined') {w.localStorage.apdAdmin = 1;}}
		var adminMode = ((typeof(Storage) == 'undefined') || (w.localStorage.apdAdmin == 1));
		w.apd_options=window.apd_options;
		var apd = w.document.createElement('script'); apd.type = 'text/javascript'; apd.async = true;
		apd.src = '//' + (adminMode ? 'cdn' : 'ecdn') + '.firstimpression.io/' + (adminMode ? 'fi.js?id=' + window.apd_options.websiteId : 'fi_client.js') ;
		var s = w.document.getElementsByTagName('head')[0]; s.appendChild(apd);
	})();</script>
<!-- END FIRSTIMPRESSION TAG -->

<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  googletag.cmd.push(function() {
    
    googletag.defineSlot('/1006593/ROS_Side_2', [[300, 600], [300, 250]], 'div-gpt-ad-1474727680612-0').addService(googletag.pubads());
 
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

</head>

<body>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N3FCGQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N3FCGQ');</script>
<!-- End Google Tag Manager -->


<div class="bc_wrapper">

<!-- Start Header Section -->

<header>
	<div class="container">
    	<div class="row">
        	<div class="col-md-4">
            	<a class="bc_logo" href="https://www.bleepingcomputer.com/"><img src="https://www.bleepstatic.com/images/site/logo.png" alt=""></a>
            </div>
            <div class="col-md-8">
            	<ul class="bc_social_icons">
                    <li><a href="https://www.facebook.com/BleepingComputer"><i class="fa fa-facebook"></i></a></li>
                    <li><a href="https://twitter.com/BleepinComputer"><i class="fa fa-twitter"></i></a></li>
                    <li><a href="https://plus.google.com/+bleepingcomputer/posts"><i class="fa fa-google-plus"></i></a></li>
                    <li><a href="/feed/"><i class="fa fa-rss"></i></a></li>
                </ul>
                <div class="bc_search_box">
                    <form action="https://www.bleepingcomputer.com/search/">
			<input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228" />
			<input type="hidden" name="cof" value="FORID:10" />
			<input type="hidden" name="ie" value="UTF-8" />
                        <input type="search" name="q" placeholder="Search Site" />
                    </form>
		    <script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
                </div>
                                <div class="bc_login">
	            <input type="submit" value="Login" class="bc_login_btn">
                    <input type="submit" value="Sign up" class="bc_signup_btn" onclick="window.location='https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register';" />
                </div>
            </div>
        </div>
    </div>


 <!-- Start Navigation -->
    
    <nav class="bc_navigation">
    	<div class="container">
               <span id="toggle-nav" class="toggle-site-nav">
                	<span></span>
                </span>
            	<div class="site-nav" id="nav" role="navigation">
                    <ul class="bc_social_icons bc_mob">
                        <li><a href="https://www.facebook.com/BleepingComputer"><i class="fa fa-facebook"></i></a></li>
                        <li><a href="https://twitter.com/BleepinComputer"><i class="fa fa-twitter"></i></a></li>
                        <li><a href="https://plus.google.com/+bleepingcomputer/posts"><i class="fa fa-google-plus"></i></a></li>
                        <li><a href="/feed/"><i class="fa fa-rss"></i></a></li>
                    </ul>
                    <div class="bc_search_box bc_mob">
                        <form action="https://www.bleepingcomputer.com/search/">
                         <input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228" />
                         <input type="hidden" name="cof" value="FORID:10" />
                         <input type="hidden" name="ie" value="UTF-8" />
                         <input type="search" name="q" placeholder="Search Site" />
                        </form>
                        <script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
                    </div>
                    		    <div class="bc_login bc_mob">
                        <input type="submit" value="Login" class="bc_login_btn">
                        <input type="submit" value="Sign up" class="bc_signup_btn">
                    </div>

                      <ul class="nav-menu">
			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/">News</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#nfeatured" role="tab" data-toggle="tab">Featured</a></li>

                                    <li><a href="#nlatest" role="tab" data-toggle="tab">Latest</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="nfeatured">
                                        <ul>
					  
                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/mongodb-apocalypse-is-here-as-ransom-attacks-hit-10-000-servers/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2017/01/03/thumb/211x130_MongoDB-Logo.jpg" alt="">
                                                 <p>MongoDB Apocalypse Is Here as Ransom Attacks Hit 10,000 Servers</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/browser-autofill-profiles-can-be-abused-for-phishing-attacks/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/01/06/thumb/211x130_Thumbnail.png" alt="">
                                                 <p>Browser Autofill Profiles Can Be Abused for Phishing Attacks</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/google/google-bans-adnauseam-from-chrome-the-ad-blocker-that-clicks-on-all-ads/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/01/06/thumb/211x130_AdNauseam.png" alt="">
                                                 <p>Google Bans AdNauseam from Chrome, the Ad Blocker That Clicks on All Ads</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/firecrypt-ransomware-comes-with-a-ddos-component/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/01/04/thumb/211x130_ransomware-builder-page-1.png" alt="">
                                                 <p>FireCrypt Ransomware Comes With a DDoS Component</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="nlatest">
                                        <ul>
					  
                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/crooks-cold-calling-uk-schools-and-tricking-staff-into-installing-ransomware/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2017/01/07/thumb/211x130_RansomedPC.png" alt="">
                                                 <p>Crooks Cold-Calling UK Schools and Tricking Staff Into Installing Ransomware</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/mongodb-apocalypse-is-here-as-ransom-attacks-hit-10-000-servers/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2017/01/03/thumb/211x130_MongoDB-Logo.jpg" alt="">
                                                 <p>MongoDB Apocalypse Is Here as Ransom Attacks Hit 10,000 Servers</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/mobile/google-patches-security-holes-in-android-bootloader-for-nexus-devices/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/01/06/thumb/211x130_Nexus.jpg" alt="">
                                                 <p>Google Patches Security Holes in Android Bootloader for Nexus Devices</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/the-week-in-ransomware-january-6th-2017-fsociety-mongodb-pseudo-darkleech-and-more/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2016/03/10/thumb/211x130_security-lock-292-170.png" alt="">
                                                 <p>The Week in Ransomware - January 6th 2017 - FSociety, MongoDB, Pseudo-Darkleech, and More</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/download/">Downloads</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#dlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#most" role="tab" data-toggle="tab">Most Downloaded</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="dlatest">
                                        <ul>
					  
                                            <li>
						<a href="https://www.bleepingcomputer.com/download/potplayer/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/172-potplayer.jpg" alt="">
                                                 <p class="center">PotPlayer</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/rainmeter-desktop-customization-tool/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/171-rainmeter-desktop-customization-tool.jpg" alt="">
                                                 <p class="center">Rainmeter Desktop Customization Tool</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/chrome-cleanup-tool/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/170-chrome-cleanup-tool.jpg" alt="">
                                                 <p class="center">Chrome Cleanup Tool</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/crypt38decrypter/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/169-crypt38decrypter.jpg" alt="">
                                                 <p class="center">Crypt38Decrypter</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="most">
                                        <ul>
					  
                                            <li>
						<a href="/download/adwcleaner/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/96-adwcleaner.jpg" alt="">
                                                 <p class="center">AdwCleaner</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/combofix/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/9-combofix.jpg" alt="">
                                                 <p class="center">ComboFix</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/rkill/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/8-rkill.jpg" alt="">
                                                 <p class="center">RKill</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/junkware-removal-tool/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/98-junkware-removal-tool.jpg" alt="">
                                                 <p class="center">Junkware Removal Tool</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#vlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#vmost" role="tab" data-toggle="tab">Most Viewed</a></li>

                                    <li><a href="#ransomware" role="tab" data-toggle="tab">Ransomware</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="vlatest">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/remove-easychrome-chrome-extension-adware">
                                                 <img src="https://www.bleepstatic.com/swr-guides/e/easychrome/easychrome-thmb-350.png" alt="">
                                                 <p>Remove the Easychrome Adware Extension (Removal Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-qtipr.com-browser-hijacker">
                                                 <img src="https://www.bleepstatic.com/swr-guides/q/qtipr.com/qtipr.com-thmb-350.png" alt="">
                                                 <p>Remove the Qtipr.com Browser Hijacker (Removal Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-antivirus-10">
                                                 <img src="https://www.bleepstatic.com/swr-guides/a/antivirus-10/antivirus-10-thmb-350.png" alt="">
                                                 <p>How to Remove Antivirus 10 (Removal Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-ms-office-activation-tech-support-scam">
                                                 <img src="https://www.bleepstatic.com/swr-guides/m/fake-microsoft-office-activation-wizard/microsoft-office-activation-wizard-1-thmb-350.png" alt="">
                                                 <p>Microsoft Office Activation Wizard Tech Support Scam Removal Guide</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="vmost">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/remove-security-tool">
                                                 <img src="https://www.bleepstatic.com/swr-guides/s/securitytool/security-tool-thmb-350.jpg" alt="">
                                                 <p>Remove Security Tool and SecurityTool (Uninstall Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/uninstall-antivirus-2009">
                                                 <img src="https://www.bleepstatic.com/swr-guides/a/antivirus-2009/antivirus-2009-thmb-350.jpg" alt="">
                                                 <p>How to remove Antivirus 2009 (Uninstall Instructions)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-vundo-virtumonde">
                                                 <img src="https://www.bleepstatic.com/images/site/navigation/generic-chalkboard-211x130.jpg" alt="">
                                                 <p>How to Remove WinFixer / Virtumonde / Msevents / Trojan.vundo</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-tdss-tdl3-alureon-rootkit-using-tdsskiller">
                                                 <img src="https://www.bleepstatic.com/swr-guides/tools/tdsskiller/tdsskiller-start-thmb-350.jpg" alt="">
                                                 <p>How to remove Google Redirects or the TDSS, TDL3, or Alureon rootkit using TDSSKiller</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="ransomware">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/cryptolocker-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/cryptolocker/CryptoLocker-thmb-350.jpg" alt="">
                                                 <p>CryptoLocker Ransomware Information Guide and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptorbit-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/cryptorbit/howdecrypt-thmb-350.gif" alt="">
                                                 <p>CryptorBit and HowDecrypt Information Guide and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptodefense-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/CryptoDefense/how_decrypt-html-thmb-350.jpg" alt="">
                                                 <p>CryptoDefense and How_Decrypt Ransomware Information Guide and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptowall-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/cryptowall/html-file-thmb-350.jpg" alt="">
                                                 <p>CryptoWall and HELP_DECRYPT Ransomware Information Guide and FAQ</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#tlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#popular" role="tab" data-toggle="tab">Popular</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="tlatest">
                                        <ul>
					  
                                            <li>
						<a href="/tutorials/close-a-program-using-task-manager/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/313-task-manager.png" alt="">
                                                 <p>How to close a program using Task Manager</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/find-license-agreement-for-installed-version-of-windows/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/312-header-image.jpg" alt="">
                                                 <p>How to find the License Agreement for the Installed version of Windows</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-recover-files-and-folders-using-shadow-volume-copies/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/311-shadow-explorer-export.png" alt="">
                                                 <p>How to recover files and folders using Shadow Volume Copies</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-show-and-hide-line-numbers-in-notepad-plus-plus/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/310-notepad-plus-plus.png " alt="">
                                                 <p>How to show and hide line numbers in Notepad++</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="popular">
                                        <ul>
					  
                                            <li>
						<a href="/tutorials/how-to-start-windows-in-safe-mode/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/61-safe-mode.jpg" alt="">
                                                 <p>How to start Windows in Safe Mode</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-remove-a-trojan-virus-worm-or-malware/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/2/101-remove-virus.jpg" alt="">
                                                 <p>How to remove a Trojan, Virus, Worm, or other Malware</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/show-hidden-files-in-windows-7/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/3/151-win-7-show-hidden.jpg" alt="">
                                                 <p>How to show hidden files in Windows 7</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-see-hidden-files-in-windows/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/62-show-hidden-files.jpg" alt="">
                                                 <p>How to see hidden files in Windows</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://deals.bleepingcomputer.com/">Deals</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#dcategories" role="tab" data-toggle="tab">Categories</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane" id="bsellers">
                                        <ul>
					  
                                            <li>
						<a href="http://deals.bleepingcomputer.com/sales/it-security-and-ethical-hacking">
                                                 <img src="https://www.bleepstatic.com/content/deals/2016/04/05/211x130_4cd72a46477bdb86c015aafc1cf73ab55d774ee3_main_hero_image[1].jpg" alt="">
                                                 <p>IT Security & Ethical Hacking Certification Training</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="deal_latest">
                                        <ul>
					  
                                        </ul>
                                    </div>

<div role="tabpanel" class="tab-pane active" id="dcategories">
                                        <ul>
					  
                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/elearning?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/elearning-nav.jpg" alt="eLearning Image">
                                                 <p align='center'>eLearning</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/certifications?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/it-certification-nav.jpg" alt="IT Certification Courses Image">
                                                 <p align='center'>IT Certification Courses</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/gear-gadgets?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/gear-gadgets-nav.jpg" alt="Gear &amp; Gadgets Image">
                                                 <p align='center'>Gear + Gadgets</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/collections/tag-cyber-security?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/security-nav.jpg" alt="Security Image">
                                                 <p align='center'>Security</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

                        <li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
                        <li class="bc_dropdown bc_more_nav"><a id="more_dd" href="#">More</a>
                        	<ul id="bc_more-nav" class="bc_more_submenu">
                              <li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
			      <li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
                              <li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
                              <li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
                              <li><a href="https://www.bleepingcomputer.com/chat/">Chat on IRC</a></li>
			      <li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
                            </ul>
                        </li>
                     </ul>
           		</div>
         </div>
    </nav>
 </header>   
<!-- End Header Section -->

<section class="cz-oa-wrapp">
  <div class="container">
    <div class="row">
      <div class="col-md-12">
        <div class="cz-toa-wrapp">
	 
 <div data-ns="billboard" data-pos="atf" data-collapse="true"></div>

        </div>
      </div>
    </div>
  </div>
</section>

<section>
  <div class="container">
    <div class="row">
      <div class="col-md-12">
        <div class="cz-breadcrumb-outer-wrapp">
          <div class="cz-breadcrumb-left-area">
            <div class="cz-breadcrumb">
              <ul itemscope itemtype="http://schema.org/BreadcrumbList">
                <li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bleepingcomputer.com/" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/" itemprop="item">News</a></span><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/security/" itemprop="item">Security</a></span><meta itemprop="position" content="3" /></li><li class="active" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name">KillDisk Ransomware Now Targets Linux, Prevents Boot-Up, Has Faulty Encryption</span></li>
              </ul>
            </div>
          </div>
          <div class="cz-breadcrumb-right-area">
            <div class="cz-like-wrapper">
              <ul>
                <li><div class="addthis_sharing_toolbox"></div></li>
	                        <li class="cz-print-icon"><a href="#">&nbsp;</a></li>
              </ul>
            </div>
          </div>
        </div>
      </div>
    </div>
  </div>
</section>
<!-- Start Content Section -->

<section class="bc_main_content">
  <div class="container">
    <div class="row">
      <div class="col-md-8">
        <div class="cz-main-left-section">
         
	 <div itemscope itemtype="http://schema.org/NewsArticle" class="article_section">
          <h2 itemprop="headline">KillDisk Ransomware Now Targets Linux, Prevents Boot-Up, Has Faulty Encryption</h2>
          <div class="cz-news-story-title-section">
            <div class="cz-news-title-left-area">
              By <h6><a rel='author' href='https://www.bleepingcomputer.com/author/catalin-cimpanu/' class='author'><span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name">Catalin Cimpanu</span></span></a></h6>
            </div>
	    <meta itemprop="articleSection" content="Security">
            <div class="cz-news-title-right-area">
	      <span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><meta itemprop="name" content="BleepingComputer.com"></span>
	      <span itemprop="datePublished" content="2017-01-05T10:50:22-05:00"></span>
              <ul>
                <li class="cz-news-date">January 5, 2017</li>
                <li class="cz-news-time">10:50 AM</li>
                
                <li class="cz-news-comment"><a href="#comments">2</a></li>
              </ul>
            </div>
          </div>
	  <meta itemprop="image" content="https://www.bleepstatic.com/content/posts/2017/01/05/KillDisk-Linux.png">
	  <span itemprop="articleBody" class="articleBody">
	   <p>Researchers have discovered a Linux variant of the KillDisk ransomware, which itself is a new addition to the KillDisk disk wiper malware family, previously used only to sabotage companies by randomly deleting data and altering files.</p>

<p>The KillDisk ransomware that targets Linux computers was <a href="http://www.welivesecurity.com/2017/01/05/killdisk-now-targeting-linux-demands-250k-ransom-cant-decrypt/" rel="nofollow" target="_blank">discovered by ESET</a> a week after researchers from CyberX came across t<a href="https://www.bleepingcomputer.com/news/security/killdisk-disk-wiping-malware-adds-ransomware-component/" target="_blank">he first KillDisk versions</a> that included ransomware features, but which only targeted Windows PCs.</p>

<h2>Linux version fumbles the encryption key</h2>

<p>According to the ESET researchers, the way the KillDisk ransomware version work on Windows and Linux is completely different, with the biggest issue being that on Linux, KillDisk doesn&#39;t save the encryption key anywhere on disk or online.</p>

<p>Normally, this would mean that victims would never be able to recover files since the encryption key would be lost immediately after the encryption process ends.</p>

<p>The good news is that ESET researchers say they&#39;ve uncovered a flaw in the Linux variant that permits them to recover the encrypted files. The same weakness does not exist in the version that targets Windows PCs.</p>

<h2>KillDisk ransomware, Windows variant</h2>

<p>The KillDisk ransomware variant that targets Windows machines worked by encrypting each file via an AES-256 key, and then encrypting the AES keys with a public RSA-1028 key.</p>

<p>A private RSA key stored on the crook&#39;s server allowed attackers to decrypt the victim&#39;s files, but only after victims paid a humongous ransom of 222 Bitcoin (~$215,000). A screenshot of the Windows version&#39;s ransom screen is available below.</p>

<div style="text-align:center">
<figure class="image" style="display:inline-block"><img alt="KillDisk Windows ransomware ransom note" height="455" src="https://www.bleepstatic.com/images/news/u/986406/Ransomware/KillDisk/killdisk-ransom.jpg" width="1250" />
<figcaption>KillDisk Windows ransomware ransom note (via CyberX)</figcaption>
</figure>
</div>

<p>Crooks received the encryption keys on their servers via the Telegram protocol, used for the eponymous IM chat app. Because of this, CyberX named the operators of this ransomware campaign as the TeleBots group.</p>

<h2>KillDisk ransomware, Linux variant</h2>

<p>The Linux variant spotted by ESET researchers during the past week is very different from the Windows variant.</p>

<p>First and foremost, the Linux version does not talk to its C&amp;C server via the Telegram API anymore. The encryption is also different.</p>

<p>According to researchers, the victim&#39;s &quot;files are encrypted using Triple-DES applied to 4096-byte file blocks,&quot; and &quot;each file is encrypted using a different set of 64-bit encryption keys.&quot;</p>

<p>The Linux variant targets the following folders, at a depth of 17 subfolders, encrypting all files and appending the &quot;DoN0t0uch7h!$CrYpteDfilE&quot; termination.</p>

<pre>
<code>/boot
/bin
/sbin
/lib/security
/lib64/security
/usr/local/etc
/etc
/mnt
/share
/media
/home
/usr
/tmp
/opt
/var
/root</code></pre>

<p>The KillDisk Linux ransomware will also rewrite the user&#39;s boot sector and will use the GRUB bootloader to show its ransom screen.</p>

<p>The ransom note is word for word identical with the one shown in the Windows version, including the email address where victims can reach out to crooks.</p>

<div style="text-align:center">
<figure class="image" style="display:inline-block"><img alt="KillDisk Linux ransomware ransom note" height="370" src="https://www.bleepstatic.com/images/news/u/986406/Ransomware/KillDisk/KillDisk-Linux.png" width="740" />
<figcaption>KillDisk Linux ransomware ransom note (via ESET)</figcaption>
</figure>
</div>

<p>Before going the route of ransomware, KillDisk had been used solely in cyber-espionage and cyber-sabotage operations.</p>

<p>The most notorious attacks using KillDisk involved deleting system files, replacing data files, and rewriting file extensions.</p>

<p>In November 2015, KillDisk was used in attacks against a Ukrainian news media agency. In December 2015, KillDisk was used to sabotage Ukraine&#39;s power grid. A cyber-espionage group known as BlackEnergy is suspected of being behind the attacks.</p>

<p>In December 2016, the TeleBots group used the KillDisk Windows ransomware to attack Ukrainian banks. At the time of writing, there is no evidence to link the TeleBots group with BlackEnergy.</p>

<h2>Ransomware features used as a decoy?</h2>

<p>In all attacks, BlackEnergy had used KillDisk to destroy computers and erase evidence of their attacks, perpetrated with other malware families.</p>

<p>The newly added ransomware features may be another way to mask their attacks, with companies thinking they might have been hit by ransomware, and not investigate the intrusions for other clues.</p>

<p>The ransomware&#39;s huge ransom demand also plays in with this scenario as it&#39;s absurd to think that a company might pay this much to recover their files.</p>

<p>The TeleBots gang may be hoping that companies give up on their files. By doing so, other signs and clues of the group&#39;s intrusions would remain lost and encrypted forever.</p>

	  </span>
         </div>
          <div class="asa">
 
<script type="text/javascript"><!--
google_ad_client = "ca-pub-3249370012249755";
/* News - After Story */
google_ad_slot = "5975899204";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

</div>

	  
          <div class="cz-news-tags-wrap">
            <ul>
	     
              <li><a href="https://www.bleepingcomputer.com/tag/killdisk/">KillDisk</a></li>

              <li><a href="https://www.bleepingcomputer.com/tag/linux/">Linux</a></li>

              <li><a href="https://www.bleepingcomputer.com/tag/ransomware/">Ransomware</a></li>

            </ul>
          </div>

          <div class="cz-news-like-wrapp">
            <div class="addthis_toolbox addthis_default_style addthis_32x32_style">
             <div class="cz-news-like-left-area">
              <ul>
               <li><a class="addthis_button_facebook"></a></li>
               <li><a class="addthis_button_twitter"></a></li>
               <li><a class="addthis_button_google_plusone_share"></a></li>
               <li><a class="addthis_button_linkedin"></a></li>
              </ul>
             </div>
             <div class="cz-news-like-right-area">
              <ul>
                
                <li><a class="addthis_button_email"></a></li>
                <li class="cz-lg-print-icon"><a href="#"></a></li>
              </ul>
             </div>
            </div>
          </div>
	            <div class="cz-full-bio-wrapp">
            <div class="cz-full-bio-img-wrapp">
		<a style="background-image:url('https://www.bleepstatic.com/author/photos/e1bde5ed1bb1075346983638c8e177b2.png');" class="author-img" href="https://www.bleepingcomputer.com/author/catalin-cimpanu/"></a>
            </div>
            <div class="cz-full-bio-content-wrapp">
              <h5><a href="https://www.bleepingcomputer.com/author/catalin-cimpanu/" target="_blank">Catalin Cimpanu</a> <span> <a href="mailto:catalin@bleepingcomputer.com"><i class="fa fa-envelope email"></i></a>  <a href="https://twitter.com/campuscodi" target="_blank"><i class="fa fa-twitter twitter"></i></a></span></h5>
              Catalin covers various topics such as data breaches, software vulnerabilities, exploits, hacking news, the Dark Web, programming topics, social media, web technology, product launches, and a few more.
            </div>
          </div>

          
          <div class="cz-story-navigation">
            <ul>
	                    <li><a href="https://www.bleepingcomputer.com/news/hardware/google-and-samsung-release-touchscreen-enabled-chromebook-that-runs-android-apps/"><i class="fa fa-chevron-left"></i> Previous Article </a></li>

              <li><a href="https://www.bleepingcomputer.com/news/security/number-of-hijacked-mongodb-databases-is-going-up-as-more-hackers-are-flocking-in/">Next Article <i class="fa fa-chevron-right"></i></a></li>

            </ul>
          </div>

          
           <div class="cz-newz-comment-wrapp" id="comments">
            <h3>Comments</h3>
            <ul>
             
              <li id="cid4241" itemscope itemtype="http://schema.org/UserComments">
                <div class="cz-newz-comment-inner-wrappper">
                  <div class="cz-newz-comment-img-wrappper"> <img alt="SleepyDude Photo" src="https://www.bleepingcomputer.com/forums/uploads/profile/photo-123997.jpg?_r=0"> </div>
                  <div class="cz-newz-comment-content-wrappper">
                    <div class="cz-newz-comment-title-wrapp">
                      <div class="cz-newz-title-left-area">
                        <data itemprop="name" content="SleepyDude" />
			<data itemprop="commentTime" content="2017-01-05T11:15" />
                        <h6>
                        <a href="https://www.bleepingcomputer.com/forums/u/123997/sleepydude/" target="_blank">SleepyDude</a> <span> -  2 days ago</span> </h6></div>
                      <div class="cz-newz-title-right-area">
                        <ul>
			  
                          
                          
                          <li><a class="cz-news-report cz-comment-report-btn" href="#" title='Report' data-id="4241">&nbsp;</a></li>
                          <li><a class="cz-news-link" href="#cid4241" title='Link'>&nbsp;</a></li>

                        </ul>
                      </div>
                    </div>
                    <p id="comment_html_4241" itemprop="commentText">Any idea how this gets installed on the Linux machine? manual hacking?</p>
                  </div>
                </div>
              </li>


              <li id="cid4242" itemscope itemtype="http://schema.org/UserComments">
                <div class="cz-newz-comment-inner-wrappper  cz-second-comment">
                  <div class="cz-newz-comment-img-wrappper"> <img alt="SidMax Photo" src="https://www.bleepingcomputer.com/forums/public/style_images/mobile/profile/default_large.png"> </div>
                  <div class="cz-newz-comment-content-wrappper">
                    <div class="cz-newz-comment-title-wrapp">
                      <div class="cz-newz-title-left-area">
                        <data itemprop="name" content="SidMax" />
			<data itemprop="commentTime" content="2017-01-05T11:50" />
                        <h6>
                        <a href="https://www.bleepingcomputer.com/forums/u/752893/sidmax/" target="_blank">SidMax</a> <span> -  2 days ago</span> </h6></div>
                      <div class="cz-newz-title-right-area">
                        <ul>
			  
                          
                          
                          <li><a class="cz-news-report cz-comment-report-btn" href="#" title='Report' data-id="4242">&nbsp;</a></li>
                          <li><a class="cz-news-link" href="#cid4242" title='Link'>&nbsp;</a></li>

                        </ul>
                      </div>
                    </div>
                    <p id="comment_html_4242" itemprop="commentText">Most likely. However, hacking PPAs might be another way to distribute the ransomware.</p>
                  </div>
                </div>
              </li>


            </ul>
           </div>
          
          <div class="cz-post-comment-wrapp">
       	    <h5>Post a Comment <span><a href="https://www.bleepingcomputer.com/forum-rules/" target="_blank">Community Rules</a></span></h5>
            <div class="cz-comment-loggin-wrapp">
              	<h6>You need to login in order to post a comment</h6>
                <input type="submit" value="Login" class="bc_login_btn cz-green-bttn">
		<p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
              </div>
          </div>

          
          <div class="cz-related-article-wrapp">
            <h3>You may also like</h3>
            <ul class="bc_suggested_article">
	     
              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/android-ransomware-infects-lg-smart-tv/">
                  <img src="https://www.bleepstatic.com/content/posts/2016/12/28/thumb/170x170_DarrenCauthonTV.jpg" alt="Android Ransomware Infects LG Smart TV Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/android-ransomware-infects-lg-smart-tv/">Android Ransomware Infects LG Smart TV</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/ultrasound-tracking-could-be-used-to-deanonymize-tor-users/">
                  <img src="https://www.bleepstatic.com/content/posts/2017/01/03/thumb/170x170_Tor-Laptop.jpg" alt="Ultrasound Tracking Could Be Used to Deanonymize Tor Users Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/ultrasound-tracking-could-be-used-to-deanonymize-tor-users/">Ultrasound Tracking Could Be Used to Deanonymize Tor Users</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/firecrypt-ransomware-comes-with-a-ddos-component/">
                  <img src="https://www.bleepstatic.com/content/posts/2017/01/04/thumb/170x170_ransomware-builder-page-1.png" alt="FireCrypt Ransomware Comes With a DDoS Component Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/firecrypt-ransomware-comes-with-a-ddos-component/">FireCrypt Ransomware Comes With a DDoS Component</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/number-of-hijacked-mongodb-databases-is-going-up-as-more-hackers-are-flocking-in/">
                  <img src="https://www.bleepstatic.com/content/hl-images/2017/01/03/thumb/170x170_MongoDB-Logo.jpg" alt="Number of Hijacked MongoDB Databases Is Going Up as More Hackers Are Flocking In Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/number-of-hijacked-mongodb-databases-is-going-up-as-more-hackers-are-flocking-in/">Number of Hijacked MongoDB Databases Is Going Up as More Hackers Are Flocking In</a></h5>
                  </div>
                </div>
              </li>

	    </ul>
	  </div>

          


        </div>
      </div>
      
      <!--  side bar section    -->    
      <div class="col-md-4 bc_right_sidebar">
       
	<div class="s-ou-wrap">
 
 <div data-ns="portrait" data-pos="atf" data-collapse="true"></div>
 
</div>
	
<!-- gallery placeholder -->
<div id="tvp-gallery"></div>
<!-- gallery placeholder -->

	
	
	                <div class="bc_latest_topic">
                        <div class="cz-line-heading"><div class="cz-line-heading-inner">Latest forum topics</div></div>
                    <ul>
                        
                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/636810/chromium-and-other-problems/">
                                <div class="bc_topic_text">
                                  <p>Chromium and other problems.</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/1033266/joaomc22/">JoaoMC22</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/22/virus-trojan-spyware-and-malware-removal-logs/">Virus, Trojan, Spyware, and Malware Removal Logs</a>
                                </div>
                            </a>
                        </li>

                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/636809/hijackhost-help/">
                                <div class="bc_topic_text">
                                  <p>Hijack.Host Help</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/1033265/tmcjr/">Tmcjr</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/22/virus-trojan-spyware-and-malware-removal-logs/">Virus, Trojan, Spyware, and Malware Removal Logs</a>
                                </div>
                            </a>
                        </li>

                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/636808/csgo-random-restarts-now-random-bsods/">
                                <div class="bc_topic_text">
                                  <p>CSGO random restarts, now random BSOD&#39;s</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/1033264/rodeoman/">RodeoMan</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/233/windows-crashes-bsod-and-hangs-help-and-support/">Windows Crashes, BSOD, and Hangs Help and Support</a>
                                </div>
                            </a>
                        </li>

                    </ul>
                </div>
	
                <div class="bc_news_letter_sidebar">
                        <h4>Newsletter Sign Up</h4>
                    <p>To receive periodic updates and news from <a href="/">BleepingComputer</a>, please use the form below. </p>
                    <form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
                        <input type="email" name="EMAIL" placeholder="Email Address...">
                        <div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div>
                      <input type="submit" value="Submit" class="bc_sub_btn">
                    </form>
                </div>
	
        
	
	<div class="s-ou-wrap">
 
<!-- /1006593/ROS_Side_2 -->
<div id='div-gpt-ad-1474727680612-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1474727680612-0'); });
</script>
</div>

</div>
        
        <div class="bc_downloads">
          <div class="cz-line-heading"><div class="cz-line-heading-inner">Latest Downloads</div></div>
          <ul>
           
            <li> <a href="https://www.bleepingcomputer.com/download/windows-repair-all-in-one/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/09/19/icon1348083463.jpg" alt="Windows Repair (All In One) Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/windows-repair-all-in-one/">Windows Repair (All In One)</a></p>
                <span>Version: 3.9.21</span></div>
              <div class="bc_download_count"><strong>931,856 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/malwarebytes-anti-malware/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/12/28/icon1356707420.jpg" alt="Malwarebytes Anti-Malware Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/malwarebytes-anti-malware/">Malwarebytes Anti-Malware</a></p>
                <span>Version: 3.0.5</span></div>
              <div class="bc_download_count"><strong>4M+ <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/vt-hash-check/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/12/02/icon1354489628.png" alt="VT Hash Check Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/vt-hash-check/">VT Hash Check</a></p>
                <span>Version: 1.58</span></div>
              <div class="bc_download_count"><strong>13,340 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/calibre/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/09/20/icon1348167390.jpg" alt="Calibre Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/calibre/">Calibre</a></p>
                <span>Version: 0.8.69</span></div>
              <div class="bc_download_count"><strong>9,003 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/vba32-antirootkit/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/05/21/icon1337633033.png" alt="Vba32 AntiRootkit Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/vba32-antirootkit/">Vba32 AntiRootkit</a></p>
                <span>Version: NA</span></div>
              <div class="bc_download_count"><strong>39,011 <i>Downloads</i></strong></div>
              </a>
            </li>

          </ul>
        </div>

	
        <div class="s-ou-wrap" id="pinned">
 
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar Sticky Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-0920899300397823"
     data-ad-slot="2748485221"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div>
      </div>
    </div>
  </div>
</section>

<!-- End Content Section --> 
<section class="cz-boa-wrapp">
 <div class="container">
  <div class="row">
   <div class="col-md-12">
    
<div class="cz-advertise-wrapp">
 <script type="text/javascript"><!--
 google_ad_client = "ca-pub-3249370012249755";
 /* Homepage - Bottom */
 google_ad_slot = "1089300124";
 google_ad_width = 728;
 google_ad_height = 90;
 //-->
 </script>
 <script type="text/javascript"
 src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

   </div>
  </div>
 </div>
</section>
<!-- Start Footer Section -->

<footer id="footer">
	<div class="container">
    	<div class="row">
        	<div class="col-md-4">
            	<h5>Newsletter Sign Up</h5>
                    <form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
                        <input type="email" name="EMAIL" placeholder="Email Address...">
                        <div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div
>
                      <input type="submit" value="Submit" class="bc_sub_btn">
                    </form>
                <ul class="bc_social_icons">
                    <li>Follow us:</li>
                    <li><a href="https://www.facebook.com/BleepingComputer"><i class="fa fa-facebook"></i></a></li>
                    <li><a href="https://twitter.com/BleepinComputer"><i class="fa fa-twitter"></i></a></li>
                    <li><a href="https://plus.google.com/+bleepingcomputer/posts"><i class="fa fa-google-plus"></i></a></li>
                    <li><a href="https://www.bleepingcomputer.com/feed/"><i class="fa fa-rss"></i></a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Main Sections</h5>
                <ul>
                	<li><a href="https://www.bleepingcomputer.com/">News</a></li>
                    <li><a href="https://www.bleepingcomputer.com/download/">Downloads</a></li>
                    <li><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a></li>
                    <li><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a></li>
                    <li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Community</h5>
                <ul>
                  <li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
	   	  <li><a href="https://www.bleepingcomputer.com/forum-rules/">Forum Rules</a></li>
                  <li><a href="https://www.bleepingcomputer.com/chat/">Chat</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Useful Resources</h5>
                <ul>
                    <li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
		    <li><a href="https://www.bleepingcomputer.com/sitemap/">Sitemap</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Company</h5>
                <ul>
                    <li><a href="https://www.bleepingcomputer.com/about/">About BleepingComputer</a></li>
                    <li><a href="https://www.bleepingcomputer.com/contact/">Contact Us</a></li>
                    <li><a href="https://www.bleepingcomputer.com/advertise/">Advertising</a></li>
		    <li><a href="https://www.bleepingcomputer.com/write-for-bleepingcomputer/">Write for BleepingComputer</a></li>
                    <li><a href="https://www.bleepingcomputer.com/rss-feeds/">Social & Feeds</a></li>
		    <li><a href="https://www.bleepingcomputer.com/changelog/">Changelog</a></li>
                </ul>
            </div>
        </div>
    </div>
    <div class="bc_footer_bottom">
    	<div class="container">
        	<div class="row">
            	<div class="col-md-6">
                	 <p><a href="https://www.bleepingcomputer.com/user-agreement/">User Agreement</a>  - <a href="https://www.bleepingcomputer.com/privacy/"> Privacy Policy</a></p>
                </div>
                <div class="col-md-6 bc_copyright">
                	<p>Copyright @ 2003 - 2017 <a href="https://www.bleepingcomputer.com/"> Bleeping Computer<sup>&reg;</sup> LLC </a> -   All Rights Reserved</p>
                </div>
            </div>
        </div>
    </div>
</footer>
</div>
<!-- End Footer Section -->

<!-- Start Go to top Section -->

<div class="bc_goto_top">
    <a href="#"><i class="fa fa-chevron-up"></i></a>
</div> 
    
<!-- End Go to top Section -->


<!-- Start Popup Section -->

<div class="bc_popup">
	<div class="bc_login_form">
    	<a class="bc_popup_close" href="javascript:;" title="Close"></a>
        <h4>Login</h4>
        <form action="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;do=process&amp;return=https://www.bleepingcomputer.com/" method="post">
            <div class="bc_form_feild">
                <label>Username</label>
                <input type="text" name="ips_username"> 
            </div>
            <div class="bc_form_feild">
                <label>Password</label>
                <input type="password" name="ips_password">
            </div>
            <div class="bc_form_feild">
                <div class="bc_remember">
                    <input id="remember" type="checkbox" name="rememberMe" value="None" checked="checked">
                    <label for="remember"></label>
                    <span>Remember Me</span>
                </div>
                <div class="bc_anon">
                     <input id="anonymous" type="checkbox" name="anonymous" value="None">
                    <label for="anonymous"></label>
                    <span>Sign in anonymously</span>
                </div>
            </div>
            <div class="bc_btn_wrap">
		<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />
                <input type="submit" value="Login" class="bc_sub_btn">
                <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;serviceClick=facebook&amp;return=https://www.bleepingcomputer.com/news/security/killdisk-ransomware-now-targets-linux-prevents-boot-up-has-faulty-encryption/" class="bc_facebook_btn"><img src="https://www.bleepstatic.com/images/site/login/facebook.png" alt="Sign in with Facebook"> Sign in with Facebook</a>
                <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;serviceClick=twitter&amp;return=https://www.bleepingcomputer.com/news/security/killdisk-ransomware-now-targets-linux-prevents-boot-up-has-faulty-encryption/" class="bc_twitter_btn"><img src="https://www.bleepstatic.com/images/site/login/twitter.png" alt="Sign in with Twitter"> Sign in with Twitter</a>
		<hr />
                <p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
            </div>
        </form>
    </div>
</div>

<!-- End Popup Section -->
    

<!-- Script -->
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/bootstrap.js"></script>

<!-- tvpage code -->
<script type="text/javascript">
  window.TVPage = window.TVPage || {};
  window.TVPage.config = TVPage.config || {};
  window.TVPage.config['tvp-gallery'] = {

  };
  (function(d) {
    var s = d.createElement('script');
    s.src = '//www-bleeping-computer-com.tvpagecdn.com/dist/js/lib.js';
    d.body.appendChild(s);
  })(document);
</script>
<!-- tvpage code -->
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.js?v=2.1.5"></script>
<script type="text/jscript">
$(document).ready(function(e) {
    $('.articleBody img').not('a>img').not('.contrib_but>img').click(function(e) {
        e.preventDefault();
                 $.fancybox({'href' : $(this).attr('src')});
    });
});
</script>

<script src="//www.bleepstatic.com/js/fixto/fixto.min.js"></script>

<script type="text/javascript">
$(document).ready(function(){

var content = $('.cz-main-left-section');
var sidebar = $('.bc_right_sidebar');
var count = 0;
var myTimer;

function setEqualContainer() {
        var getContentHeight = content.outerHeight();
        var getSidebarHeight = sidebar.outerHeight();

        if ( getContentHeight > getSidebarHeight ) {
                sidebar.css('min-height', getContentHeight);
        }

        if ( getSidebarHeight > getContentHeight ) {
                content.css('min-height', getSidebarHeight);
        }
}

// creating the timer which will run every 500 milliseconds
// and will stop after the container will be loaded
// ...or after 15 seconds to not eat a lot of memory

myTimer = setInterval( function() {
        count++;

        if ( $('.testContainer').length == 0 ) {
                setEqualContainer();
        } else {
                setEqualContainer();
                clearInterval(myTimer);
        }

        if ( count == 15) {
                clearInterval(myTimer);
        }
}, 500);

        $('#pinned').fixTo('.bc_right_sidebar', {
                 top: 129
        });

        $('#more_dd').click(function (e) {
          e.preventDefault()
        });

        $('.bc_goto_top a').click(function(){
        $("html, body").animate({ scrollTop: 0 }, 600);
        return false;
        });
        jQuery('.bc_login_btn').on('click', function() {
    jQuery('.bc_popup').fadeIn("slow");
  });
        jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });

});
</script>
<script type="text/javascript">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</script>

<script type="text/javascript">
$('.cz-print-icon, .cz-lg-print-icon').click(function(e) {
    e.preventDefault();
    var divToPrint = document.getElementById('.article_section'); 
    var mywindow = window.open('','','left=0,top=0,width=950,height=600,toolbar=0,scrollbars=0,status=0,addressbar=0');

    var is_chrome = Boolean(mywindow.chrome);
    mywindow.document.write($( ".article_section" ).html());
    mywindow.document.close(); // necessary for IE >= 10 and necessary before onload for chrome

    if (is_chrome) {
        mywindow.onload = function() { // wait until all resources loaded 
            mywindow.focus(); // necessary for IE >= 10
            mywindow.print();  // change window to mywindow
            mywindow.close();// change window to mywindow
        };
    }
    else {
        mywindow.document.close(); // necessary for IE >= 10
        mywindow.focus(); // necessary for IE >= 10
        mywindow.print();
        mywindow.close();
    }

    return true;
});
</script>

<script type="text/javascript">

var loginhash = '880ea6a14ea49e853634fbdc5015a024';
var main_nav_hide_flag = true;
var scrollTop =0;
var main_nav_hide_timer = '';

function call_main_nav_hide()
{
 if(main_nav_hide_flag && scrollTop >=100)
 {
  $('header').addClass("nav-up");
 }
}
var cz_header_pos = $('header').offset().top;
$(window).scroll(function() {
	$('header').each(function(){
	var cz_top_of_window = $(window).scrollTop()-100;
		if (cz_top_of_window > cz_header_pos) {			
			$('.bc_goto_top').fadeIn("slow");
		} else {
			$('.bc_goto_top').fadeOut("slow");			
		}
	});

});
var prevScrollTop = 0;
$(window).scroll(function(event){
    scrollTop = $(this).scrollTop();

    if ( scrollTop < 0 ) {
        scrollTop = 0;
    }
    if ( scrollTop > $('body').height() - $(window).height() ) {
        scrollTop = $('body').height() - $(window).height();
    }

    if (scrollTop >= prevScrollTop && scrollTop) {
        $('header').addClass("nav-up");
    } else {
	if (scrollTop >=100)
	{
	 $('header').removeClass("nav-up"); 
	 main_nav_hide_timer = setTimeout("call_main_nav_hide()",5000);
	}
	else
	{
	 $('header').removeClass("nav-up");
	 clearInterval(main_nav_hide_timer);
	}
    }

    prevScrollTop = scrollTop;
});
$(document).ready(function(){	
	$('#more_dd').click(function (e) {
	  e.preventDefault()
	});

	$('.bc_goto_top a').click(function(){
	$("html, body").animate({ scrollTop: 0 }, 600);
	return false;
	});
	jQuery('.bc_login_btn').on('click', function() { 
    jQuery('.bc_popup').fadeIn("slow");
  });
	jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });
  

});
$('#bc_drop_tab a').hover(function (e) {
  e.preventDefault()
  $(this).tab('show')
})

$(document).mouseup(function (e)
{
    var container = $(".bc_login_form");

    if (!container.is(e.target) // if the target of the click isn't the container...
        && container.has(e.target).length === 0 && $('.bc_popup').css('display') =='block') // ... nor a descendant of the container
    {
        jQuery('.bc_popup').fadeOut("slow");
    }
});
if($(window).width() < 767)
{ 
	$(".nav-menu").on('click','li', function(){
	$(this).toggleClass('active').siblings().removeClass('active');
 })
}
</script>

<section class="cz-popup">
  <div class="cz-popup-wrapp"> 
  <a class="cz-popup-close" href="javascript:;" title="Close"> <i class="fa fa-times"></i> </a>
    <h4>Reporter</h4>
    <div class="cz-popup-inner-wrapp">
     <h6>Help us understand the problem. What is going on with this comment?</h6>
        <form>
          <input type="hidden" id="comment-id-report" value="0">
         <ul>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Spam">Spam</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Abusive or Harmful">Abusive or Harmful</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Inappropriate content">Inappropriate content</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Strong language">Strong language</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Other">Other</label>
                </li>
                <li id="comment-report-other-reason-wrap" style="display:none;">
                 <textarea rows="2" cols="2" id="comment-report-other-reason"></textarea>
                </li>
            </ul>
            <p><a href="https://www.bleepingcomputer.com/posting-guidelines/">Learn more</a> about what is not allowed to be posted.</p>
        </form>
    </div>
    <div class="cz-popup-bottom-wrapp">
    <div class="cz-popup-report-submiting" style="display:none;">Submitting...</div>
     <a href="#" class="cz-next-btn comment-report-submit-btn">SUBMIT</a>
    </div>
  </div>
</section>

<script type="text/javascript" >

                (function(w){

                                var AdblockPlus=new function(){this.detect=function(n,e){function o(n,e){0==t||e>2e3?n(0==t&&c):setTimeout(function(){o(n,2*e)},2*e)}function r(){--t||(c=!a&&i)}var c=!1,t=2,a=!1,i=!1;if("function"==typeof e){n+="?ch=*&rn=*";var f=11*Math.random(),u=new Image;u.onload=r,u.onerror=function(){a=!0,r()},u.src=n.replace(/\*/,1).replace(/\*/,f);var l=new Image;l.onload=r,l.onerror=function(){i=!0,r()},l.src=n.replace(/\*/,2).replace(/\*/,f),o(e,250)}}}; 

                                 AdblockPlus.detect("https://p.acceptableserver.com/px.gif", function(usesABP){ 

                                                 if(usesABP){ 

                                                                 var s = w.document.createElement("script"); 

                                                                 s.src = (w.location.protocol === "https:" ? "https:" : "http:")+"//serve.acceptableserver.com/show_lay?id=266&url="+encodeURIComponent(w.location.href)+"&cb="+(+new Date()); 

                                                                 w.document.getElementsByTagName("head")[0].appendChild(s); 

                                                 } 

                                 }) 

                })(window.top); 

</script>


        <script type="text/javascript" src="//s9.addthis.com/js/300/addthis_widget.js#pubid=ra-55d5fe0cec929e88&domready=1" async="async"></script>


</body>
</html>