<!doctype html>
<html lang="en-us">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
 
<link href='https://fonts.googleapis.com/css?family=Roboto:400,100,300,500,700,900' rel='stylesheet' type='text/css'>
 
<link href="https://www.bleepstatic.com/css/redesign/bootstrap.css" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/main.css?v=3.29.17.1" rel="stylesheet" type="text/css" media="all">
<link href="https://www.bleepstatic.com/css/redesign/home.css" rel="stylesheet" type="text/css" media="screen"><link href="https://www.bleepstatic.com/css/redesign/news.css?v=31017.1" rel="stylesheet" type="text/css" media="screen,print">
<link rel="stylesheet" href="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.css?v=2.1.5" type="text/css" media="screen"/>
 
<meta name="Owner" content="Lawrence Abrams/BleepingComputer.com"/>
<link rel="shortcut icon" href="https://www.bleepstatic.com/favicon/bleeping.ico"/>
<meta http-equiv="Pragma" content="no-cache"/>
<META NAME="ROBOTS" CONTENT="NOODP"/>
<meta property="og:site_name" content="BleepingComputer"/>
<meta property="og:locale" content="en_us"/>
<meta name="application-name" content="BleepingComputer"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//www.bleepstatic.com'/>
<title>Keylogger Found in Audio Driver of HP Laptops</title>
<meta name="Description" content="The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user's keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look."/>
<meta name="Abstract" content="The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user's keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look."/>
<meta name="Keywords" content="computers, windows, linux, mac, support, tech support, spyware, malware, virus, security, Driver, HP, Keylogger, Laptop,virus removal, malware removal, computer help, technical support"/>
<link rel="canonical" href="https://www.bleepingcomputer.com/news/security/keylogger-found-in-audio-driver-of-hp-laptops/"/>
<link rel="prev" href="https://www.bleepingcomputer.com/news/security/edge-security-flaw-allows-theft-of-facebook-and-twitter-credentials/"/>
<link rel="next" href="https://www.bleepingcomputer.com/news/software/avast-antivirus-update-blocks-internet-access/"/>
<meta name="news_keywords" content="Driver, HP, Keylogger, Laptop, Security, InfoSec, Computer Security">
<meta property="og:type" content="article"/>
<meta property="og:title" content="Keylogger Found in Audio Driver of HP Laptops"/>
<meta property="og:url" content="https://www.bleepingcomputer.com/news/security/keylogger-found-in-audio-driver-of-hp-laptops/"/>
<meta property="og:image" content="https://www.bleepstatic.com/content/hl-images/2017/05/11/HP-Laptop.jpg"/>
<meta property="og:description" content="The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user&#039;s keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look."/>
<meta property="fb:app_id" content="517620508265293"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@BleepinComputer"/>
<meta name="twitter:creator" content="@BleepinComputer"/>
<meta name="twitter:title" content="Keylogger Found in Audio Driver of HP Laptops"/>
<meta name="twitter:description" content="The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user&#039;s keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look."/>
<meta name="twitter:image" content="https://www.bleepstatic.com/content/hl-images/2017/05/11/HP-Laptop.jpg"/>
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "Article",
    "headline": "Keylogger Found in Audio Driver of HP Laptops",
    "name": "Keylogger Found in Audio Driver of HP Laptops",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "id": "https://www.bleepingcomputer.com/news/security/keylogger-found-in-audio-driver-of-hp-laptops/"
    },
    "description": "The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user&#039;s keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look.",
    "image": {
        "@type": "ImageObject",
        "url": "https://www.bleepstatic.com/content/hl-images/2017/05/11/HP-Laptop.jpg",
        "width": 1250,
        "height": 465
    },
    "author": {
        "@type": "Person",
        "name": "Catalin Cimpanu",
        "url": "https://www.bleepingcomputer.com/",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.bleepstatic.com/images/site/logo.png",
            "width": 287,
            "height": 24
        }
    },
    "datePublished": "2017-05-11T08:45:12-04:00",
    "dateModified": "2017-05-12T11:47:48-04:00",
    "publisher": {
        "@type": "Organization",
        "name": "BleepingComputer.com",
        "url": "https://www.bleepingcomputer.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.bleepstatic.com/images/site/logo.png",
            "width": 287,
            "height": 24
        }
    }
}
</script>
<link href="https://plus.google.com/+bleepingcomputer" rel="publisher"/>
<LINK REL="alternate" TITLE="Bleeping Computer's News" HREF="https://www.bleepingcomputer.com/feed/" TYPE="application/rss+xml">
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/jquery-1.11.1.min.js"></script>
<script type="text/javascript" async src="https://www.bleepstatic.com/js/redesign/bleep.js?t=1494744182"></script>
<script async type="text/javascript" src="https://www.bleepstatic.com/js/redesign/news.js"></script>
<script type="text/javascript" id="nsgpt" data-channel="homepage" data-oop="" src="//cdn.nsstatic.net/ns/bleepingcomputer.com.js" async="true"></script>
 
<script data-cfasync='false' type='text/javascript'>
	window.apd_options = { 'websiteId': 5971, 'runFromFrame': false };
	(function() {
		var w = window.apd_options.runFromFrame ? window.top : window;
		if(window.apd_options.runFromFrame && w!=window.parent) w=window.parent;
		if (w.location.hash.indexOf('apdAdmin') != -1){if(typeof(Storage) !== 'undefined') {w.localStorage.apdAdmin = 1;}}
		var adminMode = ((typeof(Storage) == 'undefined') || (w.localStorage.apdAdmin == 1));
		w.apd_options=window.apd_options;
		var apd = w.document.createElement('script'); apd.type = 'text/javascript'; apd.async = true;
		apd.src = '//' + (adminMode ? 'cdn' : 'ecdn') + '.firstimpression.io/' + (adminMode ? 'fi.js?id=' + window.apd_options.websiteId : 'fi_client.js') ;
		var s = w.document.getElementsByTagName('head')[0]; s.appendChild(apd);
	})();</script>
 
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  googletag.cmd.push(function() {
    
    googletag.defineSlot('/1006593/ROS_Side_2', [[300, 600], [300, 250]], 'div-gpt-ad-1474727680612-0').addService(googletag.pubads());
 
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="//www.bleepstatic.com/js/cookieconsent/cookieconsent.min.js"></script>
<script>
window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#237afc"
    },
    "button": {
      "background": "#fff",
      "text": "#237afc"
    }
  },
  "theme": "classic",
  "content": {
    "href": "https://www.bleepingcomputer.com/privacy/"
  }
})});
</script>
</head>
<body>
 
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N3FCGQ" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N3FCGQ');</script>
 
<div class="bc_wrapper">
 
<header>
<div class="container">
<div class="row">
<div class="col-md-4">
<a class="bc_logo" href="https://www.bleepingcomputer.com/"><img src="https://www.bleepstatic.com/images/site/logo.png" width="287" height="24" alt="logo"></a>
</div>
<div class="col-md-8">
<ul class="bc_social_icons">
<li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
<li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
<li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
<li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
</ul>
<div class="bc_search_box">
<form action="https://www.bleepingcomputer.com/search/">
<input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228"/>
<input type="hidden" name="cof" value="FORID:10"/>
<input type="hidden" name="ie" value="UTF-8"/>
<input type="search" name="q" placeholder="Search Site"/>
</form>
<script async type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
</div>
<div class="bc_login">
<input type="submit" value="Login" class="bc_login_btn">
<input type="submit" value="Sign up" class="bc_signup_btn" onclick="window.location='https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register';"/>
</div>
</div>
</div>
</div>
 
<nav class="bc_navigation">
<div class="container">
<span id="toggle-nav" class="toggle-site-nav">
<span></span>
</span>
<div class="site-nav" id="nav" role="navigation">
<ul class="bc_social_icons bc_mob">
<li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
<li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
<li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
<li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
</ul>
<div class="bc_search_box bc_mob">
<form action="https://www.bleepingcomputer.com/search/">
<input type="hidden" name="cx" value="partner-pub-0920899300397823:3529943228"/>
<input type="hidden" name="cof" value="FORID:10"/>
<input type="hidden" name="ie" value="UTF-8"/>
<input type="search" name="q" placeholder="Search Site"/>
</form>
<script async type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
</div>
<div class="bc_login bc_mob">
<input type="submit" value="Login" class="bc_login_btn">
<input type="submit" value="Sign up" class="bc_signup_btn">
</div>
<ul class="nav-menu">
<li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/">News</a>
<div class="bc_sub_menu">
<div role="tabpanel">
<ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
<li class="active"><a href="#nfeatured" role="tab" data-toggle="tab">Featured</a></li>
<li><a href="#nlatest" role="tab" data-toggle="tab">Latest</a></li>
</ul>
<div class="tab-content">
<div role="tabpanel" class="tab-pane active" id="nfeatured">
<ul>
<li>
<a href="https://www.bleepingcomputer.com/news/security/microsoft-releases-patch-for-older-windows-versions-to-protect-against-wana-decrypt0r/">
<img src="https://www.bleepstatic.com/content/posts/2017/05/13/thumb/211x130_MicrosoftUpdates.png" alt="Microsoft Releases Patch for Older Windows Versions to Protect Against Wana Decrypt0r Image">
<p>Microsoft Releases Patch for Older Windows Versions to Protect Against Wana Decrypt0r</p>
</a>
</li>
<li>
<a href="https://www.bleepingcomputer.com/news/security/wana-decrypt0r-ransomware-outbreak-temporarily-stopped-by-accidental-hero-/">
<img src="https://www.bleepstatic.com/content/posts/2017/05/13/thumb/211x130_MalwareTech.png" alt="Wana Decrypt0r Ransomware Outbreak Temporarily Stopped By "Accidental Hero" Image">
                                                 <p>Wana Decrypt0r Ransomware Outbreak Temporarily Stopped By "Accidental Hero"</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/wana-decrypt0r-ransomware-using-nsa-exploit-leaked-by-shadow-brokers-is-on-a-rampage/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/05/12/thumb/211x130_WannaCrypt.png" alt="Wana Decrypt0r Ransomware Using NSA Exploit Leaked by Shadow Brokers Is on a Rampage Image">
                                                 <p>Wana Decrypt0r Ransomware Using NSA Exploit Leaked by Shadow Brokers Is on a Rampage</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/wana-decryptor-wanacrypt0r-technical-nose-dive/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2017/05/12/thumb/211x130_wana-292-176.png" alt="Wana Decryptor / WanaCrypt0r Technical Nose Dive Image">
                                                 <p>Wana Decryptor / WanaCrypt0r Technical Nose Dive</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="nlatest">
                                        <ul>
					  
                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/the-week-in-ransomware-may-13th-2017-the-wanacrypt0r-ransomapocageddonware/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2016/03/10/thumb/211x130_security-lock-292-170.png" alt="The Week in Ransomware - May 13th 2017 - The WanaCrypt0r RansomApocaGeddonWare Image">
                                                 <p>The Week in Ransomware - May 13th 2017 - The WanaCrypt0r RansomApocaGeddonWare</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/microsoft-releases-patch-for-older-windows-versions-to-protect-against-wana-decrypt0r/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/05/13/thumb/211x130_MicrosoftUpdates.png" alt="Microsoft Releases Patch for Older Windows Versions to Protect Against Wana Decrypt0r Image">
                                                 <p>Microsoft Releases Patch for Older Windows Versions to Protect Against Wana Decrypt0r</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/wana-decrypt0r-ransomware-outbreak-temporarily-stopped-by-accidental-hero-/">
                                                 <img src="https://www.bleepstatic.com/content/posts/2017/05/13/thumb/211x130_MalwareTech.png" alt="Wana Decrypt0r Ransomware Outbreak Temporarily Stopped By "Accidental Hero" Image">
                                                 <p>Wana Decrypt0r Ransomware Outbreak Temporarily Stopped By "Accidental Hero"</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/news/security/wana-decryptor-wanacrypt0r-technical-nose-dive/">
                                                 <img src="https://www.bleepstatic.com/content/hl-images/2017/05/12/thumb/211x130_wana-292-176.png" alt="Wana Decryptor / WanaCrypt0r Technical Nose Dive Image">
                                                 <p>Wana Decryptor / WanaCrypt0r Technical Nose Dive</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/download/">Downloads</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#dlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#most" role="tab" data-toggle="tab">Most Downloaded</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="dlatest">
                                        <ul>
					  
                                            <li>
						<a href="https://www.bleepingcomputer.com/download/bitkangaroodecrypter/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/185-bitkangaroodecrypter.jpg" alt="BitKangarooDecrypter Image">
                                                 <p class="center">BitKangarooDecrypter</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/vipre-advance-security-for-home/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/184-vipre-advance-security-for-home.jpg" alt="VIPRE Advance Security for Home Image">
                                                 <p class="center">VIPRE Advance Security for Home</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/btcwaredecrypter/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/183-btcwaredecrypter.jpg" alt="BTCWareDecrypter Image">
                                                 <p class="center">BTCWareDecrypter</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://www.bleepingcomputer.com/download/pc-hunter/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/1/182-pc-hunter.jpg" alt="PC Hunter Image">
                                                 <p class="center">PC Hunter</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="most">
                                        <ul>
					  
                                            <li>
						<a href="/download/adwcleaner/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/96-adwcleaner.jpg" alt="AdwCleaner Image">
                                                 <p class="center">AdwCleaner</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/combofix/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/9-combofix.jpg" alt="ComboFix Image">
                                                 <p class="center">ComboFix</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/rkill/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/8-rkill.jpg" alt="RKill Image">
                                                 <p class="center">RKill</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/download/junkware-removal-tool/">
                                                 <img src="https://www.bleepstatic.com/download/nav-header-images/0/98-junkware-removal-tool.jpg" alt="Junkware Removal Tool Image">
                                                 <p class="center">Junkware Removal Tool</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#vlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#vmost" role="tab" data-toggle="tab">Most Viewed</a></li>

                                    <li><a href="#ransomware" role="tab" data-toggle="tab">Ransomware</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="vlatest">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/locky-ransomware-information-help">
                                                 <img src="https://www.bleepstatic.com/swr-guides/l/locky/locky-header-thmb-350.png" alt="Locky Ransomware Information, Help Guide, and FAQ Image">
                                                 <p>Locky Ransomware Information, Help Guide, and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-yeahdesktop.com-advertisements">
                                                 <img src="https://www.bleepstatic.com/removal-guides/y/yeadesktop.com/yeadesktop.com-redirect-thmb-350.jpg" alt="Remove Yeadesktop.com Ads (Uninstall Guide) Image">
                                                 <p>Remove Yeadesktop.com Ads (Uninstall Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-tubetime">
                                                 <img src="https://www.bleepstatic.com/removal-guides/t/tubetime/tubetime-thmb-350.jpg" alt="How to remove the TubeTime Program Image">
                                                 <p>How to remove the TubeTime Program</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-the-boravid-chrome-extension">
                                                 <img src="https://www.bleepstatic.com/removal-guides/b/boravid/boravid-advertisements-thmb-350.jpg" alt="How to remove the Boravid Chrome Extension (Uninstall Guide) Image">
                                                 <p>How to remove the Boravid Chrome Extension (Uninstall Guide)</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="vmost">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/remove-security-tool">
                                                 <img src="https://www.bleepstatic.com/swr-guides/s/securitytool/security-tool-thmb-350.jpg" alt="Remove Security Tool and SecurityTool (Uninstall Guide) Image">
                                                 <p>Remove Security Tool and SecurityTool (Uninstall Guide)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/uninstall-antivirus-2009">
                                                 <img src="https://www.bleepstatic.com/swr-guides/a/antivirus-2009/antivirus-2009-thmb-350.jpg" alt="How to remove Antivirus 2009 (Uninstall Instructions) Image">
                                                 <p>How to remove Antivirus 2009 (Uninstall Instructions)</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-vundo-virtumonde">
                                                 <img src="https://www.bleepstatic.com/images/site/navigation/generic-chalkboard-211x130.jpg" alt="How to Remove WinFixer / Virtumonde / Msevents / Trojan.vundo Image">
                                                 <p>How to Remove WinFixer / Virtumonde / Msevents / Trojan.vundo</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/remove-tdss-tdl3-alureon-rootkit-using-tdsskiller">
                                                 <img src="https://www.bleepstatic.com/swr-guides/tools/tdsskiller/tdsskiller-start-thmb-350.jpg" alt="How to remove Google Redirects or the TDSS, TDL3, or Alureon rootkit using TDSSKiller Image">
                                                 <p>How to remove Google Redirects or the TDSS, TDL3, or Alureon rootkit using TDSSKiller</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="ransomware">
                                        <ul>
					  
                                            <li>
						<a href="/virus-removal/locky-ransomware-information-help">
                                                 <img src="https://www.bleepstatic.com/swr-guides/l/locky/locky-header-thmb-350.png" alt="Locky Ransomware Information, Help Guide, and FAQ Image">
                                                 <p>Locky Ransomware Information, Help Guide, and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptolocker-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/cryptolocker/CryptoLocker-thmb-350.jpg" alt="CryptoLocker Ransomware Information Guide and FAQ Image">
                                                 <p>CryptoLocker Ransomware Information Guide and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptorbit-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/cryptorbit/howdecrypt-thmb-350.gif" alt="CryptorBit and HowDecrypt Information Guide and FAQ Image">
                                                 <p>CryptorBit and HowDecrypt Information Guide and FAQ</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/virus-removal/cryptodefense-ransomware-information">
                                                 <img src="https://www.bleepstatic.com/swr-guides/c/CryptoDefense/how_decrypt-html-thmb-350.jpg" alt="CryptoDefense and How_Decrypt Ransomware Information Guide and FAQ Image">
                                                 <p>CryptoDefense and How_Decrypt Ransomware Information Guide and FAQ</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#tlatest" role="tab" data-toggle="tab">Latest</a></li>

                                    <li><a href="#popular" role="tab" data-toggle="tab">Popular</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
                                    <div role="tabpanel" class="tab-pane active" id="tlatest">
                                        <ul>
					  
                                            <li>
						<a href="/tutorials/how-to-start-windows-10-in-safe-mode-with-networking/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/320-safe-mode-with-networking.jpg" alt="How to Start Windows 10 in Safe Mode with Networking Image">
                                                 <p>How to Start Windows 10 in Safe Mode with Networking</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-remove-a-google-chrome-extension/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/319-confirm-removal.jpg" alt="How to Remove a Google Chrome Extension Image">
                                                 <p>How to Remove a Google Chrome Extension</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/understanding-google-chrome-extensions/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/318-chrome-web-store.jpg" alt="What are Google Chrome Extensions? Image">
                                                 <p>What are Google Chrome Extensions?</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-open-a-bookmark-in-google-chrome/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/6/317-open-a-bookmark-in-chrome.jpg" alt="How to Open a Bookmark in Google Chrome Image">
                                                 <p>How to Open a Bookmark in Google Chrome</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                    <div role="tabpanel" class="tab-pane" id="popular">
                                        <ul>
					  
                                            <li>
						<a href="/tutorials/how-to-start-windows-in-safe-mode/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/61-startup-settings.png" alt="How to start Windows in Safe Mode Image">
                                                 <p>How to start Windows in Safe Mode</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-remove-a-trojan-virus-worm-or-malware/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/2/101-Cerber-wallpaper.png" alt="How to remove a Trojan, Virus, Worm, or other Malware Image">
                                                 <p>How to remove a Trojan, Virus, Worm, or other Malware</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/show-hidden-files-in-windows-7/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/3/151-show-hidden-files.jpg" alt="How to show hidden files in Windows 7 Image">
                                                 <p>How to show hidden files in Windows 7</p>
					        </a>
                                            </li>

                                            <li>
						<a href="/tutorials/how-to-see-hidden-files-in-windows/">
                                                 <img src="https://www.bleepstatic.com/images/site/tutorials/nav-header-images/1/62-hidden-files.jpg" alt="How to see hidden files in Windows Image">
                                                 <p>How to see hidden files in Windows</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

			
                        <li class="bc_dropdown"><a href="https://deals.bleepingcomputer.com/">Deals</a>
                            <div class="bc_sub_menu">
                                <div role="tabpanel">
                                  <ul class="nav nav-tabs" role="tablist" id="bc_drop_tab">
                                    
                                    <li class="active"><a href="#dcategories" role="tab" data-toggle="tab">Categories</a></li>

                                  </ul>
                                  <div class="tab-content">
				   
<div role="tabpanel" class="tab-pane active" id="dcategories">
                                        <ul>
					  
                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/elearning?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/elearning-nav.jpg" alt="eLearning Image">
                                                 <p align='center'>eLearning</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/certifications?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/it-certification-nav.jpg" alt="IT Certification Courses Image">
                                                 <p align='center'>IT Certification Courses</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/deals/gear-gadgets?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/gear-gadgets-nav.jpg" alt="Gear &amp; Gadgets Image">
                                                 <p align='center'>Gear + Gadgets</p>
					        </a>
                                            </li>

                                            <li>
						<a href="https://deals.bleepingcomputer.com/collections/tag-cyber-security?utm_source=bleepingcomputer.com&utm_medium=dd_cat">
                                                 <img src="https://www.bleepstatic.com/images/deals/security-nav.jpg" alt="Security Image">
                                                 <p align='center'>Security</p>
					        </a>
                                            </li>

                                        </ul>
                                    </div>

                                  </div>
                                </div>
                            </div>
                        </li>

                        <li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
                        <li class="bc_dropdown bc_more_nav"><a id="more_dd" href="#">More</a>
                        	<ul id="bc_more-nav" class="bc_more_submenu">
                              <li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
			      <li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
                              <li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
                              <li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
                              <li><a href="https://www.bleepingcomputer.com/chat/">Chat on IRC</a></li>
			      <li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
                            </ul>
                        </li>
                     </ul>
           		</div>
         </div>
    </nav>
 </header>   
<!-- End Header Section -->

<section class="cz-oa-wrapp">
  <div class="container">
    <div class="row">
      <div class="col-md-12">
        <div class="cz-toa-wrapp">
	 
 <div data-ns="billboard" data-pos="atf" data-collapse="true"></div>

        </div>
      </div>
    </div>
  </div>
</section>

<section>
  <div class="container">
    <div class="row">
      <div class="col-md-12">
        <div class="cz-breadcrumb-outer-wrapp">
          <div class="cz-breadcrumb-left-area">
            <div class="cz-breadcrumb">
              <ul itemscope itemtype="http://schema.org/BreadcrumbList">
                <li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bleepingcomputer.com/" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/" itemprop="item">News</a></span><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name"><a href="https://www.bleepingcomputer.com/news/security/" itemprop="item">Security</a></span><meta itemprop="position" content="3" /></li><li class="active" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><span itemprop="name">Keylogger Found in Audio Driver of HP Laptops</span></li>
              </ul>
            </div>
          </div>
          <div class="cz-breadcrumb-right-area">
            <div class="cz-like-wrapper">
              <ul>
                <li><div class="addthis_sharing_toolbox"></div></li>
	                        <li class="cz-print-icon"><a href="#">&nbsp;</a></li>
              </ul>
            </div>
          </div>
        </div>
      </div>
    </div>
  </div>
</section>
<!-- Start Content Section -->

<section class="bc_main_content">
  <div class="container">
    <div class="row">
      <div class="col-md-8">
        <div class="cz-main-left-section">
         
	 <div class="article_section">
          <h2>Keylogger Found in Audio Driver of HP Laptops</h2>
          <div class="cz-news-story-title-section">
            <div class="cz-news-title-left-area">
              By <h6><a rel='author' href='https://www.bleepingcomputer.com/author/catalin-cimpanu/' class='author'><span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name">Catalin Cimpanu</span></span></a></h6>
            </div>
	    <meta itemprop="articleSection" content="Security"><meta itemprop="articleSection" content="Hardware">
            <div class="cz-news-title-right-area">
              <ul>
                <li class="cz-news-date">May 11, 2017</li>
                <li class="cz-news-time">08:45 AM</li>
                
                <li class="cz-news-comment"><a href="#comments">2</a></li>
              </ul>
            </div>
          </div>
	  <div class="articleBody">
	   <p style="text-align:center"><img alt="HP laptop" height="465" src="https://www.bleepstatic.com/content/hl-images/2017/05/11/HP-Laptop.jpg" width="1250" /></p>

<p>The audio driver installed on some HP laptops includes a feature that could best be described as a keylogger, which records all the user&#39;s keystrokes and saves the information to a local file, accessible to anyone or any third-party software or malware that knows where to look.</p>

<p>Swiss cyber-security firm modzero discovered the keylogger on April 28 and made its <a href="https://www.modzero.ch/advisories/MZ-17-01-Conexant-Keylogger.txt" rel="nofollow" target="_blank">findings</a> public today.</p>

<h2>Keylogger found in preinstalled audio driver</h2>

<p>According to researchers, the keylogger feature was discovered in the Conexant HD Audio Driver Package version 1.0.0.46 and earlier.</p>

<p>This is an audio driver that is preinstalled on HP laptops. One of the files of this audio driver is <strong>MicTray64.exe</strong> (<em>C:&#092;windows&#092;system32&#092;mictray64.exe</em>).</p>

<p>This file is registered to start via a Scheduled Task every time the user logs into his computer. According to modzero researchers, the file &quot;monitors all keystrokes made by the user to capture and react to functions such as microphone mute/unmute keys/hotkeys.&quot;</p>

<p>This behavior, by itself, is not a problem, as many other apps work this way. The problem is that this file writes all keystrokes to a local file at:</p>

<pre>
<code>C:&#092;users&#092;public&#092;MicTray.log</code></pre>

<h2>Audio driver also exposes keystrokes in real-time via local API</h2>

<p>If the file doesn&#39;t exist or a registry key containing this file&#39;s path does not exist or was corrupted, the audio driver will pass all keystrokes to a local API, named the OutputDebugString API.</p>

<p>The danger is that malicious software installed on the computer, or a person with physical access to the computer, can copy the log file and have access to historical keystroke data, from where he can extract passwords, chat logs, visited URLs, source code, or any other sensitive data.</p>

<p>Furthermore, the OutputDebugString API provides a covert channel for malware to record real-time keystrokes without using native Windows functions, usually under the watchful eye of antivirus software.</p>

<h2>Keylogger feature confirmed in HP laptops</h2>

<p>Modzero researchers said they found the Conexant HD Audio Driver Package preinstalled on 28 HP laptop models. Other hardware that uses this driver may also be affected, but investigators haven&#39;t officially confirmed that the issue affects other manufacturers.</p>

<pre>
<code>   HP EliteBook 820 G3 Notebook PC
   HP EliteBook 828 G3 Notebook PC
   HP EliteBook 840 G3 Notebook PC
   HP EliteBook 848 G3 Notebook PC
   HP EliteBook 850 G3 Notebook PC
   HP ProBook 640 G2 Notebook PC
   HP ProBook 650 G2 Notebook PC
   HP ProBook 645 G2 Notebook PC
   HP ProBook 655 G2 Notebook PC
   HP ProBook 450 G3 Notebook PC
   HP ProBook 430 G3 Notebook PC
   HP ProBook 440 G3 Notebook PC
   HP ProBook 446 G3 Notebook PC
   HP ProBook 470 G3 Notebook PC
   HP ProBook 455 G3 Notebook PC
   HP EliteBook 725 G3 Notebook PC
   HP EliteBook 745 G3 Notebook PC
   HP EliteBook 755 G3 Notebook PC
   HP EliteBook 1030 G1 Notebook PC
   HP ZBook 15u G3 Mobile Workstation
   HP Elite x2 1012 G1 Tablet
   HP Elite x2 1012 G1 with Travel Keyboard
   HP Elite x2 1012 G1 Advanced Keyboard
   HP EliteBook Folio 1040 G3 Notebook PC
   HP ZBook 17 G3 Mobile Workstation
   HP ZBook 15 G3 Mobile Workstation
   HP ZBook Studio G3 Mobile Workstation
   HP EliteBook Folio G1 Notebook PC</code></pre>

<p>The Conexant HD Audio Driver Package has versions for the following operating systems.</p>

<pre>
<code>   Microsoft Windows 10 32-Bit
   Microsoft Windows 10 64-Bit
   Microsoft Windows 10 IOT Enterprise 32-Bit (x86)
   Microsoft Windows 10 IOT Enterprise 64-Bit (x86)
   Microsoft Windows 7 Enterprise 32 Edition
   Microsoft Windows 7 Enterprise 64 Edition
   Microsoft Windows 7 Home Basic 32 Edition
   Microsoft Windows 7 Home Basic 64 Edition
   Microsoft Windows 7 Home Premium 32 Edition
   Microsoft Windows 7 Home Premium 64 Edition
   Microsoft Windows 7 Professional 32 Edition
   Microsoft Windows 7 Professional 64 Edition
   Microsoft Windows 7 Starter 32 Edition
   Microsoft Windows 7 Ultimate 32 Edition
   Microsoft Windows 7 Ultimate 64 Edition
   Microsoft Windows Embedded Standard 7 32
   Microsoft Windows Embedded Standard 7E 32-Bit</code></pre>

<p>HP did not respond to a request for comment from Bleeping Computer in time for this article&#39;s publication.</p>

<h3>Here&#39;s how to Check for and Remove the HP MicTray64 Keylogger</h3>

<p>According to modzero, to check for and remove the HP MicTray64.exe keylogger, you should follow these steps:</p>

<ol>
	<li>Open Task Manager and check for a running process called MicTray64.exe. If this process exists, close it.<br />
	&nbsp;</li>
	<li>Navigate to <strong>c:&#092;Windows&#092;System32&#092;MicTray64.exe</strong>&nbsp;and move the file to your Desktop.<br />
	&nbsp;</li>
	<li>Now check if the file <strong>C:&#092;Users&#092;Public&#092;MicTray.log </strong>exists. If it does, move this file to the Desktop as well.<br />
	&nbsp;</li>
	<li>Now that the keylogger has been removed and you have isolated the log files, let&#39;s take a look at what was logged.<br />
	&nbsp;</li>
	<li>Open the&nbsp;<strong>MicTray.log&nbsp;</strong>file on your desktop and examine the contents. If you notice that login names, passwords, banking info, or any other sensitive login info has been logged, you should immediately change your passwords at the associated accounts.&nbsp;</li>
</ol>

<p>After following the steps, the keylogger will no longer be active and will not start on reboot.</p>

<p><strong>UPDATE [May 12, 2017, 11:45 AM ET]:</strong> HP has <a href="https://www.bleepingcomputer.com/news/hardware/hp-releases-driver-update-to-remove-accidental-keylogger/" target="_blank">released a driver update</a> to resolve this issue.</p>

	  </div>
         </div>
          <div class="asa">
 
<script type="text/javascript"><!--
google_ad_client = "ca-pub-3249370012249755";
/* News - After Story */
google_ad_slot = "5975899204";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

</div>

	  
          <div class="cz-news-tags-wrap">
            <ul>
	     
              <li><a href="https://www.bleepingcomputer.com/tag/driver/">Driver</a></li>

              <li><a href="https://www.bleepingcomputer.com/tag/hp/">HP</a></li>

              <li><a href="https://www.bleepingcomputer.com/tag/keylogger/">Keylogger</a></li>

              <li><a href="https://www.bleepingcomputer.com/tag/laptop/">Laptop</a></li>

            </ul>
          </div>

          <div class="cz-news-like-wrapp">
            <div class="addthis_toolbox addthis_default_style addthis_32x32_style">
             <div class="cz-news-like-left-area">
              <ul>
               <li><a class="addthis_button_facebook"></a></li>
               <li><a class="addthis_button_twitter"></a></li>
               <li><a class="addthis_button_google_plusone_share"></a></li>
               <li><a class="addthis_button_linkedin"></a></li>
              </ul>
             </div>
             <div class="cz-news-like-right-area">
              <ul>
                
                <li><a class="addthis_button_email"></a></li>
                <li class="cz-lg-print-icon"><a href="#"></a></li>
              </ul>
             </div>
            </div>
          </div>
	            <div class="cz-full-bio-wrapp">
            <div class="cz-full-bio-img-wrapp">
		<a style="background-image:url('https://www.bleepstatic.com/author/photos/e1bde5ed1bb1075346983638c8e177b2.png');" class="author-img" href="https://www.bleepingcomputer.com/author/catalin-cimpanu/"></a>
            </div>
            <div class="cz-full-bio-content-wrapp">
              <h5><a href="https://www.bleepingcomputer.com/author/catalin-cimpanu/" target="_blank">Catalin Cimpanu</a> <span> <a href="mailto:catalin@bleepingcomputer.com"><i class="fa fa-envelope email"></i></a>  <a href="https://twitter.com/campuscodi" target="_blank"><i class="fa fa-twitter twitter"></i></a></span></h5>
              Catalin covers various topics such as data breaches, software vulnerabilities, exploits, hacking news, the Dark Web, programming topics, social media, web technology, product launches, and a few more.
            </div>
          </div>

          
          <div class="cz-story-navigation">
            <ul>
	                    <li><a href="https://www.bleepingcomputer.com/news/security/edge-security-flaw-allows-theft-of-facebook-and-twitter-credentials/"><i class="fa fa-chevron-left"></i> Previous Article </a></li>

              <li><a href="https://www.bleepingcomputer.com/news/software/avast-antivirus-update-blocks-internet-access/">Next Article <i class="fa fa-chevron-right"></i></a></li>

            </ul>
          </div>

          
           <div class="cz-newz-comment-wrapp" id="comments">
            <h3>Comments</h3>
            <ul>
             
              <li id="cid5278" itemscope itemtype="http://schema.org/UserComments">
                <div class="cz-newz-comment-inner-wrappper">
                  <div class="cz-newz-comment-img-wrappper"> <img alt="Wolverine 7 Photo" src="https://www.bleepingcomputer.com/forums/uploads/profile/photo-762133.jpg?_r=1459984471"> </div>
                  <div class="cz-newz-comment-content-wrappper">
                    <div class="cz-newz-comment-title-wrapp">
                      <div class="cz-newz-title-left-area">
                        <data itemprop="name" content="Wolverine 7" />
			<data itemprop="commentTime" content="2017-05-11T05:35" />
                        <h6>
                        <a href="https://www.bleepingcomputer.com/forums/u/762133/wolverine-7/" target="_blank">Wolverine 7</a> <span> -  2 days ago</span> </h6></div>
                      <div class="cz-newz-title-right-area">
                        <ul>
			  
                          
                          
                          <li><a class="cz-news-report cz-comment-report-btn" href="#" title='Report' data-id="5278">&nbsp;</a></li>
                          <li><a class="cz-news-link" href="#cid5278" title='Link'>&nbsp;</a></li>

                        </ul>
                      </div>
                    </div>
                    <p id="comment_html_5278" itemprop="commentText">How weird,putting  a keylogger in an audio driver,issue published because neither HP or Conexant were prepared to comment or take any responsibility,typical..My HP laps dont have<br />
it fortunately but thanks for the heads up.<br />
<br />
HP,the company that brought us deliberately overheating laptops so you buy another one,<br />
they,ll probably end up in the part of the afterlife reserved for Microsoft executives and Lawyers...</p>
                  </div>
                </div>
              </li>


              <li id="cid5283" itemscope itemtype="http://schema.org/UserComments">
                <div class="cz-newz-comment-inner-wrappper">
                  <div class="cz-newz-comment-img-wrappper"> <img alt="profitleads Photo" src="https://www.bleepingcomputer.com/forums/public/style_images/master/profile/default_large.png"> </div>
                  <div class="cz-newz-comment-content-wrappper">
                    <div class="cz-newz-comment-title-wrapp">
                      <div class="cz-newz-title-left-area">
                        <data itemprop="name" content="profitleads" />
			<data itemprop="commentTime" content="2017-05-12T10:50" />
                        <h6>
                        <a href="https://www.bleepingcomputer.com/forums/u/1051537/profitleads/" target="_blank">profitleads</a> <span> -  1 day ago</span> </h6></div>
                      <div class="cz-newz-title-right-area">
                        <ul>
			  
                          
                          
                          <li><a class="cz-news-report cz-comment-report-btn" href="#" title='Report' data-id="5283">&nbsp;</a></li>
                          <li><a class="cz-news-link" href="#cid5283" title='Link'>&nbsp;</a></li>

                        </ul>
                      </div>
                    </div>
                    <p id="comment_html_5283" itemprop="commentText">Wonderful.  Now it isn't necessary to worry about picking up malware from the internet; HP pre-installs it........no doubt to provide an "enhanced customer experience".</p>
                  </div>
                </div>
              </li>


            </ul>
           </div>
          
          <div class="cz-post-comment-wrapp">
       	    <h5>Post a Comment <span><a href="https://www.bleepingcomputer.com/forum-rules/" target="_blank">Community Rules</a></span></h5>
            <div class="cz-comment-loggin-wrapp">
              	<h6>You need to login in order to post a comment</h6>
                <input type="submit" value="Login" class="bc_login_btn cz-green-bttn">
		<p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
              </div>
          </div>

          
          <div class="cz-related-article-wrapp">
            <h3>You may also like</h3>
            <ul class="bc_suggested_article">
	     
              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/234-android-applications-are-currently-using-ultrasonic-beacons-to-track-users/">
                  <img src="https://www.bleepstatic.com/content/hl-images/2016/11/08/thumb/170x170_Android-Browser.jpg" alt="234 Android Applications Are Currently Using Ultrasonic Beacons to Track Users Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/234-android-applications-are-currently-using-ultrasonic-beacons-to-track-users/">234 Android Applications Are Currently Using Ultrasonic Beacons to Track Users</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/software/avast-antivirus-update-blocks-internet-access/">
                  <img src="https://www.bleepstatic.com/content/hl-images/2017/05/11/thumb/170x170_Avast.jpg" alt="Avast Antivirus Update Blocks Internet Access Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/software/avast-antivirus-update-blocks-internet-access/">Avast Antivirus Update Blocks Internet Access</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/open-ports-create-backdoors-in-millions-of-smartphones/">
                  <img src="https://www.bleepstatic.com/content/hl-images/2016/11/15/thumb/170x170_Android-Smartphone.jpg" alt="Open Ports Create Backdoors in Millions of Smartphones Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/open-ports-create-backdoors-in-millions-of-smartphones/">Open Ports Create Backdoors in Millions of Smartphones</a></h5>
                  </div>
                </div>
              </li>

              <li>
                <div class="cz-related-article-inner-wrapp">
                  <div class="cz-related-article-img-wrapp">
                  <a href="https://www.bleepingcomputer.com/news/security/wall-street-it-engineer-hacks-employer-to-see-if-he-will-be-let-go/">
                  <img src="https://www.bleepstatic.com/content/hl-images/2017/03/18/thumb/170x170_IT-admin.jpg" alt="Wall Street IT Engineer Hacks Employer to See If He Will Be Let Go Image">
                  </a>
                  </div>
                  <div class="cz-related-article-content-wrapp">
                    <h5><a href="https://www.bleepingcomputer.com/news/security/wall-street-it-engineer-hacks-employer-to-see-if-he-will-be-let-go/">Wall Street IT Engineer Hacks Employer to See If He Will Be Let Go</a></h5>
                  </div>
                </div>
              </li>

	    </ul>
	  </div>

          


        </div>
      </div>
      
      <!--  side bar section    -->    
      <div class="col-md-4 bc_right_sidebar">
       
	<div class="s-ou-wrap">
 
 <div data-ns="portrait" data-pos="atf" data-collapse="true"></div>
 
</div>
	
<!-- gallery placeholder -->
<div id="tvp-gallery"></div>
<!-- gallery placeholder -->

	
	
	                <div class="bc_latest_topic">
                        <div class="cz-line-heading"><div class="cz-line-heading-inner">Latest forum topics</div></div>
                    <ul>
                        
                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/646606/need-some-help-with-permissions/">
                                <div class="bc_topic_text">
                                  <p>Need some help with permissions.</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/1051794/chasep28/">chasep28</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/229/windows-10-support/">Windows 10 Support</a>
                                </div>
                            </a>
                        </li>

                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/646605/discovered-today-restore-function-fails-with-error-0x80070091/">
                                <div class="bc_topic_text">
                                  <p>Discovered today Restore function fails with Error 0x80070091</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/527168/peterlonz/">peterlonz</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/229/windows-10-support/">Windows 10 Support</a>
                                </div>
                            </a>
                        </li>

                        <li>
                                <a href="https://www.bleepingcomputer.com/forums/t/646604/windows-10-creators-update/">
                                <div class="bc_topic_text">
                                  <p>Windows 10 creators update</p>
                                  <span><a href="https://www.bleepingcomputer.com/forums/u/984338/bug1971/">bug1971</a></span> in <a href="https://www.bleepingcomputer.com/forums/f/229/windows-10-support/">Windows 10 Support</a>
                                </div>
                            </a>
                        </li>

                    </ul>
                </div>
	
                <div class="bc_news_letter_sidebar">
                        <h4>Newsletter Sign Up</h4>
                    <p>To receive periodic updates and news from <a href="/">BleepingComputer</a>, please use the form below. </p>
                    <form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
                        <input type="email" name="EMAIL" placeholder="Email Address...">
                        <div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div>
                      <input type="submit" value="Submit" class="bc_sub_btn">
                    </form>
                </div>
	
        
	
	<div class="s-ou-wrap">
 
<!-- /1006593/ROS_Side_2 -->
<div id='div-gpt-ad-1474727680612-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1474727680612-0'); });
</script>
</div>

</div>
        
        <div class="bc_downloads">
          <div class="cz-line-heading"><div class="cz-line-heading-inner">Latest Downloads</div></div>
          <ul>
           
            <li> <a href="https://www.bleepingcomputer.com/download/malwarebytes-anti-malware/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/12/28/icon1356707420.jpg" alt="Malwarebytes Anti-Malware Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/malwarebytes-anti-malware/">Malwarebytes Anti-Malware</a></p>
                <span>Version: 3.1.2.1733</span></div>
              <div class="bc_download_count"><strong>4M+ <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/shadowexplorer/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2015/11/19/icon1447957482.png" alt="ShadowExplorer Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/shadowexplorer/">ShadowExplorer</a></p>
                <span>Version: 0.9</span></div>
              <div class="bc_download_count"><strong>51,822 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/glasswire/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2015/11/16/icon1447711295.png" alt="Glasswire Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/glasswire/">Glasswire</a></p>
                <span>Version: 1.2.3100.0</span></div>
              <div class="bc_download_count"><strong>36,285 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/stupiddecryptor/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2017/04/27/icon1493302772.png" alt="StupidDecryptor Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/stupiddecryptor/">StupidDecryptor</a></p>
                <span>Version: NA</span></div>
              <div class="bc_download_count"><strong>588 <i>Downloads</i></strong></div>
              </a>
            </li>

            <li> <a href="https://www.bleepingcomputer.com/download/windows-repair-all-in-one/">
              <div class="bc_download_img"><img src="https://www.bleepstatic.com/download/product-logos/2012/09/19/icon1348083463.jpg" alt="Windows Repair (All In One) Logo"></div>
              <div class="bc_download_text">
                <p><a href="https://www.bleepingcomputer.com/download/windows-repair-all-in-one/">Windows Repair (All In One)</a></p>
                <span>Version: 3.9.30</span></div>
              <div class="bc_download_count"><strong>1M+ <i>Downloads</i></strong></div>
              </a>
            </li>

          </ul>
        </div>

	
        <div class="s-ou-wrap" id="pinned">
 
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar Sticky Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-0920899300397823"
     data-ad-slot="2748485221"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div>
      </div>
    </div>
  </div>
</section>

<!-- End Content Section --> 
<section class="cz-boa-wrapp">
 <div class="container">
  <div class="row">
   <div class="col-md-12">
    
<div class="cz-advertise-wrapp">
 <script type="text/javascript"><!--
 google_ad_client = "ca-pub-3249370012249755";
 /* Homepage - Bottom */
 google_ad_slot = "1089300124";
 google_ad_width = 728;
 google_ad_height = 90;
 //-->
 </script>
 <script type="text/javascript"
 src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

   </div>
  </div>
 </div>
</section>
<!-- Start Footer Section -->

<footer id="footer">
	<div class="container">
    	<div class="row">
        	<div class="col-md-4">
            	<h5>Newsletter Sign Up</h5>
                    <form action="//bleepingcomputer.us10.list-manage.com/subscribe/post?u=3e2b3b692f780cdff40d45346&amp;id=30c98e654e" method="post" target="_blank" novalidate>
                        <input type="email" name="EMAIL" placeholder="Email Address...">
                        <div style="position: absolute; left: -5000px;"><input type="text" name="b_3e2b3b692f780cdff40d45346_30c98e654e" tabindex="-1" value=""></div
>
                      <input type="submit" value="Submit" class="bc_sub_btn">
                    </form>
                <ul class="bc_social_icons">
                    <li>Follow us:</li>
                    <li><a href="https://www.facebook.com/BleepingComputer"><span class="fa fa-facebook"></span></a></li>
                    <li><a href="https://twitter.com/BleepinComputer"><span class="fa fa-twitter"></span></a></li>
                    <li><a href="https://plus.google.com/+bleepingcomputer/posts"><span class="fa fa-google-plus"></span></a></li>
                    <li><a href="https://www.youtube.com/user/BleepingComputer"><span class="fa fa-youtube"></span></a></li>
                    <li><a href="https://www.bleepingcomputer.com/feed/"><span class="fa fa-rss"></span></a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Main Sections</h5>
                <ul>
                	<li><a href="https://www.bleepingcomputer.com/">News</a></li>
                    <li><a href="https://www.bleepingcomputer.com/download/">Downloads</a></li>
                    <li><a href="https://www.bleepingcomputer.com/virus-removal/">Virus Removal Guides</a></li>
                    <li><a href="https://www.bleepingcomputer.com/tutorials/">Tutorials</a></li>
                    <li><a href="https://www.bleepingcomputer.com/startups/">Startup Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/uninstall/">Uninstall Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/filedb/">File Database</a></li>
                    <li><a href="https://www.bleepingcomputer.com/glossary/">Glossary</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Community</h5>
                <ul>
                  <li><a href="https://www.bleepingcomputer.com/forums/">Forums</a></li>
	   	  <li><a href="https://www.bleepingcomputer.com/forum-rules/">Forum Rules</a></li>
                  <li><a href="https://www.bleepingcomputer.com/chat/">Chat</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Useful Resources</h5>
                <ul>
                    <li><a href="https://www.bleepingcomputer.com/welcome-guide/">Welcome Guide</a></li>
		    <li><a href="https://www.bleepingcomputer.com/sitemap/">Sitemap</a></li>
                </ul>
            </div>
            <div class="col-md-2">
            	<h5>Company</h5>
                <ul>
                    <li><a href="https://www.bleepingcomputer.com/about/">About BleepingComputer</a></li>
                    <li><a href="https://www.bleepingcomputer.com/contact/">Contact Us</a></li>
                    <li><a href="https://www.bleepingcomputer.com/advertise/">Advertising</a></li>
		    <li><a href="https://www.bleepingcomputer.com/write-for-bleepingcomputer/">Write for BleepingComputer</a></li>
                    <li><a href="https://www.bleepingcomputer.com/rss-feeds/">Social & Feeds</a></li>
		    <li><a href="https://www.bleepingcomputer.com/changelog/">Changelog</a></li>
                </ul>
            </div>
        </div>
    </div>
    <div class="bc_footer_bottom">
    	<div class="container">
        	<div class="row">
            	<div class="col-md-6">
                	 <p><a href="https://www.bleepingcomputer.com/user-agreement/">User Agreement</a>  - <a href="https://www.bleepingcomputer.com/privacy/"> Privacy Policy</a></p>
                </div>
                <div class="col-md-6 bc_copyright">
                	<p>Copyright @ 2003 - 2017 <a href="https://www.bleepingcomputer.com/"> Bleeping Computer<sup>&reg;</sup> LLC </a> -   All Rights Reserved</p>
                </div>
            </div>
        </div>
    </div>
</footer>
</div>
<!-- End Footer Section -->

<!-- Start Go to top Section -->

<div class="bc_goto_top">
    <a href="#"><i class="fa fa-chevron-up"></i></a>
</div> 
    
<!-- End Go to top Section -->


<!-- Start Popup Section -->

<div class="bc_popup">
	<div class="bc_login_form">
    	<a class="bc_popup_close" href="javascript:;" title="Close"></a>
        <h4>Login</h4>
        <form action="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;do=process&amp;return=https://www.bleepingcomputer.com/" method="post">
            <div class="bc_form_feild">
                <label for="ips_username">Username</label>
                <input type="text" id="ips_username" name="ips_username"> 
            </div>
            <div class="bc_form_feild">
                <label for="ips_password">Password</label>
                <input type="password" id="ips_password" name="ips_password">
            </div>
            <div class="bc_form_feild">
                <div class="bc_remember">
                    <input id="remember" type="checkbox" name="rememberMe" value="None" checked="checked">
                    <label for="remember"></label>
                    <span>Remember Me</span>
                </div>
                <div class="bc_anon">
                     <input id="anonymous" type="checkbox" name="anonymous" value="None">
                    <label for="anonymous"></label>
                    <span>Sign in anonymously</span>
                </div>
            </div>
            <div class="bc_btn_wrap">
		<input type='hidden' name='auth_key' value='880ea6a14ea49e853634fbdc5015a024' />
                <input type="submit" value="Login" class="bc_sub_btn">
                <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;serviceClick=facebook&amp;return=https://www.bleepingcomputer.com/news/security/keylogger-found-in-audio-driver-of-hp-laptops/" class="bc_facebook_btn"><img src="https://www.bleepstatic.com/images/site/login/facebook.png" width="12" height="24" alt="Sign in with Facebook"> Sign in with Facebook</a>
                <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&amp;module=global&amp;section=login&amp;serviceClick=twitter&amp;return=https://www.bleepingcomputer.com/news/security/keylogger-found-in-audio-driver-of-hp-laptops/" class="bc_twitter_btn"><img src="https://www.bleepstatic.com/images/site/login/twitter.png" width="28" height="24" alt="Sign in with Twitter"> Sign in with Twitter</a>
		<hr />
                <p>Not a member yet? <a href="https://www.bleepingcomputer.com/forums/index.php?app=core&module=global&section=register">Register Now</a></p>
            </div>
        </form>
    </div>
</div>

<!-- End Popup Section -->
    

<!-- Script -->
<script async type="text/javascript" src="https://www.bleepstatic.com/js/redesign/bootstrap.js"></script>

<div id="sidebar-dynamic"></div>
<script>
    window.__TVPage__ = window.__TVPage__ || {};
    __TVPage__.config = __TVPage__.config || {};
    __TVPage__.config['sidebar-dynamic'] = {

        targetEl: "tvp-gallery",
	
        products_info_tooltip: true,
        products_message: "Based on the video you are watching, we think you might be interested in one or more " +
            "of these products. Clicking in this box will show you results from providers who can fulfill your " +
            "request. We may be compensated by some of these providers.",
        products_headline_text: "Sponsored Products",
	        no_products_banner: function() {
            return "<div data-ns='leaderboard' data-pos='' data-collapse='true'></div>";
        },
        title_text: "<span>Recommended Videos</span><span style=\"background-color:#eaeaea;height:5px;" +
            "width:28%;display:block;position:absolute;right:0;top:35%;transform:translateY(-50%);\"></span>"
    };
</script>
<script async src='//videos-bleepingcomputers-com.tvpagecdn.com/tvpwidget/sidebar-dynamic/index.js'></script>
<script type="text/javascript" src="https://www.bleepstatic.com/js/redesign/fancybox/jquery.fancybox.js?v=2.1.5"></script>
<script type="text/jscript">
$(document).ready(function(e) {
    $('.articleBody img').not('a>img').not('.contrib_but>img').click(function(e) {
        e.preventDefault();
                 $.fancybox({'href' : $(this).attr('src')});
    });
});
</script>

<script src="//www.bleepstatic.com/js/fixto/fixto.min.js"></script>

<script type="text/javascript">
$(document).ready(function(){

var content = $('.cz-main-left-section');
var sidebar = $('.bc_right_sidebar');
var count = 0;
var myTimer;

function setEqualContainer() {
        var getContentHeight = content.outerHeight();
        var getSidebarHeight = sidebar.outerHeight();

        if ( getContentHeight > getSidebarHeight ) {
                sidebar.css('min-height', getContentHeight);
        }

        if ( getSidebarHeight > getContentHeight ) {
                content.css('min-height', getSidebarHeight);
        }
}

// creating the timer which will run every 500 milliseconds
// and will stop after the container will be loaded
// ...or after 15 seconds to not eat a lot of memory

myTimer = setInterval( function() {
        count++;

        if ( $('.testContainer').length == 0 ) {
                setEqualContainer();
        } else {
                setEqualContainer();
                clearInterval(myTimer);
        }

        if ( count == 15) {
                clearInterval(myTimer);
        }
}, 500);

        $('#pinned').fixTo('.bc_right_sidebar', {
                 top: 129
        });

        $('#more_dd').click(function (e) {
          e.preventDefault()
        });

        $('.bc_goto_top a').click(function(){
        $("html, body").animate({ scrollTop: 0 }, 600);
        return false;
        });
        jQuery('.bc_login_btn').on('click', function() {
    jQuery('.bc_popup').fadeIn("slow");
  });
        jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });

});
</script>
<script type="text/javascript">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</script>

<script type="text/javascript">
$('.cz-print-icon, .cz-lg-print-icon').click(function(e) {
    e.preventDefault();
    var divToPrint = document.getElementById('.article_section'); 
    var mywindow = window.open('','','left=0,top=0,width=950,height=600,toolbar=0,scrollbars=0,status=0,addressbar=0');

    var is_chrome = Boolean(mywindow.chrome);
    mywindow.document.write($( ".article_section" ).html());
    mywindow.document.close(); // necessary for IE >= 10 and necessary before onload for chrome

    if (is_chrome) {
        mywindow.onload = function() { // wait until all resources loaded 
            mywindow.focus(); // necessary for IE >= 10
            mywindow.print();  // change window to mywindow
            mywindow.close();// change window to mywindow
        };
    }
    else {
        mywindow.document.close(); // necessary for IE >= 10
        mywindow.focus(); // necessary for IE >= 10
        mywindow.print();
        mywindow.close();
    }

    return true;
});
</script>

<script type="text/javascript">

var loginhash = '880ea6a14ea49e853634fbdc5015a024';
var main_nav_hide_flag = true;
var scrollTop =0;
var main_nav_hide_timer = '';

function call_main_nav_hide()
{
 if(main_nav_hide_flag && scrollTop >=100)
 {
  $('header').addClass("nav-up");
 }
}
var cz_header_pos = $('header').offset().top;
$(window).scroll(function() {
	$('header').each(function(){
	var cz_top_of_window = $(window).scrollTop()-100;
		if (cz_top_of_window > cz_header_pos) {			
			$('.bc_goto_top').fadeIn("slow");
		} else {
			$('.bc_goto_top').fadeOut("slow");			
		}
	});

});
var prevScrollTop = 0;
$(window).scroll(function(event){
    scrollTop = $(this).scrollTop();

    if ( scrollTop < 0 ) {
        scrollTop = 0;
    }
    if ( scrollTop > $('body').height() - $(window).height() ) {
        scrollTop = $('body').height() - $(window).height();
    }

    if (scrollTop >= prevScrollTop && scrollTop) {
        $('header').addClass("nav-up");
    } else {
	if (scrollTop >=100)
	{
	 $('header').removeClass("nav-up"); 
	 main_nav_hide_timer = setTimeout("call_main_nav_hide()",5000);
	}
	else
	{
	 $('header').removeClass("nav-up");
	 clearInterval(main_nav_hide_timer);
	}
    }

    prevScrollTop = scrollTop;
});
$(document).ready(function(){	
	$('#more_dd').click(function (e) {
	  e.preventDefault()
	});

	$('.bc_goto_top a').click(function(){
	$("html, body").animate({ scrollTop: 0 }, 600);
	return false;
	});
	jQuery('.bc_login_btn').on('click', function() { 
    jQuery('.bc_popup').fadeIn("slow");
  });
	jQuery('.bc_popup_close').on('click', function() {
    jQuery('.bc_popup').fadeOut("slow");
  });
  

});
$('#bc_drop_tab a').hover(function (e) {
  e.preventDefault()
  $(this).tab('show')
})

$(document).mouseup(function (e)
{
    var container = $(".bc_login_form");

    if (!container.is(e.target) // if the target of the click isn't the container...
        && container.has(e.target).length === 0 && $('.bc_popup').css('display') =='block') // ... nor a descendant of the container
    {
        jQuery('.bc_popup').fadeOut("slow");
    }
});
if($(window).width() < 767)
{ 
	$(".nav-menu").on('click','li', function(){
	$(this).toggleClass('active').siblings().removeClass('active');
 })
}
</script>

<section class="cz-popup">
  <div class="cz-popup-wrapp"> 
  <a class="cz-popup-close" href="javascript:;" title="Close"> <i class="fa fa-times"></i> </a>
    <h4>Reporter</h4>
    <div class="cz-popup-inner-wrapp">
     <h6>Help us understand the problem. What is going on with this comment?</h6>
        <form>
          <input type="hidden" id="comment-id-report" value="0">
         <ul>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Spam">Spam</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Abusive or Harmful">Abusive or Harmful</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Inappropriate content">Inappropriate content</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Strong language">Strong language</label>
                </li>
             <li>
                 <label><input type="radio" name="comment-report-reason" value="Other">Other</label>
                </li>
                <li id="comment-report-other-reason-wrap" style="display:none;">
                 <textarea rows="2" cols="2" id="comment-report-other-reason"></textarea>
                </li>
            </ul>
            <p><a href="https://www.bleepingcomputer.com/posting-guidelines/">Learn more</a> about what is not allowed to be posted.</p>
        </form>
    </div>
    <div class="cz-popup-bottom-wrapp">
    <div class="cz-popup-report-submiting" style="display:none;">Submitting...</div>
     <a href="#" class="cz-next-btn comment-report-submit-btn">SUBMIT</a>
    </div>
  </div>
</section>

    <noscript id="deferred-styles">
        
	<link rel="stylesheet" type="text/css" href="//www.bleepstatic.com/js/cookieconsent/cookieconsent.min.css" />
	<link href="https://www.bleepstatic.com/css/redesign/font-awesome.css" rel="stylesheet" type="text/css" media="all">
    </noscript>
    <script>
      var loadDeferredStyles = function() {
        var addStylesNode = document.getElementById("deferred-styles");
        var replacement = document.createElement("div");
        replacement.innerHTML = addStylesNode.textContent;
        document.body.appendChild(replacement)
        addStylesNode.parentElement.removeChild(addStylesNode);
      };
      var raf = requestAnimationFrame || mozRequestAnimationFrame ||
          webkitRequestAnimationFrame || msRequestAnimationFrame;
      if (raf) raf(function() { window.setTimeout(loadDeferredStyles, 0); });
      else window.addEventListener('load', loadDeferredStyles);
    </script>

        <script type="text/javascript" async src="//s9.addthis.com/js/300/addthis_widget.js#pubid=ra-561517d2c7f964d6&domready=1"></script>


</body>
</html>