Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu Custom Desktop Resolution


  • Please log in to reply
10 replies to this topic

#1 Glunn11

Glunn11

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Idaho
  • Local time:11:37 PM

Posted 10 July 2007 - 11:23 AM

Hello BC!
I've recently installed Ubuntu as a second OS on my computer. I realized that I have the choice of 1024x768 OR 1280x1024, but no 1280x720.
I have read that modification of your "Screen" section of the xorg.conf file is supposed to work, but when I add "1280x720" and restart, it doesn't show up on the Screen Resolution options drop-down menu.
EDIT: If it is needed, my refresh rate is 75, and my video card is Intel 82945G.
Help?
Thanks!
-Glen

Edited by Glunn11, 10 July 2007 - 11:23 AM.


BC AdBot (Login to Remove)

 


#2 BlackSpyder

BlackSpyder

    Bleeping Big Rig


  • BC Advisor
  • 2,456 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Huddleston, VA USA (Home Sweet Home)
  • Local time:01:37 AM

Posted 10 July 2007 - 07:58 PM

Are you having issues using either of the other resolutions?

Also which display settings box are you using? there are 2 on under Admin and one under preferences. Ensure that the Admin Display settings are set to your monitor (I had issues with my LCD being labeled as a CRT) The path to the Admin Display Settings is System->Admin->Display I'm not sure where the other one is but I believe it is located under System->Preferences-> Display (or Screen Resolution)

Posted Image




#3 Glunn11

Glunn11
  • Topic Starter

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Idaho
  • Local time:11:37 PM

Posted 10 July 2007 - 10:35 PM

I do not have a "Display" option under my Admin menu x_X. And I'm using an LCD monitor.

#4 oldf@rt

oldf@rt

  • Members
  • 2,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Avondale, Arizona USA
  • Local time:10:37 PM

Posted 10 July 2007 - 10:45 PM

Try changing the refresh rate to 60 HZ.

Intel® Graphics Drivers (Production Versions 14.x & 15.x) dynamically support a wide range of display modes depending upon the monitor and computer configurations. A display mode is a set of data for providing a viewable image on a given display. This data includes the active pixel resolution (width and height such as 800x600), corresponding refresh rate (such as 60Hz), and color depth (such as 16-bit).

Specifically, the Intel Graphics Drivers support the display modes described within a monitor Extended Display Information Data (EDID) and the custom display modes that are defined within the Video BIOS Table (VBT) by the computer manufacturer, as well as a set of static modes (for non Plug and Play monitors that have no EDID). EDID information describes the display modes that are supported by the monitor. Only plug and play monitors can provide EDID information to a computer. The set of basic static display modes (at 60Hz and up to 32bpp colors) include 640x480, 800x600, 1024x768, 1280x1024, and 1600x1200.

Taken from intels web site.

Your monitor may not support the 1280 x 720 resolution that you are looking for. Look at your monitor's EDID.
The name says it all -- 59 and holding permanently

**WARNING** Links I provide might cause brain damage

#5 Glunn11

Glunn11
  • Topic Starter

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Idaho
  • Local time:11:37 PM

Posted 10 July 2007 - 11:02 PM

If my monitor doesn't support 1280x720, how come it works on Vista?
Also, there is a sticker below my monitor that explicitly says "1280x720 Widescreen Resolution". ;)
My monitor type, if it is needed, is an eMachines E17T4W LCD Flat Panel Monitor.
Also, the only refresh rate option I am given is 75 Hz.
Thanks, though!

Edited by Glunn11, 10 July 2007 - 11:03 PM.


#6 oldf@rt

oldf@rt

  • Members
  • 2,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Avondale, Arizona USA
  • Local time:10:37 PM

Posted 11 July 2007 - 12:15 AM

that monitor is supposed to support 60, 70, 72 and 75 hz. On some lcd monitors you can change the refresh in the monitor controls. Also, you might need to edit the monitor type in the configuration file, I am not sure where this in ubuntu, but in red hat 7.2 I can only do that as root or su root.

Edited by oldf@rt, 11 July 2007 - 12:15 AM.

The name says it all -- 59 and holding permanently

**WARNING** Links I provide might cause brain damage

#7 BlackSpyder

BlackSpyder

    Bleeping Big Rig


  • BC Advisor
  • 2,456 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Huddleston, VA USA (Home Sweet Home)
  • Local time:01:37 AM

Posted 11 July 2007 - 12:22 AM

The monitor controls (GUI) should be located somewhere in the System->Administration Menu. if you could post what selections you have in that menu i could probably tell you which one it is (In F7 and KUbuntu which have different menus and i cant get to Ubuntu right now). Its a PITA to find I know that. took me forever to find it.

Posted Image




#8 Glunn11

Glunn11
  • Topic Starter

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Idaho
  • Local time:11:37 PM

Posted 12 July 2007 - 06:50 PM

The List in Administration:

Keyring Manager
Language Support
Login Window
Network
Network Tools
Printing
Restricted Drivers Manager
Services
Shared Folders
Software Sources
Synaptic Package Manager
System Log
System Monitor
Time and Date
Update Manager
Users and Groups



And here's my xorg.conf file as it is right now:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "E17T4W"
Option "DPMS"

EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "E17T4W"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x720" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

#9 nforce

nforce

  • Members
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:37 PM

Posted 15 July 2007 - 02:19 AM

From looking around and stuff, I found that linux does not like some of these intel integrated chipsets and for some reason or another (I think incomplete/missing driver information for this type of integrated vid card), and it sometimes doesn't work even if you edit xorg.

The quickest fix that might work is to type
sudo 915resolution
in the console - found this from http://ubuntuforums.org/showthread.php?t=3...t=915resolution

if that doesn't work, it is also described and fixed here - http://ubuntuforums.org/showthread.php?t=326211
The thing that worked the best there was to install the xserver-xorg-video-intel (universe) driver
pg 2 quote

I managed to solve this problem for myself by installing xserver-xorg-video-intel (universe) which appears to be a build of the experimental modesetting branch of the driver. This obsoletes 915resolution. Change the driver in xorg.conf to intel (from i810) after installation.


hope this helps and good luck.

Edited by nforce, 15 July 2007 - 02:41 AM.


#10 Glunn11

Glunn11
  • Topic Starter

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Idaho
  • Local time:11:37 PM

Posted 15 July 2007 - 12:38 PM

915resolution WORKED! Thanks! :thumbsup:

#11 nforce

nforce

  • Members
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:37 PM

Posted 15 July 2007 - 02:01 PM

Glad I could help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users