Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

100% Cpu Usage


  • Please log in to reply
9 replies to this topic

#1 chasrob

chasrob

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 03 June 2007 - 11:27 AM

Programs not responding Task manager shows !100% cpu usage and when I end process on the svchoost process wich seems to take up most cpu usage, computer works ok, I have xp pro I found reference to a microsoft update KB927891 which supposed to cure this bug something to do with auto update? Ihave downloaded this and still no difference I know ending this process can effect other programs but its the only way to get over the problem I have scanned for virus etc., with norton and defender and others but they say no problems found can you help

BC AdBot (Login to Remove)

 


#2 rigel

rigel

    FD-BC


  • Members
  • 12,944 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina - USA
  • Local time:05:55 AM

Posted 03 June 2007 - 03:18 PM

Hi chasrob,

Follow this procedure. It worked many times for me...

1. Click Start->Run, type "services.msc" (without quotation marks) in the
open box and click OK.
2. Double click the service "Automatic Updates".
3. Click on the Log On tab, please ensure the option "Local System account"
is selected and the option "Allow service to interact with desktop" is
unchecked.

4. Check if this service has been enabled on the listed Hardware Profile. If
not, please click the Enable button to enable it.
5. Click on the tab "General "; make sure the "Startup Type" is "Automatic".
Then please click the button "Start" under "Service Status" to start the
service.
6. Repeat the above steps with the other service: Background Intelligent
Transfer Service (BITS)

Step 4: Re-register Windows Update components and Clear the corrupted
Windows Update temp folder

1. Click on Start and then click Run,
2. In the open field type "REGSVR32 WUAPI.DLL" (without quotation marks) and
press Enter.
3. When you receive the "DllRegisterServer in WUAPI.DLL succeeded" message,
click OK.
4. Please repeat these steps for each of the following commands:

REGSVR32 WUAUENG.DLL
REGSVR32 WUAUENG1.DLL
REGSVR32 ATL.DLL
REGSVR32 WUCLTUI.DLL
REGSVR32 WUPS.DLL
REGSVR32 WUPS2.DLL
REGSVR32 WUWEB.DLL

After the above steps are finished. Sicne temporary folder of Windows Update
may be corrupted. We can refer to the following steps to rename this folder
that

1. Click Start, Run, type: cmd and press Enter. Please run the following
command in the opened window.

net stop WuAuServ
(note, you might need to reboot before the net stop command will work)

2. Click Start, Run, type: %windir% and press Enter.
3. In the opened folder, rename the folder SoftwareDistribution to SDold.
4. Click Start, Run, type: cmd and press Enter. Please run the following
command in the opened window.

net start WuAuServ


"In a world where you can be anything, be yourself." ~ unknown

"Fall in love with someone who deserves your heart. Not someone who plays with it. Will Smith


#3 zbd

zbd

  • Members
  • 390 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 03 June 2007 - 08:09 PM

Disable or put to manual unnecessary services.

http://www.pcstats.com/articleview.cfm?art...1494&page=4

#4 mme

mme

  • Members
  • 400 posts
  • OFFLINE
  •  
  • Local time:05:55 AM

Posted 04 June 2007 - 06:29 AM

disable automatic updates until you are able to resolve this issue

#5 chasrob

chasrob
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 04 June 2007 - 08:52 AM

many thanks to your replies, I am afraid I chickened out on your procedure "rigel" and followed" zbd" answer and disabled automatic updates advised by "mme" and its working ok but of course problem still there which will have to resolved at some time . Sorry "rigel" :thumbsup: but I am a complete amatuer at computers so shy away from registry

#6 rigel

rigel

    FD-BC


  • Members
  • 12,944 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina - USA
  • Local time:05:55 AM

Posted 04 June 2007 - 09:08 AM

It isn't a registry fix... just command line commands. That's ok. Just remember to do manual updates about every two weeks.

good luck,

rigel

"In a world where you can be anything, be yourself." ~ unknown

"Fall in love with someone who deserves your heart. Not someone who plays with it. Will Smith


#7 chasrob

chasrob
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 04 June 2007 - 09:13 AM

I fogot to mention "mme"if I put manuel instead of disable would this do the same job ?

#8 zbd

zbd

  • Members
  • 390 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 04 June 2007 - 09:38 AM

Manual only updates when or if you want it updated.

Disable only stops your computer from updating without your approval or knowledge.

#9 mme

mme

  • Members
  • 400 posts
  • OFFLINE
  •  
  • Local time:05:55 AM

Posted 04 June 2007 - 02:24 PM

zbd is right....but this problem seems to happen to a lot of people and i havent really came accross a fix....perhaps someone out there knows of one ....if your cpu is not at 100% then manual is fine...whether you manual or disable it...always check for updates on tuesdays....or even try contacting microsoft...

Edited by mme, 04 June 2007 - 03:08 PM.


#10 chasrob

chasrob
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:04:55 AM

Posted 05 June 2007 - 04:55 AM

Many thanks out there for all your help much appreciated, I should think microsoft should solve this problem looks like it is of there making ,anyway thanks again for your help .from a Brit




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users