Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Os X Networking Issue


  • Please log in to reply
1 reply to this topic

#1 twardnw

twardnw

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:08:17 AM

Posted 30 May 2007 - 11:45 AM

Ok, at one of our clients we have 2 users on Macs. One has no issues whatsoever, the other can't seem to stay connected reliably to the windows network shares. They are both connected to Active Directory via the AD plugin. The one with no issuse connects via wireless (don't think that would make a difference), the troubled one is wired. If the user on the problem machine closes Finder, she then randomly gets disconnected from the network share. If Finder is open, no problems, always connected.

Ideas on what to look for?

BC AdBot (Login to Remove)

 


#2 twardnw

twardnw
  • Topic Starter

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:08:17 AM

Posted 30 May 2007 - 04:24 PM

As I continued my research I stumbled upon this article. I don't know yet if this will resolve the problem, but I like to share my findings with the community.

excerpt from : http://www.macwindows.com/Win2003.html

Windows Server 2003/OS X disconnections

October 29, 2004 -- Paul Kneipp has a problem with Windows 2003 Server disconnection Macs running Panther:

Since upgrading to Windows 2003 Server at our school, OS X clients (10.3) are being disconnected randomly, sometimes even whilst being used. I contacted Microsoft; they couldn't even say if there was a time out setting for the Win 2000 clients, let alone Macs. Under Win 2000 Server, it seemed to be OK.

The problem is, teachers are leaving FileMaker open and then teaching for 5 or 10 minutes; the time it waits before disconnecting seems random. We are going nuts about this.

Most clients are connecting via IP address and they are all authorized users. This problem doesn't seem to happen on the PC clients.

November 1, 2004
Donald Harkin

It happens with us, too. We are using a grading program which resides on a Windows 2003 box. All of our iBooks run Panther. Disconnects happen randomly at any given time.

November 1, 2004
Derek Smith reports seeing the problem with AdmitMac on the network:

I've seen it sporadically here as well. We use ADmitMac to authenticate and automount two volumes at user login. In our case one of the volumes will dismount with the 'puff-of-smoke' animated icon. The volume cannot be remounted during the same session, and on one occasion could not be remounted until after 3 reboots. On one occurrence, both mounted volumes dismounted. ADmitMac automounts using SMB (CIFS). In general, the volume on which the users' files resides is the volume which is dismounted. For our PC users, this volume holds home folders specified in the users' profiles. On our OS X machines, I have ADmitMac use a local user folder.

I mentioned ADmitMac only because it is the method we use to automount volumes at user login. The unexpected dismount is very rare, (three reports - I've only seen it once with my own eyes,) and I have no evidence ADmitMac is responsible. Once the volume is mounted, I believe the OS is responsible for maintaining the connection on the client end, not ADmitMac. The disconnects could very likely come from the server, or perhaps they are even network related. The jury is still out on this one.

Saving problem with Word files

November 8, 2004
Michael Pearson sees this problem with Word files:

At our University we are having the same problem saving Word files on a Win 2003 server. Our magazine labs is using G5s running 10.3.5. Many times Word files on the server can not be saved under the same name, it gives the error that the file is in use or the network share has been closed, neither of which is true. I gave everyone full control for the temporary items folder but we are still having the problem.

March 11 2005
Kevin Myers has the problem with a Linux SMB server:

I have just converted a small office from Windows 2000 workstations to Mac G5s. They're using a Linux server for SMB file sharing, based on Redhat 7 running Samba 2.2.7. The server has been running in this configuration for years without problems.

The G5s are running OfficeX and are exhibiting the exact symptoms as above - occasionally. It's not a disconnection problem. It's linked to the presence of what I assume is a lock file (named "._documentfilename") in the shared directory. It appears that once that is removed (at the server), the file can be saved again from the workstation.

March 14, 2005
Dan Szczepaniak

Our iMac's (USB 2.0) with Office 2004 can not save Word files on our Windows 2000 server. (But my Power Mac G4 Mirror Bay Doors can save Word files to the SMB server.) I have found that if you connect to the server via the IP address, Word can save files, but when opening a folder, there is a delay before you see the contents of the folder. I contacted Microsoft Tech Support about a month ago and they say there is a problem with the SMB protocol and are working with Apple to fix it. Microsoft Tech Support says it's because Word uses a work file. Excel and PowerPoint save files without a problem.

March 14, 2005
Rault Kehlor

I've seen this problem too, but with all file types, not just Word files. We have a Windows 2003 server that we access with Windows 2000 and our Macs (OS X 10.3.8) via SMB. (The server is running Services for Macintosh, but it STILL doesn't allow long file names, so we prefer to connect via SMB.)

Sometimes we can't save a new version of an existing file; other times, we delete a file first, then try to save a new version with the same name, and it still won't let us save it -- we get the message "the file is in use." We've seen this with Word files, Excel files, Peak files, QuickTime movies, etc.

We've had many reports of problems with Excel, where Virex seems to cause the problem.

Troubleshooting advice and potential cause

November 1, 2004
Ronald McCafferty

I have seen this many times, and in many cases have needed to look further into network hardware settings, such as DHCP lease options, router/firewall rules, as in trusted addresses, which contain the hardware (MAC) addresses of each NIC (Ethernet card). Try using the Microsoft User Authentication Module for the OS X machines as well. However, my guess is that something is not configured properly on one of your routers or firewalls.

To prove this, try using an unassigned static IP address in the same subnet as your DHCP scope. See if that machine stays connected. If so, then look at your DHCP settings for the problem. Delete all active leases, set the default lease for a shorter time, then refresh each computer to test.

There is nothing wrong with Windows 2003 Services for Mac, other than it is not the total answer to file services for the Mac.

Suggested Fix

November 15, 2004
Julian Poyntz

I gleaned this off of another Mac site. It seems to have worked here.

1. Go to the Start Menu
2. Select Programs
3. Select Administrative Tools
4. Select Local Security Policy
5. Choose Local Policies
6. Select Security Options
7. Change Amount of idle time required before disconnecting session to 0

Microsoft's fix

November 23, 2004
Joseph Senak has a suggestion for the problem of Windows Server 2003/OS X disconnections, which is similar to disconnection of Windows clients:

The timeout problem sounds very much like Knowledge Base article Q297684. I applied that fix for Macs and a Windows 2000 Server share which seemed to work just fine.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users