Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Epson Stylus C64


  • Please log in to reply
3 replies to this topic

#1 xanderthemighty

xanderthemighty

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:California
  • Local time:12:02 AM

Posted 29 May 2007 - 10:46 AM

I've run into a problem on an Epson Stylus C64, I don't seem to be able to print... well, it goes through the motions of printing... the ink cartridges move as if they are printing the words however nothing comes out but a blank piece of paper. It isn't the ink cartridges themselves either because they've been changed out and are brand new. I'd appreciate any help you can offer. Thanks in advance.




~ xanderthemighty

BC AdBot (Login to Remove)

 


#2 wildchild2

wildchild2

  • Members
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Queensland, Australia
  • Local time:06:02 PM

Posted 29 May 2007 - 11:13 AM

Have you done the head cleaning and the nozzle tests? They should be somewhere in the menu on the front. Just flick through the options until you find them. I think the "colour copy" button activates.
I have an Epsom (diff. model) and I have been using non genuine cartridges and found that I have to clean the heads a lot more often than with genuine ones
Posted Image

Custom Desktop,Intel Core2 Duo, GeForce 8400 Graphics,Vista Home, 2Gb ram, 160Gb & 250Gb Sata HDDs, Triple Monitors, Belkin keyboard and mouse, Avast Free, Compaq Laptop, Firefox browser, Thunderbird email, HP C5380 All-in-one Printer,Speedtouch Modem,Netgear Router, ADSL Broadband, Fuji Digital Camera.

#3 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:04:02 AM

Posted 29 May 2007 - 11:15 AM

Look in your manual on how to clean the print head. You can try soaking the cartridges in a small dish with a small amount of warm water. Make sure they're seated in the carriage properly. Are these OEM cartridges or generic?
Mark
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#4 xanderthemighty

xanderthemighty
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:California
  • Local time:12:02 AM

Posted 29 May 2007 - 11:20 AM

The cartridges are fine and I've cleaned the print heads but I still get the problems.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users