Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Php


  • Please log in to reply
13 replies to this topic

#1 Che Guevara

Che Guevara

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 18 May 2007 - 08:38 AM

so im trying to install PHP on my server now. I've looked around and been trying for about a day now. I read a few tutorials and it says edit the php.ini so i changed the ext directory and the document directory. R:\Website for document and R:\php\ext for ext. Then I edited the httpd.conf for apache. it says add

LoadModule php5_module "R:/php/php5apache2.dll"
PHPIniDir "R:/php"
AddType application/x-httpd-php .php

but i also tried

LoadModule php5_module "R:/php/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "R:/php"

in that order and I'm not sure where I tried putting it in 3 places so far at the bottom of the file, after all the load modules, and after

AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz

Each time i couldn't start apache service. I copied the php5ts.dll to my windows folder already. Any ideas on what I could be doing wrong

Edited by Che Guevara, 18 May 2007 - 08:39 AM.

Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

BC AdBot (Login to Remove)

 


#2 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 18 May 2007 - 01:47 PM

Localhost server you mean?

#3 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 18 May 2007 - 08:24 PM

yes its a local host server
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#4 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 19 May 2007 - 02:22 AM

Did you download PHP and Apache separately? If so, why not try a integrated one? Which makes your life easier.

And is R: your local drive too?

#5 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 19 May 2007 - 02:56 PM

R: is the drive i have both Apache and PHP on and i tried XAMP as a combined version but it didnt work then either are there any that you would recomend
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#6 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 20 May 2007 - 12:42 AM

What problem did you encounter when u try to install xampp?

#7 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 20 May 2007 - 01:56 AM

it said PHP was installed on apache... it said apache 2.2/PHP 5...... etc.... but when I used a php documents like for instance an index.php document as simple as one that showed the current date it wouldn't show up except in code that i couldnt understand.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#8 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 20 May 2007 - 03:47 AM

It might be that your apache is not working. Is the service of apache working? Did your firewall block port 80? or did you use port 80 for other stuff?

Now what I suggest you to do is to uninstall/delete everything that has to do with apache/php etc. If you already had installed apache/php and/or xampp. Please remove them all completely. If you are unable to do so, please let me know why and if there's any error.

Next, if you are able to remove everything, please download a new version of xampp.

Here consist of some help if you met with any problem while installing or after installing xampp.

Let me know of any problem you face.

#9 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 20 May 2007 - 08:12 AM

actually i have apache running off of 157 and it does work port 80s blocked by my isp so i have to use that
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#10 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 20 May 2007 - 08:29 AM

Alright. Thanks for the information.

Do what I have posted above, and remember to change the port of apache.

#11 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 21 May 2007 - 08:59 AM

Ok, so I did what you said and i everything was working fine my website is up and now im trying to get PHP-NUKE to work. I get it installed fine im guessing except a screen pops up saying

"PhP-NUKE
there seems to be a problem with the MySQL server, Sorry for the Inconvenience.
We should be back Shortly."


any ideas on what it could be. I tried installing it as a database a few times and then i used the installer they had and it didnt do anything to change that. So I'm guessing it really is the MySQL server. I was wondering though in the PHP-NUKE config file it says chose the server type and i put MySQL but my MySQL server is in MySQLD mode could that be a problem and if so how would i change that to regular MySQL mode it has buttons I can use in teh SQLMyADMIN console or what ever put the MySQL version is faded and i cant chose it.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#12 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 21 May 2007 - 09:11 AM

I had never use before PHP-NUKE. Thus, I'm not very sure about the problem.

However, a quick search gave me this. and it seem to be able to solve your problem.

Try it and let me know how is it.

#13 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:01:17 PM

Posted 23 May 2007 - 09:16 AM

well i got php nuke working thanks for the help
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#14 Nikas

Nikas

  • Members
  • 650 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Singapore
  • Local time:02:17 AM

Posted 23 May 2007 - 10:29 AM

well i got php nuke working thanks for the help


Well. That's good for you.

But do you mind explaining how you do it? It can be used for a reference for me as well as others.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users