Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Web Server


  • Please log in to reply
28 replies to this topic

#1 Che Guevara

Che Guevara

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 12 May 2007 - 07:01 PM

So I'm still trying to get my webserver running and I decided to use site to help redirect the port because I think its possible that Charter (my cable ISP) is blocking port 80. Anyways, I used there open port tool at http://canyouseeme.org/ to see what port was open that I could use. Heres the problem, I checked several ports and none could be seen. Basically, all my ports are closed at least it says that, my firewalls down, not really sure what to do next. Any ideas?
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 12 May 2007 - 10:17 PM

Are you using a router? Most routers (that I can think of) have firewalls enabled by default.

#3 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 13 May 2007 - 06:51 PM

yes i am using a router, but I already thoughtr of that and disabled it. I even tried putting my static IP in the DMZ anbd still nothing.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#4 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 13 May 2007 - 07:13 PM

Something that you are running is blocking the ports. If all of your firewalls are disabled, then you should still be able to see the unblocked ports. Have you tried flushing your iptables? Instead of disabling the firewall on your router, did you try forwarding the port?

#5 oldf@rt

oldf@rt

  • Members
  • 2,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Avondale, Arizona USA
  • Local time:03:16 AM

Posted 13 May 2007 - 07:25 PM

My isp, Cox, has blocked usage of home/personal computers from functioning as a web server. Under your ISPs acceptable usage policy you might find a hint.

Here is part from COX: Commercial Use. The Service is designed for personal, non-business related use of the Internet and may not be used for commercial purposes. You may not resell or otherwise charge others to use the residential Service. You agree not to use the Service for operation as an Internet service provider, or for any other business enterprise, including, without limitation, IP address translation or similar facilities intended to provide additional access. Cox Business Services offers commercial Internet services.

Cox does provide web space for personal web pages, I dont know about your isp .
The name says it all -- 59 and holding permanently

**WARNING** Links I provide might cause brain damage

#6 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 13 May 2007 - 08:19 PM

ok so i called my ISP Charter and asked them after like 20 min of going through many computer illiterate people. It was funny though cuz i asked someone, "I was wondering, does charter allow you to use a computer as web server and let people access it through their internet?" and some girl paused for a second and was like... wait, what? what do you mean? so i said it again and she's like well how bout i transfer you to a different area where they should be able to help you. ANYWAYS, so they don't block any ports and they allow it so i don't really understand what could be the problem.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#7 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 13 May 2007 - 09:53 PM

Being as how we know zip about your setup, neither do we.

#8 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 13 May 2007 - 10:13 PM

Ok here are my specs

Processor: AMD Athlon 64 X2 3800+
MOBO: MSI K9N4 SLI
Video: EVGA e-Geforce 7600GS
PSU: stalk crapy chinese one or something soon to be replaced)
Memory: 2x OCZ 512MB sticks
HDD: 120GB WD and a 80GB WD
LaN: wired NVIDIA nForce Networking Controller (build into MOBO) but also have a Realtek RTL8139 I have disabled)
Sound: build in something doesnt matter really

I have Sygate Personal Firewall
a Linksys WRT54GX2 router
and of course a crapy modem my ISP gave us to use
need anything else?

Edited by Che Guevara, 13 May 2007 - 10:14 PM.

Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#9 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 14 May 2007 - 07:25 AM

Operating System would really be helpful.. :thumbsup:

#10 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 14 May 2007 - 07:44 AM

oh yeah Windows XP SP2
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#11 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 14 May 2007 - 08:28 AM

1. Port forward Port 80 on your router.
2. Allow port 80 through Sygate
3. Allow port 80 through your Windows firewall.

That's all it can be. One of those three is blocking the port, unless you have some other firewalling software installed, like maybe some trial version that you forgot about?

#12 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 14 May 2007 - 09:27 AM

it cant be any firewall i've disabled them all. I've tried port forward on port 80 canyouseeme.org does not see port 80 open.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#13 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:16 AM

Posted 14 May 2007 - 09:40 AM

If all of your firewalls were disabled, you would see a ton of ports open. There is no other way of them being blocked. Just a thought, do you have more than one computer on your network?

I've tried port forward on port 80

You have to be a bit more specific. You tried to port forward on what? Your router? Sygate?

#14 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:16 AM

Posted 14 May 2007 - 09:56 AM

I disabled all my firewalls and i used my router to forward it. Then I tried using No-Ip.com to forward it too since i thought it was because of my ISP. Using that I forwared it to some random port and forwarded that port on my router. Still no glory.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#15 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:06:16 AM

Posted 14 May 2007 - 10:23 AM

My guess it is the linksys. Do you have two computers on your network? If so can you telnet to port 80 on your web server from that other computer? If so, its not a software firewall issue, but a hardware one which points to the linksys.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users