Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Phpmyadmin Will Not Run


  • Please log in to reply
2 replies to this topic

#1 Peter R. Fletcher

Peter R. Fletcher

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Location:Cambridgeshire, United Kingdom
  • Local time:03:48 AM

Posted 08 May 2007 - 09:57 AM

I am running Vista Ultimate on a Asus P5LD2 motherboard with a 2.8 GHz Intel D CPU, 3 GB of memory and lots of disk space. No problems with other applications or services. IIS 7.0 is installed and running, and I can browse to files in inetpub/wwwroot.

I have just installed PHP 4.4.7 (this is for testing prior to final publication via a web hosting service, and the hosting service's server doesn't support 5.x) and the latest version of MySQL (5.0.37). Both seem to be working properly. Browsing a test file invoking phpInfo () produces the expected output (including confirmation that MySQL support is loaded), and the MySQL command line connects to the server and responds sanely.

I installed phpMyAdmin 2.10.1 according to the instructions (into inetpub\wwwroot\phpMyAdmin). When I tried to use the phpMyAdmin configuration wizard, I got a "page not found" error, which I thought rather odd. I confirmed that a copy of my php test file placed in the appropriate directory worked correctly, so there wasn't a path name or permissions problem, but I then decided to create a config file manually rather than investigating further. I mention this problem in case it provides a clue to what follows.

Now, invoking phpMyAdmin/index.php produces a blank page with a two-tone red error flag at the top, which says, supremely unhelpfully, "phpMyAdmin - Error". I have tried a few minor tweaks to config.inc.php without changing things by one iota.

Does anyone have any clues as to what might be going on

Edited by Peter R. Fletcher, 08 May 2007 - 09:58 AM.

Peter R. Fletcher

BC AdBot (Login to Remove)

 


m

#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,389 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:48 PM

Posted 10 May 2007 - 10:39 AM

The $cfg['PmaAbsoluteUri'] = variable is set correctly? Also make sure the host is set to localhost.

#3 Peter R. Fletcher

Peter R. Fletcher
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Location:Cambridgeshire, United Kingdom
  • Local time:03:48 AM

Posted 10 May 2007 - 01:25 PM

Thanks for your response.
It was a combination of errors and misunderstandings, now fixed. https://sourceforge.net/forum/message.php?msg_id=4306227 points to one of the messages in a thread which gives more details.
Peter R. Fletcher




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users