Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Apache Web Server


  • Please log in to reply
3 replies to this topic

#1 Che Guevara

Che Guevara

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:00 AM

Posted 25 April 2007 - 10:32 AM

So I'm trying to make my computer into a web server and I'm obviously using Apache. I went through the httpd.conf file and changed all the directories to what i wanted them but its not really working as of yet. My dilemma is that the folder i want as root isn't working as it. It keeps going to the htdoc folder and using files there. I can just move all my files there, but I want all these on a specific hard drive I have on my computer instead of my programs folder if you know what I mean.

Also second question, I'm having problems getting one of my web pages working correctly. I have these images set at all these different places and none of them show up. When I right-click and select view image it shows just fine but its not showing any on my web page.


Well any help would be much appreciated, and thanks for your time in reading this.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

BC AdBot (Login to Remove)

 


#2 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:00 AM

Posted 25 April 2007 - 01:16 PM

Never mind with my problem on the pictures I fixed that.
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA

#3 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:04:00 AM

Posted 25 April 2007 - 03:51 PM

You should just have to change your document base in httpd.conf.

#4 Che Guevara

Che Guevara
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Minnesota
  • Local time:05:00 AM

Posted 25 April 2007 - 04:04 PM

Well, I looked through it a couple more times and I did change all things that said root including Server Root, Document Root, and a Directory thats suppost to be the same as Document Root. I'm using Apache through a program called XAMP tho do you think there could be a conflict or maybe another config file i haven't found
Che

"Shoot, coward--you are only going to kill a man." - Che Guevara as he was then murdered as an unarmed prisoner by the Brazilian army aided by the US CIA




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users