Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing Or Corrupt Ntoskrnl.exe But Not Always!


  • Please log in to reply
2 replies to this topic

#1 ecuyetx

ecuyetx

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:03 AM

Posted 12 April 2007 - 05:48 AM

Here is a tricky one. "Windows Cannot start due to missing or corrupt NTOSKRNL.exe".
However we only get the message if something is plugged into the USB port when it is booted up.

It started when the PS2 mouse stopped working. Other PS2 mice did not work either, so it must be the port I thought. So we decided to use a USB mouse, but if we boot with it plugged in we get this message and it won't boot. The same happens with a flash memory key in the USB port. If we boot and then plug it in, it's fine.

I have looked at lots of sites with answers to this problem, but none of them have resolved the problem.

I have replaced the file with another from a different machine.
I have rebuilt the boot.ini file using bootcfg command
I have tried bootfix but not fixmbr, as there was a warning that the MBR was non-standard and it may not work. This may be due to the recovery partition on the hard disk which I don't want to lose.
I have tried another PS 2 mouse, I have tried another Keyboard.

I stopped the problem with a 'system restore' but it came back when I plugged the (USB) printer back in.
Pulling my hair out here! Any ideas?

BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:03:03 AM

Posted 12 April 2007 - 05:55 AM

Posted Image to BC ecuyetx

Read this There are a few suggestions which make sence here. Please post back if not succcesfull and we continue our little quest.

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:10:03 PM

Posted 12 April 2007 - 06:21 PM

You'll have to replace the file with the exact same version that was on the system in the first place. That "may" fix it.

Microsoft points to the boot.ini file in this article: http://www.microsoft.com/technet/archive/w...t.mspx?mfr=true

But, since it's associated with your USB ports, I'd suggest updating your motherboard chipset drivers also.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users