Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vsmon.dll Or Exe Always Running & No Usb Function


  • Please log in to reply
5 replies to this topic

#1 kacho

kacho

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 11 April 2007 - 06:34 AM

guys, i've got this weird problem. my zonealarm dissapeard a couple of nights ago and since then this vsmon.dll or exe keeps running in the process list. it goes on and off, on and off repeatedly. my cursor always displays the busy hourglass icon even when i'm not running anything. i tried to uninstall zonealarm but to no avail, saying like it cannot uninstall ZA and there is an error or something is missing. and when i shut down my pc there a window that's popping up saying vsmon.dll is missing/error/damaged.

and another this that happened at the same time as this, is that my usb ports would not detect anything that is connected to it. i've got a webcam, printer, speakers connected to the usb. it would not detect anything. i've tried unplugging all the devices the restarting the pc, and after i restart i plug one device and windows cannot detect it on any of the usb ports on my pc.

does anyone have any idea on how to fix these problems? specially the usb not detecting anything.

thanks.

BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:12:52 PM

Posted 11 April 2007 - 07:04 AM

In order to completely remove ZA+/ZAP from your system, please do the following. If any of the steps below do not apply to you, or you are unable to perform the function listed, CONTINUE on to the next step.

If you plan to reinstall then, before starting, please be sure to download the latest version. Remember that while the download versions are called Trial, it becomes the FULL version once you enter your current, valid license key. To find out if your key is valid, click Configure > Change Key. Your expiration date and time will appear directly underneath the license number. If your key is not valid, use the following link to renew: http://www.zonelabs.com/renew
DOWNLOAD LINKS :
For ZoneAlarm:
http://www.zonelabs.com/zadownload
For ZoneAlarm Pro:
http://www.zonelabs.com/zapdownload

==============================================


** Use ONLY the primary Administrator account if possible (i.e. log in with the username ADMINISTRATOR). If you are unable to do so, then try a user account with Administrative rights. ** If the machine is part of a domain, you should have the Network Administrator help you.

Please do the following. If any of the steps below do not apply to you, or you are unable to perform the function listed, please continue to the next step. If you are unable to remove any files, make a note of the file AND location (example: C:\WINNT\SYSTEM32 \VSDATA.DLL).

Open the ZoneAlarm Pro program, go to the OVERVIEW -> PREFERENCES tab, and make sure the Load At Startup box is UNchecked. Close the ZA Control Panel.
Right-click on the ZA icon, and select Shutdown. Wait several minutes before going on.
REBOOT.
You should now have no ZA processes running on your system.
Now click Start -> Programs -> Zone Labs -> Uninstall. Be sure to say YES to any security checks.
REBOOT.
To make sure that you can see any ZA system files, if they are still on your computer:
a. Right-click on Start button, then left-click on Explore. When the Windows Explorer panel appears, click View -> Options. Click the "View" tab, then click the "Show all files" radio button.
b. Make sure you also UNcheck the box to "Hide Protected Operating System Files" if you have one.
c. Click OK.

IMPORTANT NOTE: Making modifications to system files may disable crucial functions of your Windows operating system. We strongly suggest re-enabling the "Hide files and folders" feature once all ZA files have been removed.
Click on Start, then Search or Find, and select Files. Make sure that the location box is set to search your local hard drive (usually C :thumbsup:, or All Local Drives.
Type each of the following exactly - delete any folders found:
zonelabs
“zone labs”
“Internet logs”


Type the following exactly - delete any files found in \Windows or any subfolder below it, or in your \Temp folder):
vsdata.dll
vsdata95.vxd
vsdatant.sys
vsmon.*
vsmonapi.dll
vsnetutils.dll
vspubapi.dll
zaplus.*
zapro.*
zllictbl.dat
zlparser.dll
zonealarm.exe

vsutil.dll (please right-click filename, then Properties -> Version.
Do NOT delete this file unless it it a Zone Labs file!)

Type the following exactly - delete any files found in any folder with "Programs" in the pathname:

zapro
zonealarm
"zonealarm pro"


Make sure your Recycle Bin is empty (right-click and select Empty).
REBOOT
NOTE: If you received an error message upon deleting the files, or if the original programs remain in the Programs list, or if the problem persists after this, then it is likely that the TrueVector Service is still running. In that case please continue on to the next section.
****************************************
IF YOU COULD NOT DELETE ALL FILES
** Start with #1. Once you successfully remove all the files, DO NOT GO ON. At that point, Empty your recycle Bin, and reboot.
Make a list of the files that you could not remove, and try to delete the files at each step.
Click Start -> Control Panel -> Services. Find the TrueVector service. Stop the service. If you have a password set on ZAP you will need that password in order to shut down the service. Once the service is stopped, delete the files as described above, and reboot. If you get a message that the system is unable to shut down the service, leave the Services window open and continue to #3.
Change the startup mode for the TrueVector service. Normally it is set to Automatically start. Change this to Disabled, then reboot without the service running. You should then be able to delete the files as described above. If you are unable to change the startup mode for the TrueVector Service, continue to #4.
Click Start -> Search, and search your hard drive for a file named VSMON.EXE. Make a note of the exact folder this file is located in, and leave this Search window open. Now open a command prompt window (Start -> Run -> type CMD). Type the following commands, hitting the ENTER key after each one. Substitute the actual folder name for .
CD (ex: "CD C:\WINNT\SYSTEM32\ZONELABS") VSMON.EXE -UNLOAD (wait up to a minute for the service to shut down)
Then delete the files as described above. If the service is still unable to shut down, or gives an error, continue to #5.
Using the same search as before, locate the file named VSMON.EXE. Right-click on the filename, and rename this to VSMON.OLD, then reboot. Now you should be able to delete the files as described above. Once you remove the files and empty the Recycle Bin, be sure to rename this file back to the original name. If you received any errors, continue to #6.
You will need to create a boot disk. Use the instructions located at the link below :
http://support.microsoft.com/default.aspx?...B;en-us;q119467
Important - If you have SCSI hard drives, you MUST include the SCSI drivers on your boot disk, or you will not be able to access the hard drive! Use the instructions from Microsoft to boot the system. Delete the file(s) as described above:
EXAMPLE : You were unable to delete the file C:\WINNT\SYSTEM32 \VSDATA.DLL. You would type
DEL C:\WINNT\SYSTEM32\VSDATA.DLL
Continue until you have deleted all of the remaining files on your list.
If you receive an error trying to delete these files because they are "hidden", "system" or "read-only", you will need to change the attributes of the file before deleting. At the command prompt, type the following:
ATTRIB -A -H -R -S C:\WINNT\SYSTEM32\VSDATA.DLL DEL C:\WINNT\SYSTEM32\VSDATA.DLL
Remove the boot disk once you are done deleting all the files mentioned, and then reboot the system normally (CTR-ALT-DEL). The settings should be back to the original installation defaults.

#3 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:52 AM

Posted 11 April 2007 - 07:22 AM

Looks like a common problem with ZoneAlarm, and vsmon.dll:
Help! Zone Alarm Problems - SpeedGuide.net Broadband Community
Huge problem with ZoneAlarm 6.1.737.000 - General - ZoneAlarm User ...
Computer Forums - I Need Some Quick Help Plz!!!!!
Re: Huge problem with ZoneAlarm 6.1.737.000

Edited by tg1911, 11 April 2007 - 07:22 AM.

MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#4 kacho

kacho
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 11 April 2007 - 08:38 AM

thanks for the fast reply peeps.

i have already removed za from my system. and the vsmon problem in no more.

thanks for your help.

what i have now is that the usb functions on my pc are still non operational.

i've done a repair install on my winxp. just finished it awhile ago. but still usb functions are none. i've tried reinstalling the motherboard driver, but no avail.

any idea how to fix this?

i am currently searching for usb drivers on the nmet

#5 zbd

zbd

  • Members
  • 390 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 11 April 2007 - 09:40 AM

Same problem with suggestions.

http://www.daniweb.com/techtalkforums/thread17703.html

#6 kacho

kacho
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:06:52 AM

Posted 11 April 2007 - 09:42 PM

thanks!

in the device manager, i tried on of the suggestions on removing or uninstalling the usb controllers but sad to say there's nothing there. there's no usb controllers in the devive manager.

as i've said earlier, i've tried to do a repair install on xp and reinstalled the motherboard drivers still there's nothing, no usb connectivity or any indication that there's any usb on the device manager.

i'm at a loss here.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users