Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


16 Bit Ms-dos Subsystem Error Ntvdm Cpu Has Encountered An Illegal Instruction

  • Please log in to reply
2 replies to this topic

#1 purrington


  • Members
  • 3 posts
  • Local time:04:48 PM

Posted 09 April 2007 - 03:46 PM

Hello to whoever can help with this....

Once I click the "view and modify" button in Canon Zoombrowser, I have the option of clicking the "edit image" button which then normally takes me into Adobe Photoshop (I have version 5.0 that came with the Canon G3 digital camera I have).

It has not given me any problem in the past, until recently and it may have happened when I installed a Canon MP600 printer about a week ago. The printer itself works fine, now that the HP 1100 laserjet has been uninstalled and a couple of HP printer drivers were removed (which was a chore). The Canon didn't initially work properly from the USB connection until the laserjet was ultimately removed from LPT1.

However, ever since then, this problem with Zoombrowser and Adobe pops up in a window: 16 bit MS-DOS Subsystem.

The actual message is:

The NTVDM CPU has encountered an illegal instruction.
CS:0541 IP:01ae OP:ff ff ff 4e 00 Choose "Close' to terminate the application.

with two options (that both lead nowhere): "Close" or "Ignore"
If I choose "ignore" (the next three times), the third line changes as follows:

CS:0541 IP:01af OP:ff ff 4e 00 00 Choose "Close' to terminate the application.

then it's:
CS:0541 IP:01dc OP:ff ff ff 00 00 Choose "Close' to terminate the application.

and then finally it's:
CS:0541 IP:01dd OP:ff ff 00 00 2f Choose "Close' to terminate the application.

and then after that I just merely close the now entirely black window box.

I thought the problem might reside with some malicious and clandestine spyware, adware, any type of malware, but scans are consistently squeaky clean, including with Bitdefender. I scanned with Spyware Blaster, Spyware Doctor, Ad-Aware, Spy Sweeper, SpyBot Search and Destroy......and all turn up nothing.

So, I'm wondering if somehow, the installation of the Canon printer or the uninstallation of the HP laserjet, or of the HP drivers has somehow caused the problem. I uninstalled and re-installed the camera sofware components, including both Zoombrowser and Adobe photoshop 5, with no luck.

I've run HijackThis and saved a log of it - but all looks good to me, but realise that I'm not a computer expert (I'm more comfortable being in a woodlot sawing up logs with a chainsaw in high mosquito season than I am with trying to diagnose and fix computer problems in a comfortable home office environment). The computer is about 3 years old and has Windows XP SP2.

Maybe the registry needs a repair somewhere but I simply do not have the expertise to go venturing in there.

Does anyone have any inkling as to what the problem might be and how to repair it?

Any help with this would be immensely appreciated.

Moderator Edit: Moved topic to more appropriate forum. ~ Animal

Edited by Animal, 09 April 2007 - 08:02 PM.

BC AdBot (Login to Remove)


#2 tg1911


    Lord Spam Magnet

  • Members
  • 19,274 posts
  • Gender:Male
  • Location:SW Louisiana
  • Local time:02:48 PM

Posted 09 April 2007 - 10:43 PM

See if this helps:
Error Message: MS-DOS or 16-bit Windows-based program - #346, on the Right
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#3 purrington

  • Topic Starter

  • Members
  • 3 posts
  • Local time:04:48 PM

Posted 10 April 2007 - 06:34 PM

No, unfortunately that didn't help. Also, I once again tried uninstalling and then reinstalling both zoombrowser and adobe photoshop but get the same error message.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users