Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ftp Server Setup


  • Please log in to reply
5 replies to this topic

#1 Roger F. Gay

Roger F. Gay

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Local time:06:18 AM

Posted 28 March 2007 - 02:54 PM

I'm trying to set-up an FTP server for the first time. I have downloaded and installed a free home version from Michael Roth:
http://www.michael-roth-software.de/english/1indexe.htm

Very easy to install. Doesn't seem to be anything to it. I've confirmed something is correct by typing:
ftp://username:password@localhost into my web browser after setting up a user account and providing read access to a directory. The correct directory information showed up in my browser.

But then I've tried using my outer-world web address:
ftp://username:password@isr2.mine.nu and it don't work.

Using SmartFTP, I can see that it properly identifes the IP address; then says it connects to the computer. After a while, it says:
"An established connection was aborted by the software in your host machine."

I've also tried through Windows Explorer and get:
"Windows cannot access this folder. .... The connection to the server was reset."

BC AdBot (Login to Remove)

 


#2 ComputerWhizz7

ComputerWhizz7

  • Members
  • 408 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Zealand
  • Local time:05:18 PM

Posted 28 March 2007 - 03:04 PM

In the software somewhere there must be an option to use your outer-world web address. It could be a field where you enter it. Give that a go and let us know how you got on.
I came, I saw, I conquered. - Julius Caeser

#3 Roger F. Gay

Roger F. Gay
  • Topic Starter

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Local time:06:18 AM

Posted 28 March 2007 - 03:10 PM

OK, well: which software are you talking about.

When I use the browser or Explorer, the web address is included, such as:
ftp://username:password@isr2.mine.nu

isr2.mine.nu is the web address.

It's also included when I use SmartFTP. There are spaces to fill in for web address, username, password, and port number.

When I start The Personal FTP-Server by Roth, it identifies my LAN address; which makes me a little nervous but I don't see how the thing will ever work if that's a problem. There is only one options window available from the top menu, with very few tabs and things to set. It was easy for me to check again to see if it's possible to tell it where it is ... it isn't.

#4 twardnw

twardnw

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:09:18 PM

Posted 28 March 2007 - 10:35 PM

Are you attempting to run this from an XP SP2 machine? Did you place exceptions for port 21 and 22 in the XP Firewall?

#5 Roger F. Gay

Roger F. Gay
  • Topic Starter

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Local time:06:18 AM

Posted 29 March 2007 - 01:57 PM

Are you attempting to run this from an XP SP2 machine? Did you place exceptions for port 21 and 22 in the XP Firewall?


Yes and yes. Windows firewall also tried to block the server program and asked if I wanted it unblocked. So the program is listed as unblocked.

#6 Roger F. Gay

Roger F. Gay
  • Topic Starter

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Local time:06:18 AM

Posted 29 March 2007 - 02:53 PM

PROBLEM FIXED

OK, I sort of told a half truth ... saga about working long hours, getting tired, and then doing more detailed technical things ....

Proper settings in the router ... just didn't click the "enable" box ....




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users