Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing "safely Remove Hardware" Icon In System Tray


  • Please log in to reply
7 replies to this topic

#1 lawrancec

lawrancec

  • Banned
  • 92 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 25 March 2007 - 12:12 AM

Hi guys,

For some reason, the "Safely Remove Hardware" icon is no longer in my system tray. I have already checked that I have not disable inactive icons. It was there ever since I got my computer but just a few days ago, it disappeared. Does anyone have any ideas how i could get it back? Thanks!

Lawrance

BC AdBot (Login to Remove)

 


#2 Walkman

Walkman

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 AM

Posted 25 March 2007 - 12:38 AM

The only solution I can think of for fixing that is to simply unplug the device, then plug it back in. Maybe you need to reboot your computer to clear out the memory.

Also, I have devices that I plug into my USB port too, and the icon down in the taskbar doesn't do anything other than take quite a few clicks just to tell you it's ok to unplug something, when you can just unplug it from the port, or just unplug the device, and leave the wire still in the port. Either way, that icon doesn't value much of a usage.

I just tested mine again while I'm doing this, and as long as my device is working, I don't even see a need for it anyway. It told me me that it was ok to unplug my device when I clicked on my icon to unplug my device. I didn't need to click all those mouse clicks and select which item I wanted to unplug... all I do is just unplug my devices, and it's a done deal.

#3 Guest_uhaligani_*

Guest_uhaligani_*

  • Guests
  • OFFLINE
  •  

Posted 25 March 2007 - 12:39 AM

You may be aware that this only concerns USB hardware. IF you have recently unplugged such (Mouse: network facility: camera etc.) then it will remain gone until you plug in again.

#4 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands

Posted 25 March 2007 - 02:43 AM

Rightclick on the time, choose customize notifications and there you can choose what you want to see there.

#5 lawrancec

lawrancec
  • Topic Starter

  • Banned
  • 92 posts
  • OFFLINE
  •  
  • Local time:04:05 PM

Posted 25 March 2007 - 05:57 PM

The thing is, my hardware IS plugged in. It's still usable and it works but its just that the icon in the system tray is missing. Also, in the customize notification menu, the "safely Remove Hardware" icon is not in that list, also, I have never turned it off myself, it just disappeared by itself.

#6 Guest_uhaligani_*

Guest_uhaligani_*

  • Guests
  • OFFLINE
  •  

Posted 26 March 2007 - 12:29 AM

Right click the taskbar, select properties.
Click the tab "Notification area"
Click "hide inactive icons" and then "Customise"
The two items "Safely remove.... and "Your device is.." should be in the list.

If you now (left) click the small message on the right hand side of the window - "hide inactive... you will see three options - make sure you have the one you want selected by default.
It should not have changed status accidentally, but maybe a recently installed program did it by default.

#7 1101doc

1101doc

  • Members
  • 93 posts
  • OFFLINE
  •  
  • Location:Mackinac Island,MI Summer-SA/TX winter
  • Local time:08:05 AM

Posted 26 March 2007 - 02:21 AM

To repair missing icons and other taskbar problems use Taskbar Repair Tool Plus:
http://www.kellys-korner-xp.com/taskbarplus!.htm

For increased functionality, create a shortcut and place it in QuickLaunch.
Right click Desktop>New>Shortcut. In the box that says "Type the location of the item" paste this:

%windir%\system32\RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll

This will offer a nice interface with a list of the USB devices available. Single click to highlight, then select "Stop." Wait for a confimation message. Then unplug. A "Properties" button is also available. I customized my shortcut with the USB plug icon from the default folder. Looks good.
Neurons that fire together, wire together.
posted with Opera

#8 lawrancec

lawrancec
  • Topic Starter

  • Banned
  • 92 posts
  • OFFLINE
  •  

Posted 26 March 2007 - 08:03 PM

Ok thanks guys, I have checked my "custom notifications" and its not even listed in there but the shortcut thing works fine. So THANKS!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users