Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Firewall/system Restore Is "missing"


  • Please log in to reply
2 replies to this topic

#1 science

science

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:10:28 PM

Posted 24 March 2007 - 02:55 AM

This is a chonological overview of the events that brought me to a very lost and confused place.

I think the first time I started to notice any problems, it was about a month ago. ATI had some kind of new drivers to install ((which seems to spam as cli.exe in the task manager. it hogs a lot of space.)) ~ and the other thing that seemed to slow my computer down was Internet Explorer 7. At the time, I thought that maybe my old computer was so old that it couldn't run the new IE7.

But then, a week ago, I was playing World of Warcraft, and the game began to freeze up and crash. I had to reboot the machine to get out of the freeze. This happened on multiple realm/servers for the game, so I began to think it was my computer.

I had defragged my computer a few times, World of Warcraft was the largest file that I couldn't defrag.
The repair.exe file that Blizzard recommends you run first showed no signs of any issues at all.

At the 6th or 7th freeze/crash, also causing me to lose access to one of my characters that the Tech Forum guys can't even help me with ~ I checked to see what the Task Manager was doing. Warcraft was "Not Responding". CPU utilization was at 100%.

I uninstalled WoW, defragged the hard-drives, and ran Spybot S&D, Ad-Aware, and avast!Antivirus. Avast said there were 4 viruses, which I quarentined. I reinstalled WoW, but I was still having my freezing/crashing issues.

I ran the WoW repair.exe utility again, and according to it, there is nothing wrong with the files in the game folder.

I got on the WoW/Blizzard tech forums this morning and explained the procedures that I had taken. One of them suggested to delete certain folders that may have been corrupted and would be re-downloaded into my game file when I next logged into WoW. He also suggested that I check the heat on my CPU, to make sure it wasn't overheating.

Deleting these files did not retrieve my character that I had lost during a freeze, and I still experienced the freeze/crash dilemma.

I then took my computer apart, and the CPU was very hot. So I let it cool down, and then put a couple more fans on it to make sure it wouldn't overheat again. The problem since my very strange, jerry-rigged fan solution has been quite a different one.

A friend in the game suggested I used another anit-virus software called "Antivir". He suggested to shut off any Local Service, Network, and System processes that might not be necessary. He told me that if I received a red X for a warning, that a virus has infected my computer and to check my bank statements.

I downloaded Antivir and ran a scan; it found 5 viruses and said it prevented 1 from starting. I wasn't real happy about Antivir's interface as it would report "Warnings" during the scan and yet there was no way to verify what the "Warning" was about.

It said that to delete the viruses, I would have to reboot the computer and then delete them. I did this. But when I rebooted, it took longer to reboot than it ever had, previously.

Around the same time, I did a registry scan with some "popular software" from download.com. It said it was free to download but not free to use. When I went to purchase the software, I got a warning from my Firefox browser that the Certificate for their site wasn't valid, and to cancel any connection with their site, which I did. ((pctools.com))

avast! was very unhappy that I had 2 anti-virus programs running on reboot. I had turned it off when I installed the other software, but the system start functions became disabled at this time.

I read a lot of different forums, searching for the problems that I was having, using the "red X's system warning" as a place to start. This warning came from terminating a svchost.exe that was running. There are 5 of them running in my Task Manager. Is this OK? The warning says something about "NT AUTHORITY/SYSTEM" and "RPC".

2 sites on the net, one for microsoft, and the other a microsoft/tech-type page, offered solutions to fix the "NT AUTHORITY/SYSTEM" error. One was to go into Admin Tools in Control Settings and change the Service sytem functions.

~~~ At this time, my computer is currently running at 100% CPU utilization even when I'm not running the game; this is new.
~~~~~~~~~~

I tried to do a System Restore, but the System Restore button is *MISSING*.

I can no longer select any icons/shortcuts on my desktop. I can double click on them, but drag and drop is no longer a function. Dragging and Dropping is still enabled.

The Extended Services List from Services in the Admin Tools is Missing. Now I can only see "Standard".

I haven't been able to re-add the function of avast!Antivirus in my notification area or as a start-up function. I can't find any options that allow me to do this.

Windows Firewall for WinXP-Pro service Pack 2 is no longer working. I get the error "Windows Firewall settings cannot be displayed because the associated service is not running. Do you want to start the Windows Firewall/Internet Connection Sharing (ICS) service?" ~ And if I click "Yes", it then says ~ "Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service."

Again, the System Restore button is there, but it does nothing. ((Actually it looks like a little empty windows function, like it's been uninstalled.))

The Quick Launch function I once had in my Taskbar shows up as a great, big line of icons now. I used to be able to just have a few there, and the rest would be in a little short-cut button to access the rest of them. Bascially, I can't change this. They're either all there now, or they're all gone.

Internet Explorer is no longer working. It just won't open anymore. It kinda blinks open for a moment, and then it is gone. Firefox is still working, but they were both working before.

The Desktop is perhaps the more startling problem I have at this point. I can no longer drag and drop anything. Open windows for websites no longer go into the taskbar as a minimized window. This also occurs with the Task Manager, and any other program that I have running. In order to get back to these open items, I have to actually hit Ctrl-Alt-Del to open another Task Manager, and then bring everything to the front.

In the Services area for Admin Tools in the Control Panel, I have tried to "start" the System Restore functions, and a few others that I thought were pertinent. It says there is something else that hasn't been turned on that needs to be, first, in order for these things to work. Avast is also in that category of not being able to "start".

I tried to start in SAFE Mode but I got this ... odd... message that said I had acquired a filesharing program from a place called "freedos.org"; the guy that created it is said to be Pascuale J. Villani. I didn't know if this was SAFE mode...? I didn't know if it was another virus. ((I didn't think SAFE Mode looked like this.)) The "File Sharing" part of the message got me particularly worried.

On Microsoft's site, they also suggested re"creating" the System Restore by typing in %systemroot%\system 32\restore\rstrui.exe. And I swear ~ it said "System Restore can't save your computer now."

BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:28 PM

Posted 24 March 2007 - 04:10 AM

If I were you I would post a HJT log and let the experts have a look at it. It sounds to me that you still have viruses/malware on your system.

Preparation Guide for use before posting a HijackThis Log
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 science

science
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:10:28 PM

Posted 24 March 2007 - 04:15 AM

Thank you, Budapest, I appreciate it. :thumbsup:

I will do the procedure they suggest on the malware/Start Here! page, asap.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users