Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista Readyboost Flash Usb Drive


  • Please log in to reply
4 replies to this topic

#1 Darren De Wilde

Darren De Wilde

  • Members
  • 208 posts
  • OFFLINE
  •  
  • Location:Howell, NJ
  • Local time:02:35 PM

Posted 10 March 2007 - 06:15 PM

Hi all,

Just wanted to make you aware of an excellent blog on ReadyBoost and Compatible Flash Drives. For those readers who do not know about ReadyBoost, it is a Vista utility that allows use of a flash drive as extra cache space as opposed to reading off the HDD.

This is not as efficient as adding extra RAM, but it does make significant difference in performance. The caveat as with all excitable things is that Vista is stringent and anal about the flash drives it will accept to use for readyboost. On inserting your flash drive, go to my comp, right click on the drive, go to properties and click on the ReadyBoost tab. Vista will test the flash USB and let you know if it passed or failed...if it passed you will be shown a dialogue asking you how much space on the drive to use as cache. If it fails Vista will inform you that the drive does not have the characteristics for Readyboost. :-(...

For more info on Readyboost and USB flashdrives, go here..where I got this info from..an excellent guide.

I'll be writing a post on how I made my slow flash drive slip through the net and get vista to accept it as Readyboost enabled..

Darren

BC AdBot (Login to Remove)

 


m

#2 intrac

intrac

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:35 PM

Posted 29 March 2007 - 04:43 PM

I have a TRANSCEND 2GB SD 150x disk (TS2GSD150) which shows compatible on www.grantgibson.co.uk/blog/index.php/2006/09/16/readyboost-chart/
but when I try to use it as a ReadyBoost device, it says not compatible.

I've formatted it to NTFS, 16K and get a reading of around 1779.

You indicated that you have way to get VISTA to accept it. Can you post this?

Thanks.

#3 Darren De Wilde

Darren De Wilde
  • Topic Starter

  • Members
  • 208 posts
  • OFFLINE
  •  
  • Location:Howell, NJ
  • Local time:02:35 PM

Posted 29 March 2007 - 05:04 PM

There is no set in stone way of getting Readyboost to accept a drive, but try reformatting again in NTFS then check the box next to "compress disk to save space" after doing this..I beleive that readyboost interprets this action as one large write and may look upon your flash drive as a more suitable readyboost cache. If it fails click the retest button.

Let us know how you get on....and good luck!!!

#4 intrac

intrac

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:35 PM

Posted 29 March 2007 - 07:17 PM

Actually, I found a method as follows:

1. Plug in the device.
2. Open the ReadyBoost tab on the device properties.
3. Select "Do not retest this device"
4. Unplug the device
5. Open regedit (start->run->regedit)
6. Expand - HKLM (Local Machine)\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\EMDgmt
7. Find your device.
8. Change Device Status to 2
9. Change ReadSpeedKBs to 1000
10. Change WriteSpeedKBs to 1000
11. Plug in the device.
12. Enable ReadyBoost!!!!

It works.

By the way, I don't get the message to compress disk to save space. I can only choose the type of drive - FAT, FAT32 or NTFS, and the size of sectors. I chose NTFS and 16K.

#5 Darren De Wilde

Darren De Wilde
  • Topic Starter

  • Members
  • 208 posts
  • OFFLINE
  •  
  • Location:Howell, NJ
  • Local time:02:35 PM

Posted 30 March 2007 - 12:06 PM

Wow, good on you for finding that about the registry...you will not see a message to compress to save space at the format dialogue stage when using the other method. You choose NTFS and format then, once that is done, close the dialogue then right click the device under computer. There you will see a checkbox for indexing and compress to save space,,,seems that both methods work..yours is more clever..:0)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users