Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu 6.10 Wireless Connection


  • Please log in to reply
6 replies to this topic

#1 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:03:09 AM

Posted 08 March 2007 - 05:41 AM

Well, I finally broke down and install Ubuntu 6.10 after staring at the CD for a month and a half.
The installation was painless and I've been having fun feeling around the OS.

I believe I was able to install my Netgear WG111 v2 USB wireless adaptor with ndiswrapper (after 3+ hours of frustration!)

Now how do I connect to the wireless network?!?

I connect to the internet through a wireless network provided by my landlord. I's good old fashioned 802.11G that works splendidly with Windows (hence my ability to post here)

I go to System>Administration>Networking like the help file said. But I can't seem to get the wireless connection to work. You'll have to bear with me as WiFi isn't my strong suit.

The Wireless connection is listed, but it says that it is not configured. So I click on Properties and it wants to know such things as "Network name ESSID" password type and password.

I just want to get online! It was never this complicated with Windows XP :thumbsup: .

BC AdBot (Login to Remove)

 


#2 tacm

tacm

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:05:09 AM

Posted 08 March 2007 - 08:30 AM

First, go to your network manager(looks like two computer humping) and double click......make sure your wireless adapter is listed as eth1 then go to System>Admin>Networking and enter your ESSID(name of the network), password type(most likely hexadecimal), password, configuration(most likely automatic(DHCP). Remember if you got on-line without a pass word in windoze you might not need all this information(your network might not have encryption) also note that the Ubuntu 6.10 ONLY supports WEP security if you have another type of encryption (wpa) you will need to install something else to make it work. READ THIS THREAD http://www.ubuntuforums.org/showthread.php?t=343977 It was not to long ago I was a noob and WOW what ive learned in just a few short weeks. Have fun, Steve
The day that Microsoft makes a product that doesn't suck, Is the day they start making vacuum cleaners.

#3 Joedude

Joedude

  • Members
  • 337 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sutton Coldfield, West Midlands, England
  • Local time:11:09 AM

Posted 09 March 2007 - 03:44 AM

Also, windows assumes the default usually, although there is a level of detection involved sometimes. Most settings would be a default setting. As far as wireless goes, Linux doesn't assume that. Particularly because of the overly easy way to set up a wireless improperly and have leechers jumping on your bandwidth.
If someone tells you to su rm -rf /
DON'T DO IT!!!!
Be in the know, Bash smart!

#4 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:03:09 AM

Posted 09 March 2007 - 03:50 AM

Linux hates me. :thumbsup:

No matter what I seem to do, nothing works right.

Reading 100 forums, tutorials, primers, and manufacturers websites yields 150 opinions on how to do something.

I tell the Terminal to do something and it laughs evilly in my face telling me access denied. After thousands of years, I stumbled upon the sudo command and things started happening. Nothing useful, apparently.

I'm not even sure what the problem is!

I pray to the Linix Gods for deliverance! I don't have any animals or virgins to sacrifice, but I have some turkey bacon and virgin olive oil if it'll do any good.

#5 Joedude

Joedude

  • Members
  • 337 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sutton Coldfield, West Midlands, England
  • Local time:11:09 AM

Posted 09 March 2007 - 04:29 AM

LOL...I know the frustration you are going through. When I first started, i was much the same. Hang in there, before you know it, you'll be doing whatever you want. Every time you run into a little problem like this, you learn. The more you learn, the easier it'll be. You didn't learn winsdows in a day, don't expect to learn linux in a short tiume either. You're right on the grading curve.

Now, I hate to state the obvious, because it always makes me feel like I'm either talking down, or calling someone stupid. Honestly, I don't intend it too.

Have you called your service provider (Landlord, if I understand it correctly) and asked him for the settings?

Now, having said that, you could do what I do. When I have read and read and read and still can't find the answer to something....I ask Voidmain. He's a Linux guru to the Nth degree. If he can't help you resolve it, he will deffinately point you to where to get the right answer. Also, if it can't be done, or he just honestly doesn't know, he'll tell you right out. However, usually, he walks through the problem with you if that's the case. Be prepared to post logs you didn't know you had if that is the case.

Edited by Joedude, 09 March 2007 - 04:34 AM.

If someone tells you to su rm -rf /
DON'T DO IT!!!!
Be in the know, Bash smart!

#6 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:03:09 AM

Posted 11 March 2007 - 08:07 AM

Okay, apprently the Netgear WG111 USB adaptor and Linux are really, really hard to make work together. But the Netgear WG111v2 USB adaptor is supposed to be somewhat more friendly. Luckily, my friend has one and I borrowed it,

To start fresh, I completely reinstalled Ubuntu.

Then, I installed ndiswrapper from the Ubuntu CD. Everyone said that I need to install the latest version, which I downloaded, but I have been unable to get it to install correctly, so I'm using the one that came on the CD.

I got the latest Windows drivers from Netgear, and extracted them to home/andrew/Desktop.
I ran ndiswrapper and appear to have succesfully installed the WG111v2 adaptor..

I open the terminal:

sudo -i

Password: *****

root@Guardian:~# iwlist scan

lo Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

wlan0 Scan completed :

Cell 01 - Address: 00:09:92:01:A2:04

ESSID:"[b]SF TechConnect[/b]"

Protocol:IEEE 802.11b

Mode:Managed

Frequency:2.412 GHz (Channel 1)

Quality:0/100 Signal level:-64 dBm Noise level:-256 dBm

Encryption key:off

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s

Extra:bcn_int=100

Extra:atim=0

Cell 02 - Address: 00:11:50:F6:F1:C1

ESSID:"[b]McAllister[/b]"

Protocol:IEEE 802.11g

Mode:Managed

Frequency:2.422 GHz (Channel 3)

Quality:0/100 Signal level:-68 dBm Noise level:-256 dBm

Encryption key:off

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s

9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s

48 Mb/s; 54 Mb/s

Extra:bcn_int=100

Extra:atim=0


The two wireless networks I use show up: McAllister which is my primary (the one from the landlord) and SF Tech Connect which is the city's prototype for citywide free wireless. SF Tech Connect is pretty flakey, and is unreliable at best, so i use the McAllister network usually.

Okay, great! Wonderful! Extraoriinary even! But how do I connect?! The computer can see the networks, so how do I tell it I want to connect to the McAllister network?

Looking around, I try this:

root@Guardian:~# iwconfig

lo no wireless extensions.

sit0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:off/any 

Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated 

Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=0/3 

RTS thr:2432 B Fragment thr:2432 B 

Encryption key:off

Power Management:off

Link Quality:0 Signal level:0 Noise level:0

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0


Help!

Edited by Amazing Andrew, 11 March 2007 - 08:08 AM.


#7 kbk

kbk

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Location:Ohio, USA
  • Local time:06:09 AM

Posted 11 March 2007 - 12:33 PM

Try setting your SSID with iwconfig.. If I remember right the command is iwconfig wlan0 essid (your ssid) . Hope that helps. I had a ton of problems with every distro I used and my wireless adapter. It's a real pain, but once you've done it a couple times you can do it in your sleep.
www.thisisbeyondbelief.com




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users