Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Media Player 11 Won't Play Dvd's


  • Please log in to reply
4 replies to this topic

#1 Yorkie

Yorkie

  • Members
  • 110 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 18 February 2007 - 06:45 AM

Hi,

I can't get Windows Media Player 11 to play DVD's I've been on the Microsoft site and downloaded the Microsoft Windows Video Decoder Check up Utility and it says I no longer have a MPEG2 decoder installed. As far as I know this hasn't been deleted.

The error message that comes up when I try to play a DVD is "Windows Media Player cannot play this DVD because there is a problem with digital copy protection between your DVD drive, decoder, and video card. Try installing an updated driver for your video card".

Does any one know how to solve this problem or where I can go to get a free mpeg2/DVD decoder from?


Thanks for your time.

Edited by Yorkie, 18 February 2007 - 07:52 AM.


BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:02:00 AM

Posted 19 February 2007 - 04:52 AM

Here you have the decoder. You have to switch off the DRM in WMP 11

#3 Yorkie

Yorkie
  • Topic Starter

  • Members
  • 110 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 19 February 2007 - 01:24 PM

Here you have the decoder. You have to switch off the DRM in WMP 11


How do I turn DRM of and does this have any effect on what you can play using WMP 11, e.g. I have sky anytime and I'm sure I needed DRM to use this?

#4 Walkman

Walkman

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 19 February 2007 - 05:27 PM

In WMP there is a setting that is on by default, that will protect your files. Actually, it'll hold them hostage on your computer. You need to edit your settings and uncheck the part that says Let Windows Media Player Protect My Files. If you don't uncheck it, then anything you load in there, (discs/files), it will protect them with DRM codes and you won't be able to transfer the files on to other discs or computers.

Do you have a stand alone dvd player to put the dvd in? If so try to see if that movie will still play in it. Also, whenever you load discs/files up using WMP, it contacts the Internet and lets it know what exactly you have/had in the player. Bottom line is that WMP will block you from even transferring or making copies of your own content from your computer. There are more user friendly softwares out there that will do everything WMP does, but doesn't have all the bundled spyware/trackingware in them.

Try these programs:
Media Player Classic
Real Alternative
Quicktime Alternative
VideoLan


You can get them all at: http://www.free-codecs.com ... just look on the left side of the page, and you'll see them all listed there.

You can also grab you a few codec packs if you need them too. But for the most part, those other programs will have the codecs you'll need, plus more.

#5 tundraman

tundraman

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 25 January 2008 - 06:38 PM

First Post:
I just found a solution and joined so I could post it.

I tried everything possible suggested in dozens and dozens of threads with the same problem. I reloaded DX, rolled back to wmp10, played with accelerator settings, reinstalled video drivers, added , deleted and promoted various mpeg2 decoders etc... :flowers: but finally a light went on!

Maybe this is a audio problem and not video at all.

I went into wmp under tools/option/DVD/Advance and found an Elecard Mpeg2 decoder but I was sure that I had originally installed an ac3 filter for audio. I searched my system for the Elecard decoder and found an entry in the "programs" directory. I just renamed the whole Elecard directory to Bak_Elecard and rechecked the wmp and this time it showed the AC3 filter. I tried a couple of commercial DVD's and they both worked!!! :trumpet: :thumbsup:

In case you need the AC3 filter the one that works for me is 1.45b. I tried others but had no audio. I'm not sure about posting links on the site if it's not permissible then please remove it with my apologies. The version they have currently is 1.46 but I haven't tried it.

ac3fillter


I'm pretty sure that once the wrong audio codec is removed the video will play even without the ac3 decoder but you probably won't get audio.

At least that idiotic misleading message is gone!!!!!

btw) You may have a different audio codec showing than mine (Elecard). The idea is that it can't decode the audio so gives a cryptic message about copy protection.

Edited by tundraman, 25 January 2008 - 06:41 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users