Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless Network Ip Problem


  • Please log in to reply
3 replies to this topic

#1 Greyleaf

Greyleaf

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:04 AM

Posted 15 February 2007 - 12:54 PM

Ok, I'll go strait to it I suppose. I've been having problems recently with my home wireless connection between the family's desktop computer and my personal laptop. I'll explain the background on the two computers and the network first, then overview the problem I'm having and the 'solutions' I've experimented with.

So, the two computers:
The Laptop is a Toshiba Satellite L25-S119, with an Intel Celeron M Processor running at 1.50GHz. 192 MB of RAM.
The Desktop is an older version Gateway PC.
Both computers are running Windows XP Home Edition. Both computers have the standard Windows firewall established, and the desktop runs Norton Anti-Virus.

And the Network:
The Desktop is linked to the internet through an ethernet cable routed through a Linksys wireless router, which generates a Access Point, WPA secured network under the name 'linksys'. The laptop links to this network via wireless. It has a Netgear 108 Mbps Wireless PC Card WG511T.

The Story:
The wireless network was set up between these computers a few months ago. Initially, the network seemed to opperate without problem, and for the most part has continued to run smoothly; the only issues I've encourtered were solved by restarting the router. Just recently, though, I've encountered a problem that I've been unable to solve.
The problems began after taking my laptop to a relative's house, where I attempted to log in to their network. Their network, also a Linksys system, was itself proving unstable that day, but I was able to connect for short periods of time. Even though I was able to access internet at this time, however, the connection would continue to read "Not Connected." (I'm not sure if this part of the story is applicable, but I wanted to put it up just in case. One of my theories is that because their network was a Linksys network as well, my computer may have ... for lack of a better word, 'assimilated' the problems.)
Anyways, I took the laptop home and attempted to connect to my wireless network. Previously, it had done this automatically. When it attempted to connect this time, however, it spent nearly half an hour "aquiring network adress", and when this process ended, it read "Limited or No Connectivity." The signal strength was a full 'five bars', but I was unable to access the internet.

I immidiately began searching for the problem. My first action was to reset the router, which did not appear to change anything. I then attempted to turn the wireless of the laptop off, then on using the physical button stationed on the laptop. This, again, did not change anything.

I then went to the network connection area of the computer. I was suprised to see that there were too wireless networks. I opened the properties windows for both. The first, named "Wireless Network Connection", stated "Connect Using: Atheros AR5005G Wireless Network" ... The second, named "Wireless Network Connection 3", stated "Connect Using: NETGEAR 108 Mbps Wireless PC C".

I went through a regement of enabling one, disabling the other, enabling them both, etc, each time resetting the router and laptop. When using the first, it would only allow me to use the Windows network finding ... thing. When using "#3", it would only allow me to use the software that came with the Netgear card.
Either way, however, the result seemed to be the same. They would both continue to scan/search for network address, and never reach it. (Aside note: I noticed that whatever password I put in the WPA access prompt, as long as it was eight degits, it would work the same. It does, however, default each time to password that worked the first time ... so, I doubt this is applicable).

Next, when I tried to "repair" the network, it would end with a message indicating it could not properly renew the IP adress. I looked further, and noticed the IP address read: "0.0.0.0", etc.
My attempted solution to this was to imput an IP address manually into both computers. (For the IP, I looked at what the PC used in the LAN that formed when the computers were linked by ethernet cable). This way, I was able to break through the first wall, but I stumbled on the rubble. Manually setting the IP allowed the wireless network to connect, but neither computer could then use the internet. So, I then set them both back to "Automatically Aquire IP Address", and was right back where I started.

In a final attempt, I ran the command promt: "cmd /k ipconfig"

What I got was:

Windows IP Configuration

Ethernet adapter Local Area Connection:
Media State .........: Media Disconnected
Ethernet adapter Wireless Network Connection:
Media State..........: Media Disconnected


In a final attempt, I asked a friend to look at it, and he created a .bat file with the following text:

ipconfig /release
ipconfig /renew
ipconfig /all
pause
iprenew.bat


This didn't seem to have any effect, however.
I decided it was about time to go to the web for help. I hope I provided enough information to make the problem clear/apparent, and I appologize if this post is verbosely long >_<
Thanks in advance for any help, it will be greatly appreciated.

[PS] Oh, one last note. In the command window my friend's bat opened, I noticed a line: "IP Routing Enabled ......: No". I thought this might actually be the problem, but I couldn't find anywhere to 'enable' it.

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:06:04 AM

Posted 18 February 2007 - 04:46 PM

Can you connect through a wired connection with the laptop? If so, then you've effectively tested the networking components - so it'll then be a wireless issue.

With the wireless, try disabling the security and then connecting. This'll make it easier to troubleshoot - and you can enable the security once the troubleshooting is done.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 919263

919263

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Local time:05:04 AM

Posted 19 February 2007 - 01:57 PM

A few questionsd first:
You stated that the network name at your place is "linksys".
Do you see this network when you do a search for Wireless Networks?
If not, is it possible that the SSID broadcast is disabled on the wireless router? Enable it

Google WirelessMon, this is a nifty application and has a demo for 30 days, run this, it will tell you what all networks are available in your area.
If you have the router on default, it might be on Channel 6, that is the most used channel, try changing this to channel 1.
It is possible that some one in the neighborhood just installed a new wireless router and that is interfering with your network.

Manual IP address schema is a good practice along with the MAC Address fitering utility, but when you do this make sure that you are updating the DNS and the Default Gateway as well.
To find the DNS, go to the Desktop, click >Start>run and type CMD and hit enter
Type ipconfig /all
Get the DNS server addresses from here, there will be 2 of them.
Manually enter the DNS addresses into the DNS fields.
Also here check what is your default gateway, once you have it, try to ping it ...



Let us know how this worked...

919263

Edited by 919263, 19 February 2007 - 01:59 PM.


#4 Greyleaf

Greyleaf
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:04 AM

Posted 20 February 2007 - 12:04 PM

Thanks for the recommendations :thumbsup:

I tried some various tips from here and a couple other places, and I'm not sure which ones ended up working, but I ended up with one network again, which at least made things simpler. In the end, we ended up re-installing the network software on the PC, and after some toying with options, it ended up working in the strange way computer things do.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users