Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Speedisk Problems


  • Please log in to reply
4 replies to this topic

#1 bindlestiff7

bindlestiff7

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 13 February 2007 - 08:24 AM

Hi All,
I downloaded and installed Diskeeper Lite with the honest intention of trying it for a couple of days and then buying it. A good job I didn't.
After installation I tried to 'run' it but received the error - 'Snap-In failed to initialise'.
I tried System Restore, three times, each time going further back. Diskeeper vanished but XP Defrag failed to re-materialise. I also cleaned up the registry with JV16.

I sculled around the 'Net and found two fixes:
Method 1
Click on Start, Run, and enter regsvr32 dfrgsnap.dll.
Click on Start, Run, and enter regsvr32 dfrgui.dll.
If this doesn't resolve the problem, try Method 2.

Didn't work, so on to Method 2

Method 2
Click on Start, Run, and enter %windir%\inf. This should open a folder named Inf.
Locate the file named dfrg.inf (it might be listed as just dfrg.)
Right-click this file and click Install.

Didn't work either.

I also tried re-registering the defrag dll. The system was unable to find the dll, even though it was in the i386 folder where it was meant to live, and told me so. So, possibly courrupted?

So, now I have no Defrag utility at all. Anyone got any ideas please?

Ian

BC AdBot (Login to Remove)

 


m

#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,570 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:30 AM

Posted 13 February 2007 - 08:26 AM

Try running the System File Checker.

Description of Windows XP and Windows Server 2003 System File Checker (Sfc.exe)
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 bindlestiff7

bindlestiff7
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 13 February 2007 - 01:35 PM

Yes I did that Budapest. It took me about two hours because I had to first create an XP CD with SP2 Slipstreamed into it and the first two were not accepted by the system as true disks.

Eventually got to run SFC and there was a lot of hard drive/CD ROM access going on so it looked as if files were being replaced. But after it finished I rebooted and tried to run Defrag - No go I'm afraid, same errors coming up. Any more ideas folks????

#4 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,072 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:07:30 PM

Posted 13 February 2007 - 08:25 PM

Next step is likely a repair install of XP and the inevitable wait as 65 (at last count) updates are downloaded from Windows Update. Here's a link on it: http://www.michaelstevenstech.com/XPrepairinstall.htm
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#5 1101doc

1101doc

  • Members
  • 93 posts
  • OFFLINE
  •  
  • Location:Mackinac Island,MI Summer-SA/TX winter
  • Local time:06:30 PM

Posted 13 February 2007 - 09:20 PM

Check C:\Windows\system32\dllcache to see if there is a copy of dfrgnts.exe listed. If so, your system has the ability to defrag. Scroll down the list to mmc.exe. The Microsoft Management console. If you bring that up, under "File," the first option (1) should be the defragmenter. If you select that, the defrag UI will open. WMI (Windows Management Instrumentation) Service should also be started.
Neurons that fire together, wire together.
posted with Opera




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users