Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Gaming Under Vista? Any Problems/performance Issues?


  • Please log in to reply
10 replies to this topic

#1 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:06:47 AM

Posted 03 February 2007 - 11:02 AM

Anyone have any performance or other gaming issues after upgrading to vista?

BC AdBot (Login to Remove)

 


#2 Mr Alpha

Mr Alpha

  • Members
  • 1,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Finland
  • Local time:01:47 PM

Posted 03 February 2007 - 11:56 AM

They have a Windows Vista Performance Guide over at Anadtech, where they discuss the ups and downs on, amongst other things, gaming on Vista.
"Anyone who cannot form a community with others, or who does not need to because he is self-sufficient [...] is either a beast or a god." Aristotle
Intel Core 2 Quad | XFX 780i SLI | 8GB Corsair | Gigabyte GeForce 8800GTX | Auzentech X-Fi Prelude| Logitech G15 | Logitech MX Revolution | LG Flatron L2000C | Logitech Z-5500 Digital

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:06:47 AM

Posted 03 February 2007 - 08:23 PM

I had issues with the expansion pack to FEAR - BSOD's that were cured by an upgrade to the latest nVidia Vista drivers. Game still had problems with rendering shadows - but it was overcome (in part) by using the flashlight at all times (a real PITA).
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:47 AM

Posted 04 February 2007 - 09:47 PM

I've only had a couple of issues, I managed to work around some of them. One has to do with Elder Scrolls: Oblivion. Any downloadable content purchased is currently incompatible with the x64 version of Vista. However, the expansion Knights of the Nine also comes in CD form with most of the downloadable content included. Running to the store and buying it solves this, I've been assured that Bethesda and it's parters are working on getting the expansions to run if they were downloaded. X3: Reunion, if unpatched, has problems surrounding Starforce copy protection. The latest patch removes the copy protection allowing the game to play. My other issue is Neverwinter Nights 2, I'm not sure if it's a driver problem, but I do get crashes from time to time. I expected this with NWN2, it's a buggy game to begin with.

3939.png

 


#5 RADIUM-V Interactive

RADIUM-V Interactive

  • Members
  • 159 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Somewhere East of Where You Are (think about it)
  • Local time:05:47 AM

Posted 05 February 2007 - 08:06 PM

My friend just got a new Vista computer. He was having troubles running MapleStory and Sauerbraten. FEAR Multiplayer worked perfectly, but his computer isn't necissarily built for gaming (video card is shared memory). There were mostly sound issues, probably caused by hardware.

He was able to run another game, but I don't remember the name. It was made for 98, and it ran like butter.

#6 carninesix

carninesix

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Location:Newark, Oh
  • Local time:05:47 AM

Posted 06 February 2007 - 07:47 PM

Hello,

PunkBuster enabled games are throwing up "Inadequite OS Privilages" and kicking people.

The work round for this is to right click and run as admin.

The two games I have had this problem with are AmericasArmy and JointOperations.

No perfomance issuses that I have noticed, although on idle 700Mb memory in use.

Steve
Oldest desktop, home build, WinXP Pro, P4 @ 1.8, 1Gb ram, nVidia Geforce 6600 256Mb, Maxtor 40 Gb C-60 Gb D, NEC DVD+RW I, LG CDRW J, 17" 1280X1024 32Bit, Cooler Master Aquagate, Motorola SB5101 Cable modem, Belkin G Plus MIMO Router, Belkin 1200VA UPS
Laptop, COMPAQ V5205NR
Middle desktop, eMachines W6409, added 1 Gb ram, added ATI X300 256 Mb
Newest desktop, home build, Vista Ultimate, Conroe 6600 @ 2.4, 2Gb ram, nVidia 8800GTX 768Mb, Samsung 500 Gb Sata, Samsung DVD, 22" 1680X1050 32Bit, CyberPower 1285VA UPS

#7 Herk

Herk

  • Members
  • 1,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:S.E. Idaho, USA
  • Local time:06:47 AM

Posted 08 February 2007 - 11:51 PM

USASMA:

Game still had problems with rendering shadows - but it was overcome (in part) by using the flashlight at all times (a real PITA).


I've always been able to render shadows with a flashlight, except in direct sunlight, of course. :huh:

#8 Mr Alpha

Mr Alpha

  • Members
  • 1,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Finland
  • Local time:01:47 PM

Posted 09 February 2007 - 05:34 AM

Observation: The Supreme Commander demo performs much worse than the Supreme Commander BETA. It would still seen the performance is a very hit or miss affair.
"Anyone who cannot form a community with others, or who does not need to because he is self-sufficient [...] is either a beast or a god." Aristotle
Intel Core 2 Quad | XFX 780i SLI | 8GB Corsair | Gigabyte GeForce 8800GTX | Auzentech X-Fi Prelude| Logitech G15 | Logitech MX Revolution | LG Flatron L2000C | Logitech Z-5500 Digital

#9 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:47 AM

Posted 09 February 2007 - 04:43 PM

Another issue for those with Vista and a GeForce 8800, Europa Universalis III will have issues. Mainly the video card driver will stop working and recover causing the game to freeze up. I hope nVidia fixes their driver soon.

3939.png

 


#10 Mr Alpha

Mr Alpha

  • Members
  • 1,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Finland
  • Local time:01:47 PM

Posted 09 February 2007 - 04:58 PM

They barely got their first BETA driver out for the 8800. If you are pissed off enough about it you can go here. :huh:
"Anyone who cannot form a community with others, or who does not need to because he is self-sufficient [...] is either a beast or a god." Aristotle
Intel Core 2 Quad | XFX 780i SLI | 8GB Corsair | Gigabyte GeForce 8800GTX | Auzentech X-Fi Prelude| Logitech G15 | Logitech MX Revolution | LG Flatron L2000C | Logitech Z-5500 Digital

#11 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:47 AM

Posted 10 February 2007 - 04:39 PM

I am pissed off, but not enough for a class action. Most of my other games work fine with the beta drivers.

3939.png

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users