Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Prefetch


  • Please log in to reply
9 replies to this topic

#1 gidget

gidget

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:12:23 PM

Posted 03 February 2007 - 03:59 AM

I've noticed for the last two/three days that none of my Prefetch files are loading into the Prefetch folder in the Windows directory....the Prefetch folder is staying completely empty everytime I reboot. I deleted all of them the other day cause I had uninstalled a couple programs and kept noticing the prefetch files for these particular programs were still showing back up in the Prefetch folder so for a quick fix I just deleted all the files that were in there and rebooted again but now I'm not seeing any prefetch files in there at all and it's been like this for the last two/three days now and this is slowing down my startup. How can I get my Prefetch cache to rebuild it self again? I went to Google and read where one guy on a site I was reading recommended you change the value up in the registry for Enable Prefetch value to 2 instead of the default value 3. When I went into the registry to where Enable Prefetch is and looked at it, it was set on 3 so I changed it to 2 like the man suggested. Then I went back yesterday and changed it back to the default value of 3 when I kept noticing the files are still not loading into my Prefetch folder. How long does it take for Windows to rebuild it? Could there be something bad stopping them from not loading? I'm thinking there somethings wrong with my Prefetch.

BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:05:23 PM

Posted 03 February 2007 - 04:27 AM

Did you do this?

#3 gidget

gidget
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:12:23 PM

Posted 03 February 2007 - 04:44 AM

I just got thru going to ElderGeek's site and doing that what you just suggested. I flushed the Prefetch folder after each time I changed the setting from 0 to 1 to 2 then to 3 and I've left it enabled on the value of 3.
By doing this will it rebuild the Prefetch cache???

#4 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:05:23 PM

Posted 03 February 2007 - 04:51 AM

According to them it will. There is a myth about cleaning the prefetch folder. As long as nothing nasty in there leave it.

#5 gidget

gidget
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:12:23 PM

Posted 03 February 2007 - 04:59 AM

WinRar kept loading back into Prefetch after I uninstalled it the other day and went and tried Izarc instead so that's when after a couple time rebooting I noticed it wasn't going away so I got irked and deleted all the prefetch files cause I knew they've reload. Not soon after that is when my files quit loading into Prefetch folder.

#6 HitSquad

HitSquad

    You're Bleepin' or you're Weepin'


  • Members
  • 1,573 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Momma
  • Local time:11:23 AM

Posted 03 February 2007 - 05:32 AM

Hi gidget.
Prefetch requires the task scheduler service be running for it to populate.
Go to Control Panel>Administrative Tools>Services. Select Task Scheduler then click start.
If the Service is set to disabled, set it to automatic for now.
If the service is already running and set to automatic, click Start>Run. Type "cmd" (no quotes) in the run dialog box and hit your enter key. At the command prompt type, or copy and paste, the command below and hit your enter key then reboot your system:

rundll32.exe advapi32.dll,ProcessIdleTasks

There is some confusion about the registry entries your changing.
Those entries only tell windows "what" to load in the prefetch folder, not when.
The task scheduler service handles the "when".
Depending on what you have loading at startup and how many programs you launch, it may take anywhere from minutes to days for the prefetch folder to repopulate. Between the reg entry and task scheduler, you can control what files go in there and when by toggling task scheduler on or off. For example, if you only want boot files in there, clear the prefetch folder, set the reg entry to 2, making sure that the task schedule service is running. Reboot your system. Once the boot files have entered into the prefetch folder, you can disable the task scheduler service. What's in the prefetch folder will stay in there and not add anything else.

Edited by HitSquad, 03 February 2007 - 05:55 AM.


#7 gidget

gidget
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:12:23 PM

Posted 03 February 2007 - 05:41 AM

Yeap I had the Task scheduler disabled but I thought you could disable that. I've turned it back on

#8 gidget

gidget
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:12:23 PM

Posted 03 February 2007 - 05:45 AM

That fixed it...the files are back in there again. Thank you HitSquad for your help!

Edited by gidget, 03 February 2007 - 05:48 AM.


#9 HitSquad

HitSquad

    You're Bleepin' or you're Weepin'


  • Members
  • 1,573 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Momma
  • Local time:11:23 AM

Posted 03 February 2007 - 06:03 AM

You're welcome gidget.
BTW, I added a little to my post to give you an idea on how to control the contents of the prefetch folder since you posted back. :thumbsup:

Edited by HitSquad, 03 February 2007 - 06:03 AM.


#10 TheTerrorist_75

TheTerrorist_75

  • Members
  • 645 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Fulton, NY > Snow country.
  • Local time:12:23 PM

Posted 03 February 2007 - 10:07 AM

When you cleared the Prefetch folder you deleted the Layout.ini file which messed things up. You shouldn't clear the prefetch folder period. Windows will take care of the Prefetch itself. In fact having the Prefetch functional actually helps to load programs faster. Anyone using CCleaner should uncheck the option to clean the Prefetch folder.

Excellent reading on this subject.

http://www.edbott.com/weblog/archives/000743.html
I am a transplant survivor.

Get Your Donor Card




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users