Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Transparent Drop Down Menus Using Firefox


  • Please log in to reply
6 replies to this topic

#1 grandpaw7

grandpaw7

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:12:09 AM

Posted 28 January 2007 - 05:32 PM

For example, when I go to my hotmail wesite and click on the button that reads "Put In Folder", the resulting menu is transparent so that the text material which would be covered over by the drop down menu if it weren't transparent still shows, with the result that there are two sets of texts which overlap and conflict, making it sometimes difficult, sometimes impossible, for me to read the items in the drop down menu.

I'm only using Hotmail as an example because this happens regularly with drop down menus. It doesn't happen, for example, when I click on a button up in the toolbar, such as Edit, Tools, etc.; in that case, the drop down menu is not transparent.

This only happens when I use Firefox. It doesn't happen when I use IE6.

But I need Firefox because of the fact that with Firefox I can always increase the size of the fonts by holding down Ctrl and using the wheel on my mouse. I need that because of my poor eyesight. (Using IE6, I can do that on some websites and not on others.)

I have Windows XP Home Edition.

Any suggestions as to what the problem is, and the solution?

Thanks, grandpaw7

Moderator Edit: Moved topic to more appropriate forum. ~ Animal

Edited by Animal, 28 January 2007 - 08:28 PM.


BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:07:09 AM

Posted 01 February 2007 - 08:00 AM

Try this :

via Tools / Options / Fonts & colours. What are your settings there



#3 grandpaw7

grandpaw7
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:12:09 AM

Posted 01 February 2007 - 09:48 AM

fozzie, my color settings were black for Text and white for Background, but I had checked the box to "Allow pages to choose their own colors, instead of the selections above".

But I have played around with those selections. I have unchecked the Allow box, I have changed the setting for background to yellow, I have tried checking the "Use system colors" box, and I have slapped my monitor up aside of the head several times, all to no avail. Actually, none of the various changes have changed the way websites get displayed. For example, I still get white backgrounds. As far as I am concerned, the various options in the Colors and Fonts dialog box are for show only, kind of like those play cell phones people used to have to impress others.

I have also tried disabling add ons and using the default theme.

One person said that the problem would be corrected in Firefox 3.0 which he said was now being tested. Since the problem apparently happens only to me and a few others, I don't quite understand how it could be a problem in Firefox 2.0 rather than in my computer somehow.

Anyhow, thanks for the input. I have posed my problem in the Firefox forum and ran across a post by someone else with the problem so maybe it may come to the attention of the Firefox programming folks.

#4 buddy215

buddy215

  • Moderator
  • 13,323 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:01:09 AM

Posted 01 February 2007 - 01:36 PM

If I uncheck the box-- "Allow pages to choose their own colors, instead of the selections above" I have the problem you have. Clear Firefox cache. Click OK after checking that box and then restart Firefox and check if that box is still checked.
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#5 grandpaw7

grandpaw7
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:12:09 AM

Posted 01 February 2007 - 09:52 PM

SOLVED!! Turns out that I needed to disable High Contrast at Control Panel > Accessibility > Display > Use High Contrast. Plus, I previously noted that when I choose different options in the Coors and Fonts dialog box, nothing happens. Not so any more.

Edited by grandpaw7, 01 February 2007 - 10:11 PM.


#6 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:12:09 AM

Posted 01 February 2007 - 10:29 PM

Good news, grandpaw7.
It's good to hear you were able to find a fix for your problem.
Thanks for posting back with the solution. :thumbsup:

Don't forget to post your fix to the Firefox forum.
It might prove helpful to someone else.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#7 grandpaw7

grandpaw7
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:12:09 AM

Posted 02 February 2007 - 09:50 AM

Thanks tq1911, and I've posted to the Firefox forum.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users