Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Usb Device Installation Problem


  • Please log in to reply
2 replies to this topic

#1 malteser10

malteser10

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:08:42 AM

Posted 21 January 2007 - 04:46 PM

i didn't know where the best place for this post was. i originally put it in the hardware forum but no one has replied, so i thought i'd post it here too, as it's possibly both a hardware and xp problem.

im wondering if anyone can help me with a problem my flatmate is having. we can't get her new digital camera (samsung) to install on her laptop (dell inspiron 1000, running windows xp sp2). the installation software provided won't install, and we've tried downloading software from their website, but it has the same problem.

as we couldn't get it to work, i suggested just buying a usb card reader and using that, as a solution. unfortunately, we can't get that to install either! it said it was plug and play, but windows didn't recognise it so we insterted the driver disk. it tried to install from that, but the error message was: "a service installation section in this INF is invalid". we did seem to have success when installing the software straight from the cd, as it said it had installed ok. but when plugged in, device manager shows the the card reader is connected, but says the drivers are not installed.

with the camera, the computer recognised that it was a samsung camera and attempted installation, asking for the cd with drivers on. it still didn't install though - error message was "the driver installation file for this device is missing a necessary entry. this may be because the INF was written for windows 95 or later. contact your hardware vendor."
i have tried to send an email to samsung about this but have had no reply. i also did a websearch for this issue with this camera and found nothing. the camera is new so i don't see why it shouldn't work with windows xp easily. also as im having problems with multiple usb devices it seems more likely that there is a problem with the computer than the camera driver.
in device manager for the card reader, it is listed under usb controllers and says "The drivers for this device are not installed. (Code 28)" when double-clicked on.
for the camera, it is listed under IDE ATA/ATAPI controllers as samsung dsc usb device, and when double-clicked on it says the same as the card reader.

im thinking there's some sort of usb general problem, as her ipod nano also wouldn't install when i tried last year- in the end i gave up and she updates her ipod from another computer. i also tried to plug in my usb flash drive a minute ago and windows didn't recognise that either. it doesn;t seem to go through the same motions that other xp computers do when you plug in a usb drive (found hardware, installing hardware etc).

the strange thing is that she has a belkin wireless usb adapter and that installed ok about a month ago and seems to work fine!

if anyone has any ideas to try and solve the problem, id be very grateful. if you want me to tell you any more details, just let me know.
thanks

BC AdBot (Login to Remove)

 


#2 TheTerrorist_75

TheTerrorist_75

  • Members
  • 645 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Fulton, NY > Snow country.
  • Local time:04:42 AM

Posted 21 January 2007 - 06:39 PM

Go to Start > Run and type services.msc and press <Enter>. Look to see if the following Services are set to manual and running. If they aren't start them.

Portable Media Serial Number Service
Removable Storage
Smart Card

Post back if this helps. Also are you running Norton or Zone Alarm?
I am a transplant survivor.

Get Your Donor Card

#3 malteser10

malteser10
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:08:42 AM

Posted 22 January 2007 - 02:31 PM

hi, thanks for the advice. i tried what you suggested- all 3 of the processes were already set to manual. none of them were currently running, so i clicked start for them all.
i then tried to re-install the card reader. once again it did not plug&play and asked for the cd. it tried to install the drivers but failed with the same error message as each time before, unfortunately.

about norton & zone alarm - my flatmate did have norton installed and running, but it was expired so no longer updating online. the computer was full of spyware and malware (which has now all gone thanks to help from your hijackthis forum), and so i downloaded all of the suggested software for the computer. it now has bitdefender as its antivirus, and is running the zonealarm firewall because there was no firewall. i have uninstalled norton now as it wasn't needed any more.

i just tried disabling zonealarm and re-installing the card reader as i figured you were probably wondering if it was causing the problems. unfortunately it didn't make any difference.

i didn't restart at point during any of the above attempts. would that make a difference possibly?

thanks for your help, hope you or someone else has some more bright ideas to try!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users