Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Extremely Slow Shutdown In Win Xp Home


  • Please log in to reply
20 replies to this topic

#1 vulturesrow

vulturesrow

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 20 January 2007 - 02:26 AM

Hello all,

For some time now Ive had some serious issues with shutting down/rebooting my computer. It is a P4 3.Ghz with 512Mb RAM. In a nutshell, what happens is when I click on the menu item for the shutdown menu, my computer hangs for several minutes. Once the shutdown screen actually pops up, it takes several additional minutes to actually shutdown. Some other problems that have been happening in the same time frame that may or may not be related (just trying to give complete info here): I lose my internet connection if the computer sits idle for an extended amountof time (overnight for instance). I am pretty sure that this is not a router or service provider issue because my wireless connection always stays good and Ive had 2 different service providers. The other problem is that at random times my mousejust stops working and I have to unplug it and then plug it back in to get it working again. The only thing I should add on my slow shutdown problem is that it doesnt happen when I boot into safe mode.

Steps taken to date:
Complete malware remvoal procedure, to include multiple virus, trojan, spyware, etc scans. Checked the following two links provided to me in a different forum: http://aumha.org/win5/a/shtdwnxp.htm and http://support.microsoft.com/default.aspx?...mp;Product=winx , neither which provided any relief. Im running XP Home SP2 and my comp is completely patched, etc, no driver or device conflicts showing up in the device menu.

I consider myself fairly computer savvy for an amateur but I am completely stumped here. I resinstalled the OS once and it worked fine for about a week, then the problems started again. Im on the verge of complete nukking the hard drive adn starting over, but I really dont want to have to go to such extreme mesuares. Any and all help will be much appreciated.

BC AdBot (Login to Remove)

 


#2 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:18 AM

Posted 20 January 2007 - 08:04 AM

Hello,

I'm sure there is a registry setting to do this, but If you download a tool called winxpmanager,http://www.yamicsoft.com/ you can go through the program and find settings and change the shutdown speed and the time it takes to kill processes and services etc. I'm sure that the slow shutdown has something to do with .net framework.

Also this might help
http://users.pandora.be/jbosman/poweroff/poweroff.htm
Hope this helps
Regards,

Alan.

#3 TheTerrorist_75

TheTerrorist_75

  • Members
  • 645 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Fulton, NY > Snow country.
  • Local time:03:18 AM

Posted 20 January 2007 - 08:26 AM

This program may help with the slow shutdown.

User Profile Hive Cleanup Service
I am a transplant survivor.

Get Your Donor Card

#4 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:08:18 AM

Posted 20 January 2007 - 10:40 AM

Please do an online check here this will check your entire computer on known issues. Do the full test. If that does not help please take the following steps :

Please follow these steps :

• Defrag your system. Disk fragmentation slows the overall performance of your system. When files are fragmented, the computer must search the hard disk when a file is opened. Disk Defragmenter consolidates fragmented files and folders on the hard disk so that each occupies a single space on the disk. This speeds up reading and writing to the disk. Read "The Importance of Disk Defragmentation" for instructions.

• Check for disk errors by running CHKDSK. CHKDSK can be run from the Recovery Console, the command prompt or through the Windows GUI.
To run chkdsk from the Win XP GUI see these instructions.
To run chkdsk from the command prompt see these instructions.
To run chkdsk from the Recovery Console see these instructions.
The problem with running CHKDSK from Win XP is that it will not check files that are being used by Windows. Using chkdsk in the Recovery Console with the /r switch is a way to resolve this.

• Check for damaged, altered or missing critical system files by running the System File Checker. If SFC discovers that a protected file has been damaged, altered or missing, it restores the correct version of the file from the cache folder. You must be logged on as an administrator or as a member of the Administrators group to run sfc and it may ask you to insert your XP Installation CD so have it available.

• Clean up your hard drive by removing unused programs and transferring old data, pictures, music files to a CD or an external hard drive. When you have moved/saved the files you want to keep, run Disk Cleanup and let it scan your system for files to remove. "Don’t clean out the Prefetch folder" - This is a common myth that will not improve performance.

• Check for any unnecessary running services. If you have a typical installation, many services are configured as "automatic"; that is, they start automatically when the system starts or when the service is called for the first time. Use "Black Viper's Services Configuration" to help fine tune this area.

• Check for any unnecessary applications loading at startup when Windows boots with MSConfig. Some startup programs are necessary so be careful what you disable. If you are unsure what any of the startup entries are or if they are safe to disable, then search one of the following Startup Databases:
Startup Programs Database
StartupList Index

Note: MSConfig.exe is a troubleshooting utility used to diagnose system configuration issues. Although it works as a basic startup manager which allows you to enable/disable auto-start programs, msconfig should not be used routinely to disable startup programs.

A better alternative is to use a startup manager. If you have have Spybot S&D 1.4 installed, launch it, go to Mode and select Advanced. Then go to Tools, select System Startups. You will be provided with a list of programs that load when Windows starts. If you untick an entry it will no longer run at startup. This will allow you to experiment and see how your system performs with any of them disabled. Other startup managers you can download and use for free are Startup Control Panel, Autoruns and Starter by CodeStuff.

• Remove any third party "Memory Manager" or "Optimizer". Windows XP memory management was designed to make the best use of Ram and these memory management utilities defeat that purpose. They push applications out of RAM into the pagefile, creating holes in the RAM and by doing so, slow down your computer.

• Disable some visual effects. While visual embellishments that may be attractive, they don’t do anything else for you. Disabling some of them frees up system resources and makes the operating system perform better. Right click My Computer, choose > Properties > Advanced, click on "Settings" under performance...UNcheck all the visual effects, except for the last three. Click "Apply", then "OK", then "OK" again. Then right click your desktop and choose > Properties > Appearance > "Effects...Uncheck the first two boxes and hit "OK".

#5 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 01:39 AM

Thanks for all the response thus far, still trying to work through the problem though. And Fozzie, I apologize for not making it clearer, but I've done all the "normal" Windows' fixes. I was looking for a little more than a canned post. Please let me know if you have any other ideas. Thanks again everyone.

#6 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:18 AM

Posted 21 January 2007 - 07:02 AM

Hello again,

I did some more digging, and found this useful tweak...
Click the Start button > Run > and type "regedit.exe". Browse this key:

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control

Click on the Control folder and in the right hand window you will see this key "WaitToKillServiceTimeout". Double click that key and set it to 200.

Close regedit.exe and then restart your computer.

Hope this helps

Make sure you back up the registry before you go in.
Regards,

Alan.

#7 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:18 AM

Posted 21 January 2007 - 08:27 AM

Try using the Processes tab of Task Manager just prior to shutdown - then see if anything is hogging the CPU cycles there.

I suspect that something was "busted" when removing the malware - so it may be extremely difficult to repair.

For a "quick" fix I'd suggest a repair install of XP - although it's a PITA, it will save your programs and data while rewriting the Windows files. Here's a link to it: http://www.michaelstevenstech.com/XPrepairinstall.htm
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#8 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 04:40 PM

Hello again,

I did some more digging, and found this useful tweak...
Click the Start button > Run > and type "regedit.exe". Browse this key:

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control

Click on the Control folder and in the right hand window you will see this key "WaitToKillServiceTimeout". Double click that key and set it to 200.

Close regedit.exe and then restart your computer.

Hope this helps

Make sure you back up the registry before you go in.


I think I love you. This seems to have done the trick. Im not sure what caused it to start taking so long to shut down, but the cure seems to have worked. :thumbsup:

Usama,

I think I may still do the repair install, as I have some other niggling problems. Thanks for the help.


Everyone else who replied,

Thanks for your help, it is much appreciated.

#9 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 04:46 PM

Try using the Processes tab of Task Manager just prior to shutdown - then see if anything is hogging the CPU cycles there.

I suspect that something was "busted" when removing the malware - so it may be extremely difficult to repair.

For a "quick" fix I'd suggest a repair install of XP - although it's a PITA, it will save your programs and data while rewriting the Windows files. Here's a link to it: http://www.michaelstevenstech.com/XPrepairinstall.htm


Usama,

Think Im out of luck on this option after all. I dont have xp discs, just bs oem recovery discs from Gateway. :thumbsup:

Edited by vulturesrow, 21 January 2007 - 04:47 PM.


#10 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:18 AM

Posted 21 January 2007 - 07:12 PM

Glad to help
Regards,

Alan.

#11 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 07:20 PM

Glad to help



I might not be out of the woods yet. It still seems to be having the problem intermittently. Im trying to narrow it down as I write this. :thumbsup:

#12 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:18 AM

Posted 21 January 2007 - 07:25 PM

What seems to be the problem?
Regards,

Alan.

#13 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 07:55 PM

same as originally posted. Click on turn off the computer and I get the hourglass for a couple minutes before the actual turn off the computer menu pops up. :thumbsup:

#14 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:18 AM

Posted 21 January 2007 - 08:10 PM

I did some more digging, this should solve the problem, also, do you have the system set to delete the pagefile at shutdown?

Open REGEDIT and navigate to ‘HKEY_CURRENT_USER\Control Panel\Desktop\’
Highlight the ‘WaitToKillAppTimeout’ value.
Set it to ‘1000′.
Now highlight the ‘HungAppTimeout’ value
Set it to ‘1000′ also.

Then go to

Open REGEDIT and navigate to ‘HKEY_USERS\.DEFAULT\Control

Panel\Desktop’
Highlight the ‘WaitToKillAppTimeout’ value.
Set it to ‘1000′.
Now highlight the ‘HungAppTimeout’ value.
Set it to ‘1000′ also.

In the third part of this tip, we will alter a second registry setting to decrease the amount of time Windows XP will wait before shutting down active services after receiving a shut down command.

Open REGEDIT and navigate to

‘HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\’

Highlight the value ‘WaitToKillServiceTimeout’

Change this value to ‘1000.’


To allow Windows XP to close non-responsive applications automatically upon shutdown:

Open REGEDIT and navigate to ‘HKEY_CURRENT_USER\Control Panel\Desktop’

Highlight the value ‘AutoEndTasks.’

Change the value to ‘1′

XP will now be able to close hung applications without user input during the shutdown process.

hope this helps
Regards,

Alan.

#15 vulturesrow

vulturesrow
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:18 AM

Posted 21 January 2007 - 08:54 PM

niggles,

Applied those registry changes and seems to doing ok for now, I'll keep you updated, staying cautiously optimistic at the moment. :thumbsup: Where the heck are you digging up all this info??!! Thanks so much once again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users