Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Startup Program


  • Please log in to reply
9 replies to this topic

#1 chuckeej

chuckeej

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:19 AM

Posted 02 January 2007 - 11:30 PM

OS: WinXP Home...."Safely Remove Hardware" icon appears in system tray at startup - also the Start menu appears. How can I prevent these two items from loading at startup?

BC AdBot (Login to Remove)

 


#2 resp

resp

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Local time:02:19 AM

Posted 03 January 2007 - 03:02 AM

Safely remove hardware starts up because you have an outside source plugged into your computer, Such as a camera, An external Drive, Etc... If you remove the source of this it will actually terminate itself, Its just a way of windows ensuring that whatever is attached to your USB ports can be removed without issues.

Im guessing if you don't use a camera, Or an external drive, Maybe theres a printer attached? if so that's why it comes up, And unless you wish to unplug this device until you need to use it, It'll keep showing up

the Start menu as far as I know is not possible to remove as it is a key component in windows, And holds all the shortcuts to programs running on your computer in it

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:04:19 AM

Posted 03 January 2007 - 08:17 AM

This can also happen if you have a card reader installed. Right click on the Start button and select "Properties". Click on the TaskBar tab, then on the Customize button. Clicking on the behavior of the Tray icons will allow you to change them to "Always hide".

As for the start meun appearing, could you describe this a bit more? The Start button must show - but the menu appearing may be a glitch in the system or a setting that has gone awry.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 chuckeej

chuckeej
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:19 AM

Posted 03 January 2007 - 10:50 PM

This can also happen if you have a card reader installed. Right click on the Start button and select "Properties". Click on the TaskBar tab, then on the Customize button. Clicking on the behavior of the Tray icons will allow you to change them to "Always hide".

As for the start meun appearing, could you describe this a bit more? The Start button must show - but the menu appearing may be a glitch in the system or a setting that has gone awry.


At startup, the Start button appears in the taskbar, but the menu also shows along with it (e.g. All Programs, Internet Explorer, MSN, Windows Media Player, My Documents, My Computer, Control Panel, Help, Search, Run, Log Off, Turn Off, etc. I just had my pc repaired. The start menu has never before appeared (with the Start button in the taskbar) at startup. Thanks for any suggestions to fix this.

#5 chuckeej

chuckeej
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:19 AM

Posted 03 January 2007 - 10:56 PM

Safely remove hardware starts up because you have an outside source plugged into your computer, Such as a camera, An external Drive, Etc... If you remove the source of this it will actually terminate itself, Its just a way of windows ensuring that whatever is attached to your USB ports can be removed without issues.

Im guessing if you don't use a camera, Or an external drive, Maybe theres a printer attached? if so that's why it comes up, And unless you wish to unplug this device until you need to use it, It'll keep showing up

the Start menu as far as I know is not possible to remove as it is a key component in windows, And holds all the shortcuts to programs running on your computer in it


My printer is not attached to the computer - until I will need it, neither do I have a camera, external drive, etc. attached. Any way to disable the "Safely remove hardware" program from loading at startup? Thanks for any further help.

#6 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:04:19 AM

Posted 04 January 2007 - 10:34 AM

I don't have a clue on how to stop the menu from showing at startup - but it's commonly done with new PC's, so there must be a startup switch for it somewhere. I'd suggest checking into msconfig.exe to see if there are any "switches" used when opening your desktop (usually explorer.exe).
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#7 sbrown.uk

sbrown.uk

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:19 AM

Posted 04 January 2007 - 10:46 AM

Do you use a USB modem?

#8 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:08:19 AM

Posted 08 January 2007 - 10:44 AM

I'm not sure how much help this is, but you can auto hide the taskbar.
OR
Crash/ end the process explorer in the task manager,
OR
Script an app that will do the job
Regards,

Alan.

#9 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:19 PM

Posted 09 January 2007 - 01:21 AM

The "Safely Remove Hardware" icon appears in the system tray on my system even if I have nothing attached to the computer. When I click on it it gives the option to safely remove my internal CD/DVD drive. I just set it to "Always Hide".
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#10 tpm

tpm

  • Members
  • 355 posts
  • OFFLINE
  •  
  • Local time:03:19 AM

Posted 09 January 2007 - 08:11 AM

I'm guessing you had your "Startup / Taskbar" on auto hide mode. Now it's always showing. Sure someone can tell you how to put it back that way.
Tom




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users