Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Xp File Sharing - 2 Machines Won't Talk


  • Please log in to reply
6 replies to this topic

#1 MitchRosenthal

MitchRosenthal

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:36 PM

Posted 30 December 2006 - 10:11 PM

Hi Geek Friends!

I feel like I've tried everything so now I'm outsourcing my problem to you folks, maybe you'll remember something I'm forgetting.

I have four computers I'd like to enable Windows XP file sharing on over a wired and wireless network joined by a D-Link DI-524 wireless router. They have used file sharing on it before, but recently I can't get it to work. For simplicity purposes, I'll try to get my two computers working--one a laptop on the wireless, and the other a new home-built desktop on wired connection. Both have XP SP2 and use the Windows firewall.

Here's what can tell you...

1. Both computers can ping each other from the command prompt.
2. The Windows Firewalls are up, but exceptions are enabled, and File and Printer Sharing is listed as an exception on both machines.
3. I have run the "Set Up Home or Small Office Network" wizard on both machines and enabled file and printer sharing.
4. Both computers have an account named Mitch with identical passwords and the guest account is also enabled.
5. 'restrictanonymous' in the LSA section of the registry of both machines is set to 0; 'restrictanonymoussam' is set to 1 in both cases (is that a problem?)
6. The router does not have any restrictions that I know of, that would hamper communications within the LAN. I've had file sharing working at school using the same router and my laptop and a friend's laptop.
7. Both computers are on the same workgroup and do not have identical names.
8. The computers can access the Internet without any problems and even play network games over the LAN.
9. Both computers are sharing at least one folder.
10. The laptop can see itself on the LAN, and can access all of the folders it's sharing through My Network Places. The desktop can not do that with its own shares--it can't even see itself on the workgroup.
11. My laptop can't see my brother's computer (on wireless) on the same workgroup through My Network Places, and the desktop can't see the other desktop on the LAN. They can all ping each other.
12. File and Printer Sharing is listed as a service on the Network Connection properties window (on both machines).
13. In the WINS tab of the TCP/IP settings, NetBIOS is set to Default (automatic, let Windows choose) and LMHOSTS lookup is enabled. They obtain their IP addresses automatically (one 192.168.0.100, the other is 103).

My conclusion is there there must be
a. A problem with the Windows Firewall on at least one of my computers
b. A problem with the router that's preventing file sharing (seems most unlikely)
c. Some issue between the Wired and Wireless computers (also seems unlikely, the wired computers and wireless computers won't file share, respectively)
d. Something I haven't thought of but you will...
Thanks for your help!

BC AdBot (Login to Remove)

 


m

#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:12:36 PM

Posted 30 December 2006 - 11:20 PM

Few things to try. First to make sure that the ports needed to be opened are in fact open you can try this from each machine.

The first is to click on start, then click on run and in the open: field type:

telnet <ipaddress> 135

and then press enter on your keyboard.

So for example if you are on the wired machine and you are telnetting to the wireless machine, and the wireless machine had an ip address of 192.168.0.100, you would type:

telnet 192.168.0.100 135

Then press the enter key. What you want is a blank black screen with a cursor blinking in the upper left hand corner. You can type, but prob not see anything. If you get this then the port, 135, is reachable from the computer you ran telnet from. Now you want to do this same thing, on the same computer, for the ports 139 and 445. If it looks good for all three ports (135, 139, 445) go to the other computer and do the same back to the original computer.

Next,

Make sure they are both in the same workgroup.

Next,

Assign static ip addresses. Dont use DHCP.

Third,

Add entries in both computers LMHOSTS file. This is because you are on a wireless network and you dont have WINS Server. Rename your c:\windows\system32\drivers\etc\lmhosts.sam to c:\windows\system32\drivers\etc\lmhosts and add a line like this:

ipaddress name of computer #PRE

So if your two computers were named wired and wireless and had the ipaddresses 192.168.0.10 and 192.168.0.11 you would add in both computer's lmhosts file the following:



192.168.0.10 wired #PRE
192.168.0.11 wireless #PRE


Then reboot. Cant hurt also adding it to your HOSTS file like this:

192.168.0.10 wired
192.168.0.11 wireless


See if these steps help.

#3 MitchRosenthal

MitchRosenthal
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:36 PM

Posted 08 January 2007 - 04:45 PM

OK, I tried your telnet instruction. First I did port 135, and the black telnet screen said "connecting to <ip address>..." and didn't go any further than that. I added port 135 as an exception into both computers' Windows firewall and tried again, and it gave me the black screen like you said it would. I noticed in the exceptions list, File and Printer sharing had 137, 138, 139, and 445 listed (but not 135). I tried those IPs and it didn't work for them (same result as happened before I added 135 to the exceptions). Should I remove the file and printer sharing exception and add each port individually? I couldn't re-add those ports because they are already listed, it told me.

Next, I'd really rather not do static IP addresses, as I've used this router and these computers to file share in the past with dynamic IPs, and don't want to 1. set them up to do static IPs and 2. have to undo that setting every time I take my laptop on a different network. Also, the router assigns the same IPs out to each computer so I won't be confused by changing IPs. Can we skip that step and try other solutions?

They are both on the same MSHOME workgroup.

If I'm not using static IPs, is it still worth playing with LMHOSTS? Any other ideas?

#4 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:12:36 PM

Posted 15 January 2007 - 10:34 AM

Sorry for the delay. Just to test something, what happens if you disable the firewalls on both computers? Can you now connect to each other?

#5 MitchRosenthal

MitchRosenthal
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:36 PM

Posted 19 January 2007 - 12:38 PM

Even with both firewalls down, I can't get them talking. The laptop can see itself in the workgroup and access its own shared folders through My Network Places, but the desktop (wired) can't even see itself in My Network Places. What the heck is wrong with my machines :thumbsup: ?! Would it be worthwhile to reinstall the network card and its drivers on one or both computers?

#6 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,394 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:12:36 PM

Posted 19 January 2007 - 02:38 PM

No i do not think thats the issue. I think its an issue with the wireless router not routing between the two segments properly. You may want to try static ip address and an lmhosts file and see if that resolves the problem. Do it with the firewalls on the computer off, and if it works, get the firewalls back and configure them so it continues to work.

#7 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:11:36 AM

Posted 25 January 2007 - 02:23 AM

When you go to MsHome in My Network Places can you see the other computers? If you can right click on them and select Explore. When prompted enter the computer name and user you wish to logged in under, along with the password for that user. This should set a path to the drive\folder.
Note this will only work if you can see the computer listed in mshome in My Network Places.
"2007 & 2008 Windows Shell/User Award"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users