Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I Can't Access My External Hard Drive


  • Please log in to reply
2 replies to this topic

#1 demao7

demao7

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:48 PM

Posted 14 December 2006 - 07:51 AM

I have a Western Digital external hard drive, 360gb, that I can't get into. It lights up, spins like its supposed to, no strange noises...everything seems ok. But when I plug it in, my computer won't recognize it. It's always been plug and play, but apparently not anymore. Under device mngr it shows up with the ellusive question mark. It's only a few months old, only been filled to about half of its capacity, never dropped or damaged, just turned it on and can no longer get into it. I've also tried it on 2 other computers with no luck. Is there a way to recover my information without spending $200 and hour (rates I've seen) or allowing strangers acces to extremely personal info (tax records, photos, financial info, etc.)?

BC AdBot (Login to Remove)

 


#2 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:09:48 PM

Posted 14 December 2006 - 08:52 AM

If you go to "my computer " can you see it? If so rightclick and than propperties. What do you see there?

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:04:48 PM

Posted 14 December 2006 - 08:54 AM

What error messages do you get when plugging it in? Since it doesn't work on 3 separate systems I'd have to suspect the drive itself.

I'd first suggest the free Western Digital tools available on their website. They have free diagnostic and recovery software there (if the drive isn't too damaged).

Have you tried this free recovery software: http://www.pcinspector.de/ ?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users