Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wsastartup Failed. Internet Errors As Well.


  • Please log in to reply
1 reply to this topic

#1 eskEMO

eskEMO

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 11 December 2006 - 11:41 AM

Hi everyone,

I found this site through searching for this actual error, but that topic never led me to anything that could help. Anyway, here's the scenario:

My computer was working pretty well, but then we had a power outage last night. Before it shut down it wasn't going slower than usual. I turned it on before school this morning to load up my normal messengers and other programs. It was going HORRENDOUSLY slow. So, I exited out of the unneeded programs (AIM, XFire, Y!IM, Steam, ESEA Client, etc.). I ran Ad-Aware Free (updating it before it ran) and deleted the normal tracking cookies it found (the supposedly harmless ones). I then opened up Spybot: Search and Destroy to update it and then run it, but I couldn't search for updates. It mentioned a "socket" error. This was my first real sign of worry. =X I found that weird, so I just ran a Spybot search anyway, immunized bad products and cleaned up the spyware it found (Nothing significant, just normal ad spyware). AVG was open in my taskbar, but I didn't have time to run it and see the results, since I had to come to school. I opened up a program that I use, Ventrilo (similar to Skype, TeamSpeak, etc.), because I usually idle our AFK channel if I'm not actually on. I received an error when I tried to open Ventrilo (using a shortcut in my Start menu) that said, "WSAStartup Failed." I hit the "OK" button and tried to get on Mozilla Firefox to search for what the problem could be. Firefox just gave me, "Cannot connect to server." errors for any site I tried to go to. I started to get more than a bit worried here. I opened up Internet Explorer to try to get help, but just like Firefox, IE said that it could not connect to any pages, because I wasn't connected to the internet.

The only reason I know that it's not an issue with the actual internet is because I could log into these programs: Windows Live Messenger, AIM, XFire, Y!IM, Steam (Used for games like Counter-Strike, Half-Life, etc.), and ESEA Client (A 3rd-party program for Counter-Strike), and World of Warcraft without error. (WoW being okay as far as last night, I don't know if it still is, since the restart.)

Anyway, back to the story. After IE, Firefox, Ventrilo, and Spybot's updater all failed to work, I was worried. I tried to restart my computer (the shutting down process took longer than usual) and when the login screen came up and I entered my password, it took very long to load my wallpaper. I waited maybe a minute for the actual desktop to load, but it never did. (I was in a hurry, since school was starting in about 20 minutes) I tried to hit ctrl+alt+delete to see if I had an error on my desktop, (I had a problem around a year ago where my desktop wouldn't load, but the task manager would come up, but that was long fixed and there's been a reformat between then and now) but the task manager never came up.

I've also been using torrents lately, if that would affect it at all. (I know the virus/trojan risk associated with Bitlord and other torrent programs)

Any ideas?


I'm going to try to run AVG tonight if I can load my desktop, but don't know where I'm going to go after that.

Extra info:
Windows XP Home SP2
1GB RAM (2x512MB)
DFI LAN Party NF4 SLI-DR Motherboard
250GB Hard Drive (Currently 140GB free)
AMD 3000+ Processor (1.8 GHz)

Thank you for reading this and hopefully helping. :thumbsup:
-eskEMO

EDIT: I'll double check Ventrilo's error message tonight and also add the exact error I receive from Spybot. I believe that the Ventrilo error I received is exactly what it says, though.

EDIT #2: I also found in might be relevant to post that I connect to the internet through a Linksys WRT54G router, although no changes have been made to the router since over a week ago.

Edited by eskEMO, 11 December 2006 - 12:05 PM.


BC AdBot (Login to Remove)

 


#2 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 36,946 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:04:26 PM

Posted 11 December 2006 - 02:14 PM

I suspect your problems all stem from the power failure which could have damaged a number of the files the programs need to run. You will probably need to do a number of fixes.

I have two suggestions that might help:

First try this: click on start then type cmd in the white area. When the black screen comes up, typ in sfc /scanonce. Make sure there is a space between the sfc and the / This will check all your protected system files at boot up and if anything is messed up it will try to fix it. It will report anything it finds and fixes or tries to fix in the event logs.

If that doesn't work, use system restore choosing a date and time just before the power outage.

Orange Blossom :thumbsup:
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users