Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Network Only Working In One Direction


  • Please log in to reply
3 replies to this topic

#1 perrymc

perrymc

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:05:43 PM

Posted 11 December 2006 - 06:14 AM

I know this is long but this problem has been around for a long time for me.

Problem: The remote pc on the network is unable to access the primary PC shared documents folder and printer.

primary computer(lan): Dell
name: home
workgroup: MSHOME
XP Pro
remote computer (wlan): micron
name: home-micron
workgroup: MSHOME
XP Home
router (residential gateway): Airlink

Both PCs obtain IP address and DNS Server address automatically. Both have DHCP enabled.. Both have Windows Firewall on and both allow exceptions for file and print sharing. Neither have any advanced settings in Services or ICMP checked.

The primary computer with XP Pro has “use simple file sharing (recommended)” unchecked. Was on previously. Changing setting had no impact (even after reboot).

Previously ran the Network Setup Wizard on both computers. The Dell has full access to the shared documents folder on the micron. The Micron cannot see the shared documents folder on the Dell (cannot access the dell other than ping)

Selecting the primary computer Network Places, then Local Network displays: the Residential Gateway icon plus icons for Shared Docs on dell(Home) and Shared Docs on micron (Home-micron). Properties for the dell shared docs show a target: c:\documents and settings\all users\documents. Properties for the micron shared docs shows a target: \\Home-micron\shareddocs.

Selecting the remote computer Micron Network Places displays under Local Network the icon for Shared Docs on Micron (home-micron) but no other icons. You must drop down to “unspecified”, select Entire Network then Microsoft windows network, then MSHOME then you will see both Dell(Home) and micron(Home-micron). You can open up micron to get to the micron shared docs but clicking on Dell(Home) generates the following message:

"Home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access Denied.”[/b]

Both PCs are recognized on the network group and can ping each other. The router can ping both computers ok. Both PCs have the shared documents folders enabled for sharing. The printer on the Dell is enabled for file and printer sharing. It is an HP Deskjet 932C connected via printer port.

The primary computer has user accounts with passwords assigned (except the guest acct). The remote computer has user accounts without passwords. Some user names are identical on both machines.

The router wireless access point is enabled (as evidenced by the Micron being able to ping the Dell). Both PCs can connect to the internet without any problem.

The printer ‘share name’ on the Dell is ”Printer”. Printer permissions are enabled for ‘everyone’.

Could not use Nslookup from command prompt on the Dell to see the printer because my system is set up as a workgroup and not a domain. Was trying to use it to ‘see’ the printer and maybe access it directly from the Micron. Believe Nslookup is strictly for domains. Don’t know.

The primary PC Start menu and Help did get me to “grant incoming connection access to your computer”. It suggested going to control panel then Network connections. From there it said click on incoming connections (did not see) and then under network tasks click change settings of this connection. …these steps were not available although Network tasks were in the left column but they only allowed create a new connection, set up a network, or change firewall settings. I tried to create a new connection but there were no device options that made any sense (only one listed was LPT1). I would think it would give me the choice of the micron but NO! There was an intro note that mentioned network policy settings might prevent me from completing this procedure.

A search of help for ‘network policy settings’ got me numerous references to group policy settings but I couldn’t may heads or tails of what to do, if anything.

I also tried running the ‘add printer wizard’ from the Micron. I chose ‘connect to this printer’ then typed in the path \\home\printer. It then came up with a logon screen for ‘connect to home’. I entered a user name and password that I use on the Dell and it came back with the message “The credentials supplied conflict with an existing set of credentials. Overwriting the existing set of credentials may cause some running applications to stop functioning properly. Do you really want to overwrite the existing set of credentials?” Okay, so I was already logged onto the micron under one user name then tried to use a username and password for the Dell. I am assuming I never got to first base and never connected to the Dell. How in the world is one to know what to do? I canceled the operation and if I wasn’t just downright angry I probably would have just given up and cried! Anyway, I think I just need to reboot my computers then try the wizard again but only using the same logon I used on the micron. Don’t really expect it to work since the username without password probably won’t be recognized by the Dell. Who knows?

Okay just used my micron username without password. Did not get credential error but system came back “Windows cannot connect to the printer. Operation could not be completed”. Then tried browse to search for a computer name. It would identify the MSHOME network but never listed a printer and kept asking for a printer name.

One other reference I read from a book said I had to set up user accounts and passwords on the primary to give the other computer access. I am so lost! Where do I go from here?

Edited by perrymc, 11 December 2006 - 05:28 PM.


BC AdBot (Login to Remove)

 


#2 perrymc

perrymc
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:05:43 PM

Posted 11 December 2006 - 05:35 PM

Update to my post: I can now access the primary shared docs and printer from the remote!

Okay, this is what I did

- assigned each username on the remote pc the matching password on primary (where usernames were the same)
- logged in on the remote and was able to print to primary
- if my network places did not display on the start menu then I went into control panel, network connections and ran the network setup wizard (I did this for each user account as needed). Had to give it a little time but the network places showed up and had the dell shared folder there!
- I then deleted the password on the remote acct and could still access the shared folder without a password. I did need to use a logon and password a couple of times, so I just used a valid username and password registered on the primary even if I wasn't in that user on the remote pc.
- Now is there a way to give a guest account access to shared folders? Not sure I will do this but might like to. Also, My daughter occasionally brings over her wifi laptop and can connect no problem. How do I give her permissions to access my network to use the printer? Last, I tried to set up a new connection that was 'direct'. I want to have one user account (me) to have full access to all my files on the primary while I am at the remote. I couldn't create a separate dedicated connection that only I could access. Any ideas?

#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:43 PM

Posted 12 December 2006 - 10:17 AM

As I recall (I may be wrong) XPHome uses the Guest account permissions for simple filesharing.

You'll have to setup the wifi laptop to be a member of the network at your house - this depends on what connection software that she uses to connect.

Where did you try to setup the "direct" connection? If it was an additional network connection, did you enable it to be the default connection? Did you disable the other connections? Did you reboot to let it take effect?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 perrymc

perrymc
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:05:43 PM

Posted 11 May 2009 - 04:22 AM

I am adding this reply for all who read this post because they too have trouble with the message "Home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access Denied.”

For a long time I tried to figure it out, then gave up and just ran back and forth with a USB memory stick. Decided to have another look and actually ran across a solution that was simple and did the job! Problem Solved! and I have no clue how or why ... Just thankful there are so many people out there smarter than me that are willing to share with the rest of us.

I used the following info to make a registry change on the primary computer that I could not access from the other computers in my network. Remember to back up your registry before trying to edit it.

You Might Not Have Permission to use this network resource
(http://www.annoyances.org/exec/forum/winxp/t1056577268)

Here's what ya really need to do to fix the problem... Straight from the DragonWiz the problem can occur if
Restrictanonymous is set to 1

1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then double-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3. In the right pane, double-click restrictanonymous.
4. Make sure that the value in the Value data box is set to 0, and then click OK.
5. Close Registry Editor.
6. Restart the computer.

This completely eliminated my problem after how long ???? Take care everyone!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users