Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

<windows Root>/system32/hal.dll. Missing Or Corrupt !error At Boot!


  • Please log in to reply
1 reply to this topic

#1 Maabsta

Maabsta

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:47 PM

Posted 07 December 2006 - 11:55 PM

I get this text when turn on my computer <windows root>/system32/hal.dll. Is either not installed or corrupt. Please reinstall with the disk. My computer is a Dell Dimension E510. I do not have the Windows XP disk to repair this error. These are the steps I took before my computer messed up:

Your boot.ini can be found by right clicking My Computer and going to System, then to the Advanced tab, then clicking Settings under Startup and Recovery. You click the "Edit" box next to where it says: To edit startup options manually, click Edit. To the file that pops up, and on the line underneath [operating systems], you are going to add the following command: /usepmtimer

When you are done editing the file, it should look like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1) \WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDO... Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

- I did all this then restarted my computer and got the error.

Here is a link to the full page I followed. I was trying to fix my counterstrike problem: http://hardware.gotfrag.com/portal/forums/thread/182114/

I want to try to find a way to fix this problem without Restoring my computer to the default settings and wiping my hard drive and without the Windows Xp Disk. Any suggestions? Thanks.

BC AdBot (Login to Remove)

 


#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:03:47 PM

Posted 08 December 2006 - 07:20 AM

See if one of these helps:
Error Message: Cannot Find \Windows\System32\hal.dll

"Invalid Boot.ini" or "Windows could not start" error messages when you start your computer
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users