Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox Search Function Problem


  • Please log in to reply
9 replies to this topic

#1 Puck3tt

Puck3tt

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:12:41 PM

Posted 07 December 2006 - 06:17 PM

For some reason my firefox pops up the search function (same thing as pressing ctrl+f) when I hit the apostrophe key. It doesn't always do this, but it is very annoying when it does happen and I'm trying to type something. I can't figure out how to fix this. It was just doing it a second ago and now it's not doing it anymore. I'm not sure how to set shortcuts and stuff like that.

Anybody have any ideas?

BC AdBot (Login to Remove)

 


#2 buddy215

buddy215

  • Moderator
  • 13,322 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:12:41 PM

Posted 07 December 2006 - 06:37 PM

This might help.
Click on tools/ options/ advanced/ uncheck under Accessibility heading these two boxes--"allow text to be selected with the keyboard" and "Begin finding when you begin typing"

I use firefox 1.5.08 so if you are using 2.0 the options might be different. Let me know if this works, please.
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#3 Puck3tt

Puck3tt
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:12:41 PM

Posted 07 December 2006 - 07:45 PM

They are already unchecked.

#4 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:06:41 PM

Posted 07 December 2006 - 11:39 PM

What are your keyboard settings? Which languages

#5 nlinecomputers

nlinecomputers

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:12:41 PM

Posted 07 December 2006 - 11:55 PM

Known bug. Supposed to be fixed in 2.0

https://bugzilla.mozilla.org/show_bug.cgi?id=258285

I used to have this bug a lot but it hasn't hit me since 1.5. YMMV
How to kill a programmer: Give him a shampoo bottle.
Lather, Rinse, and Repeat

http://www.wtc7.net

#6 hillbillygreek

hillbillygreek

  • Members
  • 397 posts
  • OFFLINE
  •  
  • Location:SC
  • Local time:12:41 PM

Posted 08 December 2006 - 01:10 AM

I just tried this & it seems to work:

Go to this page below & download the SearchHotkeys Extension for your version of Firefox. Save it to your desktop.

Search Hotkey

In Firefox choose File > Open File. Look for the searchhotkey XPI file, click once on it to highlight, & click open. Firefox will recognize the XPI & will start the install process. You will then restart Firefox.

In your browser address bar type in about:config . In the filter bar underneath the tabs, start typing in the word search. Find the entry searchkeys.disable.all. On the entry right click on it & choose toggle to set it to true.

Ctrl-F will still open the Search Bar if needed.

Edited by hillbillygreek, 08 December 2006 - 01:30 AM.


#7 buddy215

buddy215

  • Moderator
  • 13,322 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:12:41 PM

Posted 08 December 2006 - 07:45 AM

Just finished reading the link supplied by nlinecomputers. Then searched for a later bug report. Below, is what I found.
According to that report the bug still exists even in 2.0 and as far as I can tell, no one is working on it. Normally, in Firefox fixing a bug is usually finding the bad extension or reinstalling Firefox. I doubt if either of these will work for you. Hopefully, the workaround mentioned by Hillbillygreek in the post above does.

Opened: 2006-10-15 03:59 PST

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8.1)
Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8.1)
Gecko/20061003 Firefox/2.0

Not always but often when entering text in forms or using the text area in
webmails etc the search/find on page opens up and the written shows up there
instead and not in the form/text area.

Reproducible: Sometimes
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#8 nlinecomputers

nlinecomputers

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:12:41 PM

Posted 08 December 2006 - 08:48 AM

If you want the bug to be fixed you should report your problem on that bug report page and you should vote for the bug. Bugs that are being actively discussed get attention.
How to kill a programmer: Give him a shampoo bottle.
Lather, Rinse, and Repeat

http://www.wtc7.net

#9 Puck3tt

Puck3tt
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:12:41 PM

Posted 10 December 2006 - 09:55 AM

Yeah I have the latest version and it still does it. I'll try installing that extension. Thanks.

#10 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 37,011 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:01:41 PM

Posted 26 January 2007 - 10:00 PM

Last night when I was on the computer at the University, I had the same problem occur. (Note the version of Firefox installed on these computers is still 1.5.04. I've no idea why it hasn't been upgraded). This had never happened to me before.

I was on the BleepingComputer site and was responding to a thread, but I wanted to look up some information on other sites. Something on one of those pages triggered this problem: after I found the information I wanted I went back to responding in the thread, and every time I hit the apostrophe the find box would open up and then everything else I typed went into the find box. Here's what I did to solve the problem:

First I cleared cache to see if that would fix it. It didn't.

Next, I checked 'about:config' to see if anything looked as though it had changed. Nothing had.

Then, I went to Tools --> Options --> Content tab --> Advanced by the Javascripts option. There were checks in the first three boxes. At home, I have them all unchecked, so I removed those check marks and voila - the problem was solved, and I could use the apostrophes in typing.

Conclusion: some javascript coding causes this problem and is likely downloaded from various sites. Removing the checks from all the advanced javascript options in the Tools menu will keep the script from affecting keystroke response behaviour.
-----------
Naturally, blocking javascripts excepting on the sites you need them is wise. My home computer is set up to block scripts.

Orange Blossom :thumbsup:
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users