Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Quicktime Opens With Error "unable To Create Control".


  • Please log in to reply
3 replies to this topic

#1 XQuintessenceX

XQuintessenceX

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Local time:09:50 PM

Posted 18 November 2006 - 07:46 PM

Hello,

I first started out with the installation problem...where a message popped up saying "Could not open key:
HKEY_LOCAL_MACHINE\Software\Classes\QuickTimePlayerLib.QuickTimePlayerApp\CLSID. Verify that you have sufficient access to that key, or contact your support personnel." I followed basically every step I could find on the internet, from uninstalling related files, running OneCare, etc. I eventually got Quicktime to install by going through every Quicktime key in the Classes folder and setting it to an Admin permission.

But now when I open Quicktime, a message pops up saying "unable to create control" twice, and I can't play anything because it says the same message. Any help? Thanks.

BC AdBot (Login to Remove)

 


#2 XQuintessenceX

XQuintessenceX
  • Topic Starter

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Local time:09:50 PM

Posted 18 November 2006 - 07:59 PM

Nevermind, I think I fixed it...there were some keys that I apparently forgot to fix. If there are any more problems, I'll post them here.

#3 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:02:50 AM

Posted 16 December 2006 - 07:12 AM

could also post which keys you fixed?

#4 rcopley

rcopley

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:50 PM

Posted 13 January 2007 - 07:52 PM

while I can't speak for XQuintessenceX, I had the same problem and fixed it, i'm not 100% sure if this fixed it bucause I went in and fixed all the quicktime related registry keys. try fixing these keys first:
  • QTOControl.QTControl
  • QTOControl.QTControl.1
  • QTOControl.QTControlPropPage
  • QTOControl.QTControlPropPage.1
remember they are located in
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\
so QTOControl.QTControlPropPage.1 would be HKEY_LOCAL_MACHINE\SOFTWARE\Classes\QTOControl.QTControlPropPage.1

if that does not work, try fixing any other quicktime keys (i think QTOControl.QTControl though QuickTimeSystem)
i'm sorry if I could not have been of more help :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users