Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Uninstall Through Add/remove Programs


  • Please log in to reply
4 replies to this topic

#1 fashunphotog

fashunphotog

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:20 AM

Posted 14 November 2006 - 11:38 AM

Hey all! I used the MS Access Package Wizard to package up an application I wrote. It installs and uninstalls well on most computers but I have two systems where when you run the Add/Remove feature of Control Panel to uninstall the program you get a missing .msi file error message. Pointing to the actual .msi file doesn't help.

The computer in question is running Windows XP. I went into the windows registry as mentioned elsewhere on this forum and deleted all keys for the software I could find. The program still shows up in the Add/Remove programs list but you no longer have the option to Change/Remove. I've gone through the registry looking for references to the program but have been unable to find any.

Stupidly, I forgot to backup the registry before deleting the keys so I can't restore to before I deleted the keys. Running System Restore indicated that there were no restore points even though monitoring was on. (Not my computer)

I even tried running "installer" from Start/Run as per one of the Microsoft directives but still got the missing .msi message.

This is getting frustrating. What more can I do?

Thank you for your help.

Edited by fashunphotog, 14 November 2006 - 11:42 AM.


BC AdBot (Login to Remove)

 


m

#2 TMacK

TMacK

  • Members
  • 4,672 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:B.C. Canada
  • Local time:02:20 AM

Posted 14 November 2006 - 02:24 PM

Hi fashunphotog and Welcome to Bleeping Computer,
When I can't delete a file,I try these two things;

1. Try deleting it in Safe Mode.
2. Change the name of the file.

Not totally sure that these would work with your problem,but worth a try!
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.

aaaaaaaa a~Suzie Wagner

#3 fashunphotog

fashunphotog
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:20 AM

Posted 14 November 2006 - 03:27 PM

Hey, thanks for responding! :thumbsup: Actually, I discovered a Microsoft utility called - ready for this? - Microsoft Installer Cleaner. It's located at support.microsoft.com. Apparently, so many people had this problem that Microsoft finally made a fix for it.

Anyway, I ran it two hours ago and it did the trick! :flowers:

Thanks for getting back to me.

M

#4 fozzie

fozzie

    aut viam inveniam aut faciam


  • Members
  • 3,516 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ossendrecht/The Netherlands
  • Local time:10:20 AM

Posted 14 November 2006 - 03:29 PM

Could you please provide the link, since other members would be delighted to have this

Edited by fozzie, 14 November 2006 - 03:30 PM.


#5 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:04:20 AM

Posted 14 November 2006 - 03:49 PM

Description of the Windows Installer CleanUp Utility

http://support.microsoft.com/kb/290301

The following file is available for download from the Microsoft Download Center:
Download the Windows Installer Cleanup Utility package now.

http://download.microsoft.com/download/e/9...1bd/msicuu2.exe




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users