Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Is There A Way To Open Sites From Programs Without Ie


  • Please log in to reply
8 replies to this topic

#1 Walkman

Walkman

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 AM

Posted 10 November 2006 - 05:34 PM

Hello all,

I was wondering if there is a way to make programs that if you click on a link will open the site using Firefox and not IE?

There are many programs out there, and when you click on the Help button, and About Us or anything similar, they open up using IE. I don't want that. I want my sites to open up using Firefox.

Is there a way to "globally" have Firefox open up, even using any program that links you to their web site?

I've tried many resources, but I'm unable to find a reasonable way to do such.

Any help would be appreciated.

BC AdBot (Login to Remove)

 


#2 rowal5555

rowal5555

    Just enough info to be armed & dangerous...


  • Members
  • 2,644 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St Kilda, Dunedin. South Island. NZ
  • Local time:07:59 PM

Posted 10 November 2006 - 07:48 PM

Hi walkman. Am not positive, but try - In FF, go to Tools/Options/Main/System Defaults (at bottom of page)/Check Now/Set.

See if this works for you.

Cheers

rowal5555 (Rob )                                                             

Avid supporter of Bleeping Computer's
Team 38444

You can help find a cure


 


#3 Walkman

Walkman
  • Topic Starter

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 AM

Posted 10 November 2006 - 08:02 PM

Thanks for the reply rowal5555,

But I don't see a MAIN anywhere in my Firefox. Am I over-looking something?

What version are you using? On this computer, I'm using version 1.5.0.7

#4 buddy215

buddy215

  • Moderator
  • 13,199 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:01:59 AM

Posted 10 November 2006 - 08:12 PM

Click on options / General tab/ set firefox as default browser/ click ok
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#5 Walkman

Walkman
  • Topic Starter

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 AM

Posted 10 November 2006 - 09:01 PM

Click on options / General tab/ set firefox as default browser/ click ok


That has always been my way. Firefox as default.

What I'm going to do is document each program that I use, and within each of them I'm going to document which ones open up their owners web site in IE. I'll then post here, and if anyone has the same programs, do the same and see if your IE or your Firefox will load up.

As a matter of fact, just try any program(s)..... when you get the time to do so, and click the Help menu, then the About Us, or similar (Visit Our Site, Online Help, etc) and see which browser opens up the web page. I'm putting all my cookies on IE.... but I don't want it that way.

Can that issue be solved?..... You'll all see that some of your programs will open up web sites using IE, even if you don't want IE to open them. That's what I'm trying to avoid.

It may be embedded into the programs to use IE as the browser. That's what I'm thinking. But I think those developers are jumping the gun by dictating which browser will/should open the link to a site... from within a program.

#6 scratcher

scratcher

  • Members
  • 124 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:59 PM

Posted 10 November 2006 - 11:50 PM

The way I did it in Win2K was to go into CONTROL PANEL / ADD/REMOVE PROGRAMS / SET PROGRAM ACCESS AND DEFAULTS / Choose a default web browser.

Worked for me. Before I did that my former browser, Netscape, kept coming up even though I had gone into Firefox and set Firefox as the default. Now only Firefox comes up.

* HP Pavilion dv7 *  2.20 gigahertz AMD Phenom II N850 Triple-Core *  4.0 GB RAM  *  Windows 7 Home Premium (x64) *   Firefox 3.6.17 * Thunderbird 3.1.11 *  Comodo Firewall  *  Malwarebytes' Anti-Malware 1.50.1 Pro *  avast! Free Anti-Virus 2014.9.0.2007  *  Erunt  *


#7 Walkman

Walkman
  • Topic Starter

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 AM

Posted 11 November 2006 - 12:17 AM

The way I did it in Win2K was to go into CONTROL PANEL / ADD/REMOVE PROGRAMS / SET PROGRAM ACCESS AND DEFAULTS / Choose a default web browser.

Worked for me. Before I did that my former browser, Netscape, kept coming up even though I had gone into Firefox and set Firefox as the default. Now only Firefox comes up.


That may have been my ticket. My setting wasn't set that way, but I set it. Now I'll see what programs load in Firefox or IE. I'd bet some more cookies that was my issue.

I'll load programs and click on their links within their Help menu just to be sure. But I do thank you for that info. Although I've been going into that area of the Add/Remove section.... they have the double arrows defaulted to NOT show the drop downs, and that's what I've been missing all this time.

Thank you very much for your input (even if it doesn't solve the issue), but you've exposed something to me that was in my face all this time. I'm using Win XP Pro (SP2).

Thanks very much for all the replies. I just learned something else today. :thumbsup:

#8 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:01:59 AM

Posted 11 November 2006 - 03:07 AM

It should work if you click on "Custom" and check only Firefox as your default browser and its enable access button and remove the checkmark and enable access button for IE.

You will still be able to open IE from your menu or desktop icon when you want to do so.

Edited by Enthusiast, 11 November 2006 - 03:10 AM.


#9 Walkman

Walkman
  • Topic Starter

  • Banned
  • 1,327 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:59 AM

Posted 23 November 2006 - 10:35 PM

Thank you all for the tips/suggestions.

Following what was replied to this post seems to be it. I haven't had any programs that open up using IE at all since then :thumbsup: . It's too bad I forgot exactly which programs did before. But they don't now.

I told you all before... the people here at http://www.bleepingcomputer.com are professionals of professionals.

I love you all, because you're all human beings like I am.

Keep up the GREAT work/support Bleeping Computer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users