Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Directx Will Not Update New Version


  • Please log in to reply
1 reply to this topic

#1 Lady T

Lady T

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:05:48 AM

Posted 28 October 2006 - 01:13 PM

My Win2000 sys will not install the newest version of DirectX. Iím trying to of course play some games and they will not open due to not having DirectX 8 or higher. Iím getting error message:

The enter point Ddentry1 could not be found in the dynamic link library Gdi32.dll.


I have installed and reinstalled the latest version but still no luck. I have also gone into the Diagnostic Tool (dxdiag) and it shows all the .dllís as version 5.3 instead of the latest 9.0.

The DirectX install states that it is complete but it seems that all the dllís are not updating to the new version. I have also uninstalled the reinstalled the games with no luck. I have also tried all the fixes found on Microsoft.com.

What next?

Thanks
LT
Lady T

BC AdBot (Login to Remove)

 


m

#2 HitSquad

HitSquad

    You're Bleepin' or you're Weepin'


  • Members
  • 1,573 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Momma
  • Local time:07:48 AM

Posted 28 October 2006 - 06:29 PM

Hi Lady T, welcome to BC.
The .dll file versions listed on the DirectX files tab in dxdiag do not designate the installed version of DirectX.
In other words, the dll's will not be version 9. Most will be 5.03 -6.05, depending on the installed version.
To see the version installed, look on the "System" tab of dxdiag near the bottom. That tells you what version you have. It would seem however that a particular version of "d3d8thk.dll" may be the issue.
See this thread for a possible fix specific to Win2k posted by "Jon".

Edited by HitSquad, 28 October 2006 - 06:32 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users