Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mozilla Firefox


  • Please log in to reply
7 replies to this topic

#1 bjagd02

bjagd02

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:03:42 PM

Posted 15 October 2006 - 01:59 PM

I have Firefox and i try to go to certain sites that use java and they wont load because it tells me my java is turned off or non existant ,but its there. How do I get it to work? Also, I have NoScript and i have to keep clicking allow(site) evry 5 seconds for the page to load correctly. How can I avoid this? Thanks!! :thumbsup: :flowers:

BC AdBot (Login to Remove)

 


#2 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:03:42 PM

Posted 15 October 2006 - 02:14 PM

Make sure you have the latest JavaRuntimeEnvironment installed on your hard drive (you should see a Java Control Panel when you open up the Windows Control Panel).
https://addons.mozilla.org/firefox/plugins/


You can set NoScript to allow scripting by site; if you trust the site, then click on the "S" at the bottom right of the viewing panel, click on "options" and then "general" to add web sites that are to be allowed to execute scripts. Under the "Advanced" tab, see if you have "forbid Java" checked for untrusted sites.
Regards,
John
Whereof one cannot speak, thereof one should be silent.

#3 bjagd02

bjagd02
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:03:42 PM

Posted 15 October 2006 - 03:55 PM

Everything is running and up to date,but some pictures still wont load, and, when i try to pay my sprint cell phone bill online i just get the following message "Your browser does not support javascript, or javascript is turned off on your browser. This site requires the use of javascript. Please enable javascript and refresh this page to try again." But I have java and its on... when i go to the java options it wont let me turn it on for firefox how do i get that to work? ( i click the advanced tab in the java control panel, then click <APPLET> tag support, then check Mozilla and Netsace but then it tells me "Pleace check that Mozilla or Netscape is properly installed on the system and/or that you have sufficient permissions to ch :thumbsup: :flowers: ange system settings."

#4 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 37,046 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:03:42 PM

Posted 15 October 2006 - 04:56 PM

Okay, let's check some settings within Firefox.

Click on Tools then Options. Click on the Content icon at the top of the options screen. Make sure there is a check mark by Enable JavaScript. If there isn't, click on the little white box to put one there. That will solve the JavaScript problem. You likely don't need one by the Enable Java. I rarely have to have this enabled.

For the pictures: On the same Content screen, make sure that there is a little check mark by Load Images. If there isn't, click on the little white box to put one there. If there is a check by "for the originating website only," this will block all pictures not hosted directly on that site, such as many of the pictures on this site.

Other questions: By chance, do you have an extension called NoScripts? Do you have any other software with privacy settings? For example, my ZoneAlarm privacy suite can block JavaScripts, pictures, java and many other items. It can block any and all downloads depending on the settings. It is possible that a software program with privacy settings is blocking the scripts and pictures.

Orange Blossom :thumbsup:
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Internet Security, NoScript Firefox ext.


animinionsmalltext.gif

#5 bjagd02

bjagd02
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:03:42 PM

Posted 16 October 2006 - 01:19 PM

I checked all of my spyware programs, and found nothing...what is going on????

#6 bjagd02

bjagd02
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:03:42 PM

Posted 16 October 2006 - 01:20 PM

oh yeah and enable javavscript and load images were both already checked.

#7 buddy215

buddy215

  • Moderator
  • 13,406 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:02:42 PM

Posted 16 October 2006 - 01:37 PM

The way NoScript works is it blocks ALL scripting in the site you visit until you select to allow the script to run either temporarily or all the time. When going to a new site click on the NoScript symbol and click on the line that best resembles what is in your search window. This allows script to run for the site you searched for. You will notice other lines which you can enable, also. These are usually scripts for ads that you see on the page.
Usually just allowing the one script line to run will also allow you to use logins or fill out forms, etc.
Learn to use NoScript correctly and it will be one of the most important security tools on your computer!!!
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#8 buddy215

buddy215

  • Moderator
  • 13,406 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:02:42 PM

Posted 16 October 2006 - 01:41 PM

A good way to probably best demonstrate the use of NoScript is to pick a site and give the address here. I will go on the site and tell you which lines in NoScript are needed and which are ad related, etc.
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users