Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop gets on the Wi-Fi, but no Internet


  • Please log in to reply
10 replies to this topic

#1 mellechman

mellechman

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 14 September 2018 - 02:30 PM

Greetings to anyone who takes the trouble to read this post!

 

For a while now, I’ve been having an annoying situation with my Wi-Fi at home. I did some research, but I can’t find any useful tips on Internet, so I was wondering if anyone has any ideas for helping me.

 

It’s like that: We have three laptops at home, all running Windows 10, as well as a host of other devices (smartphones, tablets, Chromecast), which all connect, via the Wi-Fi, to the Internet. The phones, tablets and Chromecasts usually rarely have a problem connecting to the Internet but, often, if one laptop is switched off/has gone to sleep and is woken up, it will connect to the Wi-Fi but a yellow triangle will appear on the Network icon on the bottom right hand corner of the task bar, it will say “No Internet Connection” and the thing will not go on the Internet. This usually happens when one or both of the other laptops are connected to the Internet. The problem goes away by simply resetting (unplug and plug in again) the router, but then one of the other laptops might lose its Internet connection.

 

The thing is annoying; restarting the router when you want to get on the Internet interrupts the connection for all the other users and if you keep doing that it gets on everybody’s nerves. The only thing the provider suggested, when I managed to get through to them, was switching to a different “Channel” on the router, but I have done that several times and it has not really changed anything.

 

I would really be grateful for any tips that might work. Thanks in advance!

 



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,638 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:24 AM

Posted 14 September 2018 - 03:33 PM

A place to start: Disable Fast Startup on all your Windows10 computers. This uses a hibernation file for supposedly faster startup but it can give problems.

 

https://www.windowscentral.com/how-disable-windows-10-fast-startup

 

Once disabled open an elevated command prompt. Windows key +  X  > Powershell as admin. Type the following commands

powercfg.exe -h off

Reboot. See if that helps. If not then on the Windows 10 computers you can do a Network Reset. 

  1. Select the Start  button, then select Settings  > Network & Internet  > Status > Network reset.
  2. On the Network reset screen, select Reset now > Yes to confirm.

Edited by JohnC_21, 14 September 2018 - 03:33 PM.


#3 mellechman

mellechman
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 15 September 2018 - 07:03 PM

Thanks! I followed your advice on all of the Laptops, but the problem persists. I am convinced the problem lies with the router, not the individual laptops. Any suggestions anyone? By the way, the router is a Netgear one. 



#4 JohnC_21

JohnC_21

  • Members
  • 24,638 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:24 AM

Posted 16 September 2018 - 08:26 AM

On the Windows 10 computers that have a problem see if giving them a static IP outside of the router's DHCP server addresses helps. 



#5 mellechman

mellechman
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 16 September 2018 - 09:24 AM

At the moment, I have now idea how to do that :) I could google it, but if you could point me to a page explaining how to do it, I'd be much obliged. 

 

By the way, since the problem just reappeared on one laptop, I went and looked up  the Network properties of the connection on that laptop and noticed that the following columns were missing (when compared with another laptop which was on the Internet on the same Wi-Fi): Link Speed, DHCP enabled, DHCP servers, DHCP lease obtained, DHCP lease expires, Defautl gateway,  Network name, Network category.

 

Connectivity (IPv4/IPv6) showed "Connected to unknown network no traffic" i.e. it does not even recognise the name of the Wi-Fi Network. 

 

I should also mention that connection to the Internet is via a Netgear Wirelles Cable Voice Gateway CVG834G, to which my telephone line is also hooked-up. I'm in Europe and the service profider is sfr, formerly numericable, formerly coditel. I haven't been able to find much on the Internet on that particular device. Most importantly, I don't know if (and how) to update the firmware. 

 

Thanks again JohnC_21 for your interest and efforts and also thanks in advance to anyone else who might take an interest. 



#6 JohnC_21

JohnC_21

  • Members
  • 24,638 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:24 AM

Posted 16 September 2018 - 09:51 AM

You're Welcome,

 

In your router settings you will see a range for your DHCP server. It can be in the range of 50 or so addresses. Outside of that range would be your address to create a static IP address.

 

This page provides the steps. 

 

https://portforward.com/networking/static-ip-windows-10.htm

 

For your DHCP address range see page 4-9 of the manual.

 

https://www.dsl-cable.net/site/doc/cable/sfr/netgear-cbvg834g-manuel-ref.pdf

 

Edit: The above manual is cbvg not cvg but it should be close.


Edited by JohnC_21, 16 September 2018 - 09:52 AM.


#7 mellechman

mellechman
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 27 October 2018 - 03:12 PM

Brief update here. In the end, it turned out that the problem was, in all probability, with the modem. I contacted the Internet access provider and they did the obvious thing, suggested that I swap the modem for a new one for free, so that's what I did. Actually, I was offered the option of updating to much quicker Internet for the same price, if I signed up for 2 years. Considering the problems I had been experiencing, maybe I should not have done that, but I said "yes", got my new modem , set everything up and, since then, I have had no problems accessing the Internet on any device. 

 

Thanks again to JohnC_21 for his help. 



#8 sjpritch25

sjpritch25

  • Security Colleague
  • 909 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Coast of Florida, USA
  • Local time:05:24 AM

Posted 27 October 2018 - 11:32 PM

In the future,  most ISP modem routers will be setup to auto for wifi channels.  Most of the issues you were describing are most likely related to the specific wifi channel you were on.  That's, why its best to let the router detect the proper channel and not set it manually to one channel.   Once the channel gets overloaded, your devices will get knocked off the network.  


Microsoft MVP Consumer Security--2007-2010

#9 mellechman

mellechman
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 28 October 2018 - 12:05 AM

Funny you should say that, because the first time I reported the problem to the provider, their advice was "[manually] change the WiFi channel on your router". I did that, but it didn't help.

 

Also, it was not a question of devices getting knocked off the network, once a device was on, it would never get knocked off. The problem was that when a laptop woke up from sleep, it would connect to the WiFi network but NOT to the internet, and there was no way to fix that but to restart the router. 


Edited by mellechman, 28 October 2018 - 12:05 AM.


#10 sjpritch25

sjpritch25

  • Security Colleague
  • 909 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Coast of Florida, USA
  • Local time:05:24 AM

Posted 29 October 2018 - 02:02 PM

Have you changed any of the IP address range. If the IP range is set to short of a list that could cause issues with devices not connecting. Do you have DHCP reservation enabled?
Microsoft MVP Consumer Security--2007-2010

#11 mellechman

mellechman
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:24 AM

Posted 30 October 2018 - 05:52 PM

Perhaps you did not understand that the problem is now resolved and, in all probability, was due to the router. The provider replaced the router for free and the problem went away. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users