Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

no NTFS permissions on a folder


  • Please log in to reply
2 replies to this topic

#1 mypalabok

mypalabok

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:56 AM

Posted 12 August 2018 - 08:31 AM

i created a folder on my Desktop a few days ago, now when i want to delete it, it says folder access denied.

 

i tried to take ownership and i can't.

i've tried some tools i found on the net to reset the NTFS permissions but it requires ownership of the folder, which i can't in the first place.

 

so how does one take ownership, and eventually reset the NTFS permissions of a folder like this?



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,819 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:56 AM

Posted 12 August 2018 - 08:47 AM

Have you tried deleting in Safe Mode?

 

If Safe Mode does not work use a program like file assassin. It should work on a folder.

 

https://www.malwarebytes.com/fileassassin

 

If file assassin does not work: For a folder that refuses to delete I usually boot a live linux distro. You will need to burn the iso to a Cd or create a bootable USB with Rufus. That takes care of deleting anything with permissions problems as linux doesn't care about Windows permissions. A small distro like Puppy would work. Your hard drive would be sdax in the lower left desktop. x being the partition number of your Windows partition. For Windows 10 it could be sda3. You only need to click once on a icon to open the File Manager. Browse to your folder. You only need to click once to open folders. Right click and select Delete.

 

http://puppylinux.org/main/Overview%20and%20Getting%20Started.htm

 

 

 

 



#3 jenae

jenae

  • Members
  • 925 posts
  • OFFLINE
  •  
  • Local time:05:56 PM

Posted 12 August 2018 - 05:05 PM

Hi, Good advice from John,  You can take ownership a number of ways, firstly the account you are logged in as, does it have admin privledges?
 
Probably easiest way is to use cmd prompt and "Takeown" and "Icacls" cmd's.
 
You need to open a cmd prompt header as administrator (elevated) to do this press the win + r keys together, in the run dialogue box type:- cmd
 
Next press the ctrl+shift+enter keys on the keyboard, an elevated cmd prompt will open.
 
At this you type:-
 
Takeown /F (full path to your folder, say the folder is called "Stuff" and it is located at c:\users\me\desktop\stuff, ("me" would be your users name), so the cmd is (substitute your details for mine in this example).
 
Takeown /F c:\users\me\desktop\stuff (press enter)
 
You will see a success message, along these lines:-
 
Success: the file (or folder): "c:\users\me\desktop\stuff" now owned by  user "me" (where "me" would be your user name).
 
Next at the cmd prompt you type:-
 
icacls c:\users\me\desktop\stuff /grant me:F (press enter) 
 
NOTE:- you substitute the right path and your user name in these cmd's, if your user name is truncated (ex:- Bill Smith, then you will need to place " " around it in these cmd's ie "Bill Smith").
 
You should receive a success message, restart computer (restart not shutdown) and you should be good to go.

Edited by jenae, 12 August 2018 - 05:07 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users