Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Desktop cannot resume from sleep if it sleeps by itself


  • Please log in to reply
7 replies to this topic

#1 randomystique

randomystique

  • Members
  • 114 posts
  • OFFLINE
  •  
  • Local time:09:40 PM

Posted 09 August 2018 - 05:46 PM

I used to have a very similar problem. My previous desktop could not wake up from sleep, regardless of whether I initiated Sleep or the desktop slept by itself due to inactivity after 10 minutes.

 

This time, it can resume if I call it to sleep, but it cannot wake up if it sleeps by itself. 

 

Already tried all possible steps but still to no avail:

 

- updated all drivers and windows updates and motherboard bios

- "allow device to wake computer" via device manager 

- no errors on chkdsk

 

using:

 

6600k

4 x 4Gb RAM

GTX 1060 3Gb

 

really need some help here. Thanks!


Edited by randomystique, 09 August 2018 - 05:47 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,615 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:40 PM

Posted 09 August 2018 - 05:56 PM

This could be due to Windows 10 hybrid shutdown called Fast Startup.

 

Disable Fast Startup.

 

Once disabled open an elevated command prompt. Windows key + X powershell as admin. Type the following commands

powercfg.exe -h off
shutdown /s /f /t 0

Reboot and see if the computer will come out of sleep when it sleeps on it's own. The hybernation file hiberfil.sys can become corrupted and lead to all sorts of problems. It's best to keep it disabled.


Edited by JohnC_21, 09 August 2018 - 05:56 PM.


#3 randomystique

randomystique
  • Topic Starter

  • Members
  • 114 posts
  • OFFLINE
  •  
  • Local time:09:40 PM

Posted 10 August 2018 - 08:05 AM

This could be due to Windows 10 hybrid shutdown called Fast Startup.

 

Disable Fast Startup.

 

Once disabled open an elevated command prompt. Windows key + X powershell as admin. Type the following commands

powercfg.exe -h off
shutdown /s /f /t 0

Reboot and see if the computer will come out of sleep when it sleeps on it's own. The hybernation file hiberfil.sys can become corrupted and lead to all sorts of problems. It's best to keep it disabled.

 

just tested. still the same issue. 

 

Separately, i never ever use hibernation mode too, so the hiberfil.sys file is untouched.



#4 JohnC_21

JohnC_21

  • Members
  • 24,615 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:40 PM

Posted 10 August 2018 - 08:26 AM

I had once had a similar issue where if I put the computer to sleep I would never be able to get it out of sleep. It turned out to be the PSU. I can't say this is your problem. Other than what I posted, I have no other ideas other then the following. 

 

Change your Power Plan to High Performance.

 

https://www.tenforums.com/tutorials/2843-change-power-plan-settings-windows-10-a.html

 

There are also troubleshooting steps here.

 

https://appuals.com/how-to-fix-windows-10-not-waking-up-from-sleep-mode/

 

Do a clean boot. Let the computer sleep and see if it comes out. There may be a service or startup item that is conflicting. Enable startup items and services a few at a time until the problem returns.



#5 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:40 PM

Posted 10 August 2018 - 01:26 PM

I have had success with the following command to reset your power plan. From Elavated command prompt enter or copy and paste the following.

powercfg -restoredefaultschemes


We are all volunteers so please by kind, courteous and respectful

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#6 randomystique

randomystique
  • Topic Starter

  • Members
  • 114 posts
  • OFFLINE
  •  
  • Local time:09:40 PM

Posted 12 August 2018 - 07:07 AM

thanks both. have tried it and it still exhibits the same issue. 

 

the PSU is brand new too by the way.



#7 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:40 PM

Posted 12 August 2018 - 11:18 AM

What happens if you change it hibernate instead of sleep?

We are all volunteers so please by kind, courteous and respectful

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#8 randomystique

randomystique
  • Topic Starter

  • Members
  • 114 posts
  • OFFLINE
  •  
  • Local time:09:40 PM

Posted 17 August 2018 - 06:04 AM

hibernate works perfectly, but i never want to use it as I have 16Gb of RAM to backup to disk, which is inefficient.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users