Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

NAS connectivity issues on local network


  • Please log in to reply
1 reply to this topic

#1 jo_wishbone

jo_wishbone

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:56 AM

Posted 05 August 2018 - 11:11 AM

Hello,

 

so I have this NAS - Asustor AS3204T. For a while there were no problems, I set it up quite easily and I was running it for six months without a problem. All of the sudden it started acting up on my home computer that runs Win10.

 

For a few weeks I could find the drive on the network only if i restarted the NAS. It wasn't that big of a problem until one night i decided to "fix" it. One of the suggested solutions were to revert to SMB1 connection, so I ordered the NAS to take maximum of SMB1, ignoring the second and third. This made the drive totally invisible on my network. So I have reverted the settings. But the problem persisted.

 

Now I've been trying solutions from all over the internet. At first I have focused on Samba related fixes (it seems that I'm not the only one this type of problems, especially on Win10 machines), network visibility and connectivity fixes, also turned off the Blacklists on the NAS, tried turning off Windows Defender and antivirus... well most of the basic stuff I guess. After six hours of searching and trying, I'm stumped as to what the solution is.

 

The NAS works fine in online browser and through mobile apps. It seems only my main networked Win10 is affected, and seems more like a windows problem than a router one.

 

The weird thing is that I found out that the NAS is findable through direct search (as in \\AS3204T-FEDC\), but the root is invisible to the user. When trying the second level (as in \\AS3204T-FEDC\Work) it gives me the basic network error (0x80070035). When I try hard enough (as in try to connect for a few minutes) in the end it will let me enter my credentials and log in. What the hell Microsoft. Also after I once log in, I'll stay that way until reboot.

 

Its all documented in this video . Please bear with me, the nature of the problem means the video is six minutes long even after speeding it up.

 

TL:DR

I have Asustor NAS AS3204T, my windows 10 saw it just fine on local network for a few months. Now it stopped working and I can find it only after few minutes of unsuccesfull clicking as seen in this video.

Connection from other devices works just fine, the online and mobile browser also work. I have tried all the basic stuff like switching off antivirus, win defender, restarting NAS. Please help me.



BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,461 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:10:56 PM

Posted 06 August 2018 - 03:17 PM

If the NAS uses SMB1 it was removed from Windows 10 in the Fall Creators update.

 

You can open PowerShell as an Administrator and run this command to install SMB1.

 

Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users