Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot Install Firefox In Another Language


  • Please log in to reply
6 replies to this topic

#1 MinterTheMaladroit

MinterTheMaladroit

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 03 August 2018 - 01:19 AM

Hello,

 

I recently installed Linux Mint 19 Cinnamon (x64) and do not know much about it. As you know, Firefox comes preinstalled with this distribution and it is in English regardless the language of the OS.

 

I went ahead and downloaded Firefox version of the desired language (the file extension is tar.bz2). Since I do not know how to install it, I extracted the files and ran the "firefox" executable file in the folder. So far everything is okay, the Firefox is in the desired language. However, whenever I execute the program from anywhere but the downloaded file, English Firefox pops up.

 

I do not know if it is related but even I set Google as the default search engine in the downloaded Firefox, the setting goes back to Yahoo or Yandex spontaneously.

 

Awaiting for your help,

Thank you.


Edited by MinterTheMaladroit, 03 August 2018 - 01:21 AM.


BC AdBot (Login to Remove)

 


#2 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,959 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 03 August 2018 - 01:43 AM

Open menu in Firefox....(three horizontal lines in top right hand corner of open page)

 

Go to Preferences

 

Then to :

232.png

 

and then.....

 

121.png

 

Click on "Select a language to add....

 

there is a drop down menu....amazing choice.....

 

Select your language....then click on "add"........then "OK "

 

Close Firefox and then reopen and you should be good to go

 

let me know.


Condobloke ...Outback Australian  fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

 GcnI1aH.jpg

 

 


#3 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,959 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 03 August 2018 - 03:08 AM

Sorry, I missed the google default search engine bit....

 

click on menu...search......scrol right to the bottom......."find more search engines"

 

down the bottom again.....find the google icon....hover over each one to find it......click on it...it will ask if you want to select this as default...click on yes.


Edited by Condobloke, 03 August 2018 - 03:16 AM.

Condobloke ...Outback Australian  fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

“A man travels the world in search of what he needs and returns home to find it."

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

 GcnI1aH.jpg

 

 


#4 MinterTheMaladroit

MinterTheMaladroit
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 03 August 2018 - 05:15 AM

Open menu in Firefox....(three horizontal lines in top right hand corner of open page)

 

Go to Preferences

 

Then to :

232.png

 

and then.....

 

121.png

 

Click on "Select a language to add....

 

there is a drop down menu....amazing choice.....

 

Select your language....then click on "add"........then "OK "

 

Close Firefox and then reopen and you should be good to go

 

let me know.

 

I think there is a misunderstanding there. I don't mind search results being based on English. I would like the Firefox settings etc. to be in another language.

 

 

 

Sorry, I missed the google default search engine bit....

 

click on menu...search......scrol right to the bottom......."find more search engines"

 

down the bottom again.....find the google icon....hover over each one to find it......click on it...it will ask if you want to select this as default...click on yes.

 

Thanks, this tip solved the search engine problem.



#5 Al1000

Al1000

  • Global Moderator
  • 7,731 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:01 PM

Posted 03 August 2018 - 06:26 AM

Since I do not know how to install it, I extracted the files and ran the "firefox" executable file in the folder. So far everything is okay, the Firefox is in the desired language. However, whenever I execute the program from anywhere but the downloaded file, English Firefox pops up.


The easiest thing to do would be to point your Firefox desktop icon to execute the new file.

Having extracted the contents of the tar.bz2 directory:

1) Right click on your Firefox desktop icon.
2) In the menu that opens, click edit
3) In the window that opens, click Browse
4) Navigate to the new Firefox executable file
5) Click the OK button.

Firefox should now start in your chosen language when you click on the desktop icon.

#6 MinterTheMaladroit

MinterTheMaladroit
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 03 August 2018 - 06:37 AM

 

Since I do not know how to install it, I extracted the files and ran the "firefox" executable file in the folder. So far everything is okay, the Firefox is in the desired language. However, whenever I execute the program from anywhere but the downloaded file, English Firefox pops up.


The easiest thing to do would be to point your Firefox desktop icon to execute the new file.

Having extracted the contents of the tar.bz2 directory:

1) Right click on your Firefox desktop icon.
2) In the menu that opens, click edit
3) In the window that opens, click Browse
4) Navigate to the new Firefox executable file
5) Click the OK button.

Firefox should now start in your chosen language when you click on the desktop icon.

 

 

Thank you, it worked.



#7 Al1000

Al1000

  • Global Moderator
  • 7,731 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:01 PM

Posted 03 August 2018 - 06:38 AM

You're welcome. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users