Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

2nd Drive not recognized after switching from IDE to AHCI and back again.


  • Please log in to reply
6 replies to this topic

#1 easybullet3

easybullet3

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:58 AM

Posted 02 August 2018 - 02:43 PM

Summary:

I decided to change from IDE to AHCI (using both: Bios and RegEdit).

System was really slow to boot, so I switched it back to IDE again,

But now my problem is that I still have the incredibly slow boot up and now my 2nd hard drive is not being recognized (even in Disk Management its not recognized)

I would appreciate any help. 
I want to avoid re-installing windows.

is there any way to remove all the AHCI drivers and also to get my 2nd drive recognized again ?

Thank you 

 

Windows 7
Gigabyte Motherboard: GA-X58A-UD3R (Ver. 2)
CPU: i7 950
Graphics: PALIT GeForce GTX-470
Memory: 12GB Kingston Hyper-X KHX1600C9D3K2/4GX (DDR3) 
........... (All banks are full with identical RAM)
Hard Drives:
1GB WD (blue) for the OS
2GB WD (black) for storage (not recognized)

 

 

These are the Values I used in the RegEdit:
For IDE mode:
msahci's START value is "3"
pciide's START value is "0"
For AHCI mode:
msahci's START value is "0"
pciide's START value is "3"

.


Edited by hamluis, 02 August 2018 - 02:53 PM.


BC AdBot (Login to Remove)

 


#2 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,028 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:58 PM

Posted 08 August 2018 - 12:37 PM

The following is the proper way to change from IDE to AHCI or vice versa. However, I recommend AHCI

 

Change IDE/Raid to AHCI
1. Run MSCONFIG
2. Enable Safe Boot (minimal)
3. Reboot into UEFI/BIOS and change to AHCI
4. Boot up into safe mode
5. Run MSCONFIG and disable Safe Boot.
6. Reboot

We are all volunteers so please by kind, courteous and respectful of all staff and members

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#3 easybullet3

easybullet3
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:58 AM

Posted 08 August 2018 - 09:24 PM

 

The following is the proper way to change from IDE to AHCI or vice versa. However, I recommend AHCI

 

Change IDE/Raid to AHCI
1. Run MSCONFIG
2. Enable Safe Boot (minimal)
3. Reboot into UEFI/BIOS and change to AHCI
4. Boot up into safe mode
5. Run MSCONFIG and disable Safe Boot.
6. Reboot

The problem I have is that AHCI really slowed down the boot process so much (because of all the extra drivers it adds).

And, then I Changed back to IDE mode (which is what I now want)..  only to find that all these drivers are still present, and now the computer still boots up slow.

AND the 2nd hard drive doesnt work anymore (since switching BACK to IDE).

I want to solve these issues.

 

Thanks for the advice on the correct method for switching between the two, but it doesnt really help with the current problem.



#4 joseibarra

joseibarra

  • Members
  • 1,259 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:10:58 PM

Posted 08 August 2018 - 10:36 PM

I don't have any IDE device attached to check things but back in the good old days when most everything was IDE a common complaint was one of performance.

 

The solution which may not apply to modern systems was to get into Device Manager and check the Transfer Mode of the IDE channels and since I have no IDE I can't provide a screenshot but have text of what to look for.

 

If you are using IDE drives, use Device Manager to verify the Transfer Mode of the IDE channels is set to something like DMA if available (depends on your hardware) and not the slower PIO mode.
  
Remember:  PIO is the slowest, DMA is the fastest.
 
This is easy to check and generally easy to fix and the mode would not have changed by itself,so if it has changed to PIO, change it to DMA and then figure out why it changed and fix it.
 
To launch the Device Manager console, click Start, Run and in the box enter:
 
devmgmt.msc
 
Click OK.
 
Expand the IDE/ATA controller section to see your IDE channels. Right click each one, choose Properties, and for each channel that has an Advanced Settings tab, determine the Transfer Mode. There are usually 4 channels to check in a desktop, maybe fewer for laptops so just check them all.
 
The fastest selection will always be some kind of DMA selection (usually: DMA, DMA5, DMA if available, UDMA, etc.).  If it is PIO, change it to DMA.
  
If you make any adjustments, reboot and check the settings again to make sure any changes "stick".

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#5 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,028 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:58 PM

Posted 09 August 2018 - 09:58 AM

IMO if you are having issues with slow boot it is not because of the using AHCI over IDE. Most all modern systems are set to use AHCI mode now and all I have ever used for a long time.

 

I recommend changing your drives back to AHCI mode and see if you can get them to work and then we can look at what may be slowing down your boot process.


We are all volunteers so please by kind, courteous and respectful of all staff and members

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 


#6 easybullet3

easybullet3
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:58 AM

Posted 10 August 2018 - 09:32 AM

IMO if you are having issues with slow boot it is not because of the using AHCI over IDE. Most all modern systems are set to use AHCI mode now and all I have ever used for a long time.

 

I recommend changing your drives back to AHCI mode and see if you can get them to work and then we can look at what may be slowing down your boot process.

ok,

but,, my bootup was GOOD (in IDE mode).

the second I changed to AHCI it went to 'turtle-speed'.

so i know it was directly connected to the change.

Now I have 3 to 4 minutes boot up process.

immediately prior to the swap (from IDE to AHCI) i had just over a minute boot-up.

 

and mostly, when I swapped back to IDE again, now the 2nd drive is not recognized at all (even in 'disk management').

 

if I went back to AHCI, what should be my next step, do you think ?



#7 dmccoy

dmccoy

  • BSOD Kernel Dump Expert
  • 1,028 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:58 PM

Posted 10 August 2018 - 09:56 AM

Do you see the 2nd drive in the bios? Do you have any files you need on that drive?


We are all volunteers so please by kind, courteous and respectful of all staff and members

 

I try to respond in 24-48 hours normally and I am more active on weekdays than weekends. However, sometimes due to my health, family or life it may take me a little longer. If you have not heard from me within 72 hours then please PM me a reminder. 

 

BC BSOD Posting Instructions 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users