Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

wsqmcons.exe Steals Focus


  • Please log in to reply
11 replies to this topic

#1 Ethanicus

Ethanicus

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 01 August 2018 - 01:12 PM

Hi everyone.

 

I've had this issue for a while now. Sometimes my focus on the current (usually Google Chrome) window turns off. About a second later, one of two things happens:

  1. If I'm just on one monitor, it never comes back by itself and I have to click back in
  2. If I have Chrome open in two windows in two monitors, it switches over to the window on the right monitor

This time around, I kept a Sysinternals Process Monitor window open. Same thing. Focus lost, switches over. And when I looked to see what just happened, I see "wsqmcons.exe" performed a Process Exit Operation right at that moment.

 

I don't know the purpose of this program or why it's doing this. I'd really appreciate some help on the subject as it's very frustrating.

 

Thanks!



BC AdBot (Login to Remove)

 


#2 old rocker

old rocker

  • Members
  • 485 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:East Tennessee
  • Local time:04:44 PM

Posted 01 August 2018 - 02:32 PM

Hello Ethanicus!
 
Please try this...
In the taskbar search box enter: task scheduler
Right click Task Scheduler and select Run as administrator
When the Task Scheduler window opens click the > next to Task Scheduler Library,  click the > next to Microsoft, click the > next to Windows
Drill down the list to Customer Experience Program and click the folder to open
Locate and right click Consolidator, from the context menu select disable.
Close the Task Scheduler, reboot the system, you should be good to go.
Old Rocker


#3 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 01 August 2018 - 02:45 PM

 

Hello Ethanicus!
 
Please try this...
In the taskbar search box enter: task scheduler
Right click Task Scheduler and select Run as administrator
When the Task Scheduler window opens click the > next to Task Scheduler Library,  click the > next to Microsoft, click the > next to Windows
Drill down the list to Customer Experience Program and click the folder to open
Locate and right click Consolidator, from the context menu select disable.
Close the Task Scheduler, reboot the system, you should be good to go.
Old Rocker

 

 

Thank you for the advise! I'll do this and report back if it works.



#4 jenae

jenae

  • Members
  • 736 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 03 August 2018 - 03:07 AM

Hi, you might be lucky and that scheduled task is the culprit, however unlike Vista & Seven days, the Customer Experience program has many hooks into task scheduler in win 10 (around 7-8), consolidator being only one of them.

 

Probably best if you disable it using group policy (win pro and above only, could you let us know what version you have?) OR you can use the registry, to see what setting you have for this process, this is perfectly safe it only reads the registry 

 

Press the win + x keys together, from the options select powershell(admin) an elevated powershell prompt will open.

 

At the prompt first type:- cmd (press enter)

 

Next copy this cmd and right click anywhere in the powershell window the cmd will append to the prompt, press enter.

 

reg query "HKLM\Software\Microsoft\SQMClient\Windows" > 0 & notepad 0

 

Notepad will open with a registry entry please copy paste the notepad output here.


Edited by jenae, 03 August 2018 - 03:08 AM.


#5 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 27 August 2018 - 11:47 AM

Hi, you might be lucky and that scheduled task is the culprit, however unlike Vista & Seven days, the Customer Experience program has many hooks into task scheduler in win 10 (around 7-8), consolidator being only one of them.

 

Probably best if you disable it using group policy (win pro and above only, could you let us know what version you have?) OR you can use the registry, to see what setting you have for this process, this is perfectly safe it only reads the registry 

 

Press the win + x keys together, from the options select powershell(admin) an elevated powershell prompt will open.

 

At the prompt first type:- cmd (press enter)

 

Next copy this cmd and right click anywhere in the powershell window the cmd will append to the prompt, press enter.

 

reg query "HKLM\Software\Microsoft\SQMClient\Windows" > 0 & notepad 0

 

Notepad will open with a registry entry please copy paste the notepad output here.

 

So sorry I took so long to get back to you! Stuff came up.

 

Here's the output of that doc:


HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows
    CEIPEnable    REG_DWORD    0x0

HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows\CommonDatapoints
HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows\ServerSync
HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows\Uploader

The problem is still occurring, frequently, even after following old rocker's tip.

 

And I have Windows 10 Home.


Edited by Ethanicus, 27 August 2018 - 11:47 AM.


#6 jenae

jenae

  • Members
  • 736 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 27 August 2018 - 08:30 PM

Hi, well the CEIPEnable is set to 0 and holding, so we have to look deeper. from Old Rockers excellent first post navigate to the task scheduler and disable the other tasks showing under this task. It could be a focus issue win 10 now has focus assist:-

 

 

https://www.windowscentral.com/how-use-focus-assist-reduce-distractions-windows-10-april-2018-update



#7 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 27 August 2018 - 11:06 PM

Hi, well the CEIPEnable is set to 0 and holding, so we have to look deeper. from Old Rockers excellent first post navigate to the task scheduler and disable the other tasks showing under this task. It could be a focus issue win 10 now has focus assist:-

 

 

https://www.windowscentral.com/how-use-focus-assist-reduce-distractions-windows-10-april-2018-update

 

Another happening has occurred. I had two separate Chrome windows open in my external monitor, on the right. I was doing something in the first window, and suddenly, it flipped over to the second window, as if I'd hit Alt-Tab. Just thought I'd bring it up. Is there a chance it's a Chrome issue?

 

I'll try your advice there as well and see if it fixes the issue.

 

EDIT: Also, there was only one other task there to disable. "usbceip"


Edited by Ethanicus, 27 August 2018 - 11:13 PM.


#8 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 06 September 2018 - 11:01 AM

Still seems to be occurring, even after following all the steps. I've restarted a few times by now.



#9 jenae

jenae

  • Members
  • 736 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 06 September 2018 - 05:50 PM

Hi, press the win + x keys together select Powershell (admin) from the options.

 

Copy this cmd and right click anywhere in the powershell window the cmd will append to the prompt, press enter.

 

Get-appxpackage -all *shellexperience* -packagetype bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + “\appxmetadata\appxbundlemanifest.xml”)}

 

This re registers the controlling process ( windows shell experience host). See if this helps.



#10 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 07 September 2018 - 12:49 PM

Hi, press the win + x keys together select Powershell (admin) from the options.

 

Copy this cmd and right click anywhere in the powershell window the cmd will append to the prompt, press enter.

 

Get-appxpackage -all *shellexperience* -packagetype bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + “\appxmetadata\appxbundlemanifest.xml”)}

 

This re registers the controlling process ( windows shell experience host). See if this helps.

 

Do I need to restart?

 

Also, there was no confirmation output or anything, is that intended behavior?



#11 jenae

jenae

  • Members
  • 736 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 07 September 2018 - 06:02 PM

Hi, yes, meant to add the restart, you would only see the cmd run, no confirmation.



#12 Ethanicus

Ethanicus
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:44 PM

Posted 17 September 2018 - 09:21 AM

Hi, yes, meant to add the restart, you would only see the cmd run, no confirmation.

 

Keeps happening, even now. I really have no idea what's wrong at this point...  :smash:






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users