Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Copy and Paste Issue Server 2012 R2


  • Please log in to reply
2 replies to this topic

#1 zzzzhf456

zzzzhf456

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:29 AM

Posted 01 August 2018 - 04:17 AM

I have RDS setup with one domain controller and a session host, which our users RDP into to work. We use copy and paste for a couple essential functions, and it had been working just fine until Thursday last week. I was updating GP to be a bit more secure on the Session Host. Now, files cannot be copied and pasted. Thinking I had set something too restrictive, I un-enforced that GPO, but, even with no GP enforced, we cannot copy and paste files with this host. I can copy and paste to the DC. I can copy and paste textto/from the session host. I tested the GP by enforcing it and restricting users from changing desktop background. It worked, the policy was enforced and when I changed that policy back to allow changing of desktop wallpaper, users were able to do so. So the Session Host sees the DC and reads/applies policy correctly. RDP clients are setup correctly, with appropriate local resources (clipboard, drives, etc.) checked before remoting in, and users can print from the remote host to their local workstations. I'm working from a Windows 10 machine version 1803, build 17134.48. I've connected with both the legacy RDP client and the Windows 10 app. I've tried killing and restarting rdpclip on the host, with no effect.  I'm not sure what else to do, other than maybe try some other remote client to connect to the server with. Luckily, the files we need can be uploaded to OneDrive. I just don't want people browsing on the server. The less they do there, the better, and typically there's only one user other than myself who has any real need to transfer files from the host. It's got to be some simple setting somewhere that I inadvertently changed. 



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:29 PM

Posted 11 August 2018 - 04:14 PM

What change or changes did you make to the group policy? Did you use group policy, or group policy preferences to make the changes?



#3 projectfocus

projectfocus

  • Members
  • 479 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brighton
  • Local time:11:29 PM

Posted 05 September 2018 - 09:44 AM

There is another option and that is to use the default admin share on the server to copy the files to with your domain admin account.

 

\\sservername\C$ is the standard root OS drive and will ask for creds of the admin to access this share.  This will allow you to copy from your host machine into that folder on the server.

 

If the GPO has been set with this as a rule to stop clipboard access then disabling the GPO will not make any difference as you will need to find the GPO setting and set the option the other way.


FocusToonSigStreched.jpg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users