Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to put Windows 10 PC to Sleep


  • Please log in to reply
10 replies to this topic

#1 balkrish999

balkrish999

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Local time:11:10 AM

Posted 29 July 2018 - 08:27 AM

As per title 

 

Click Start, - Power - Sleep

 

Just goes to log in screen

 

Any idea why and fix?

 

 

Thank you 



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,433 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:10 AM

Posted 29 July 2018 - 08:45 AM

Disable Fast Startup

 

Open an elevated command prompt. Windows key + X > command prompt as admin. Your will probably say powershell as admin

 

Type the following commands

powercfg.exe -h off
shutdown /s /f /t 0

Reboot and see if the computer will sleep.



#3 balkrish999

balkrish999
  • Topic Starter

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Local time:11:10 AM

Posted 29 July 2018 - 09:26 AM

Disable Fast Startup

 

Open an elevated command prompt. Windows key + X > command prompt as admin. Your will probably say powershell as admin

 

Type the following commands

powercfg.exe -h off
shutdown /s /f /t 0

Reboot and see if the computer will sleep.

 

 

 

Hello, Thank you that worked!

 

 

But I have a few questions:

 

- Now Hibernation is gone 

- Fast Startup is disabled

 

 

Can I ask, is this a Windows Bug/Problem or my PC?

 

 

Why can't I have Fast startup and sleep?  

 

Thanks



#4 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,005 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:10 AM

Posted 29 July 2018 - 09:34 AM

If you want the straight hibernation option to show up you can go to Power Options in Control Panel and turn it on again.

 

You should be able to have Fast Startup and Sleep, but Fast Startup has a tendency to cause all sorts of nasty problems if its hibernation file (and that's what it uses, it just hibernates the OS state alone, not the OS state and user state(s) like regular hibernation does) gets corrupted over time.  I always keep Fast Startup off for that very reason.  I have seen some very bizarre behavior that disappears once Fast Startup is off.

 

It would not surprise me if Fast Startup was at the root of your Sleep issue, and that having turned it off, even if you turn it on again, will have solved the problem for a while at least.  When you turn Fast Startup off the existing OS hibernation file gets purged.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#5 JohnC_21

JohnC_21

  • Members
  • 24,433 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:10 AM

Posted 29 July 2018 - 10:03 AM

Brian, the powercfg-exe -h off command removes the option in power settings. To bring it back open the elevated command prompt and type:

powercfg.exe -h on

Reboot.

 

Personally, I would not use Fast Startup. That hibernation file can lead to issues if it gets corrupted. And, be very careful if you have an external drive connected and then remove it during hibernation. That can lead to big problems.

 

https://hardforum.com/threads/warning-external-drives-and-hibernate.1345435/


Edited by JohnC_21, 29 July 2018 - 10:03 AM.


#6 balkrish999

balkrish999
  • Topic Starter

  • Members
  • 149 posts
  • OFFLINE
  •  
  • Local time:11:10 AM

Posted 29 July 2018 - 10:06 AM

Brian, the powercfg-exe -h off command removes the option in power settings. To bring it back open the elevated command prompt and type:

powercfg.exe -h on

Reboot.

 

Personally, I would not use Fast Startup. That hibernation file can lead to issues if it gets corrupted. And, be very careful if you have an external drive connected and then remove it during hibernation. That can lead to big problems.

 

https://hardforum.com/threads/warning-external-drives-and-hibernate.1345435/

 

 

 

Okay thanks 

 

I think i will keep it safe and leave Fast start up off and just use Sleep 

 

 

Thanks once more!!



#7 JohnC_21

JohnC_21

  • Members
  • 24,433 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:10 AM

Posted 29 July 2018 - 10:13 AM

You are Welcome.  :)



#8 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,005 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:10 AM

Posted 29 July 2018 - 10:17 AM

John,

 

          I will admit, openly, to having completely glossed over the "-h off" parameter on that powercfg command and since the topic was Fast Startup I thought that was probably what you were disabling.  It is possible to have Fast Startup off and the ability to do a full hibernate on.  That's how all my systems are configured, though these days I seldom hibernate unless I know I want to come back to something hours and hours later where I'd rather not run down the battery even slightly during the wait time.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#9 jenae

jenae

  • Members
  • 831 posts
  • OFFLINE
  •  
  • Local time:02:10 AM

Posted 30 July 2018 - 08:52 PM

Hi, actually windows ten gives you some more control over this, you can have two settings for hibernate, One is Full the other is Reduced.

 

This explains the difference:-

 

Full:- 
Supports being able to enable hibernate and turn on fast startup (hiberboot). The hiberfile (C:\hiberfil.sys) will be allowed to consume up to 40% of physical RAM, installed on your computer. Hibernate is available to be added to the power menu.
 
Reduced:-
Only supports being able to turn on fast startup (hiberboot) without hibernate. The hiberfile (C:\hiberfil.sys) will be 20% of physical RAM installed on your computer. Removes hibernate from the power menu.
 
Open a cmd as admin, and you will need to have hibernate active for these cmd's to work so :-
 
powercfg /h on (press enter)
 
To set "Full" at the prompt:-
 
powercfg /h /type full (press enter)
 
To set "Reduced" at the prompt:-
 
powercfg /h /type reduced (press enter)
 
Some advanced users may have customized the hiberfil.sys file, (many get stuck doing this) to clear any customization run:-
 
powercfg /h /size 0 (press enter) this clears the file and allows you to revert to normal.
 
You do need to know what you are doing, changing windows settings, my advice,  if you leave it alone out of the box, you will enjoy your computer and will have little to no problems.
 
It's the third party apps and theTweakers that do the damage. If it was ethically possible, we have hundreds of qualified scientists and engineers on staff, if there was an honest $ to be made, we would have produced a tweaking util ourselves years ago, the fact we haven't should alert you to the possible pitfalls. All you need is included in the service that is windows ten. (I do not work for MS, I do some work for them, however we are independent from MS, I am long since retired).
 
 

 



#10 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,005 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:11:10 AM

Posted 30 July 2018 - 09:04 PM

I have to disagree with the "leave well enough alone" philosophy [which I generally espouse myself] when it comes to Fast Startup.

 

Given the number of really ugly, and utterly inexplicable problems, that can and do occur once the hiberfile that's used for Fast Startup gets corrupted it's just an accident waiting to happen.

 

As a result of my observations I routinely turn Fast Startup off, via Control Panel - Power Options, as a part of my standard system configuration protocol.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 


#11 jenae

jenae

  • Members
  • 831 posts
  • OFFLINE
  •  
  • Local time:02:10 AM

Posted 30 July 2018 - 09:46 PM

Hi, thanks Brian, that is something I did mean to mention, I also recommend turning off fast startup. This is an optional feature native to win 10, so does not fall into the mod's or tweaking category. 






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users