Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help Regarding Chrome - Slow on the Initial Page Load.


  • Please log in to reply
3 replies to this topic

#1 Hareen

Hareen

  • Members
  • 152 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hyderabad, India.
  • Local time:05:30 AM

Posted 14 July 2018 - 01:26 AM

Hello everyone,

 

I have a problem with Chrome on Windows 10 that I am experiencing on multiple different machines.

 
The basic problem is that when Chrome is first opened, the first webpage opening (no matter what the site is google.com / fast.com / 9gag.com/ school.myclassboard.com / bleepingcomputer.com) takes about 30-60 seconds to load.
Once the first page is loaded, every webpage in new window or tab opens immediately as expected.
If I close the whole program and start again, there's still that initial delay.
 
 
So, the advanced techie people any suggestions for my problem?
 
The systems range from:
 
Processors: Dual Core, i3, i5, AMD
RAM: 2 GB, 4 GB, 8GB, 16 GB
HDD: 500 GB, 1 TB, 1.5 TB
Operating System: Windows 10
 
The Windows 7 Machines work like a charm. On the same systems Firefox, Internet Explorer, Edge works fine when the Microsoft browsers homepages are set to blank.
 
All the Systems are Clean Windows installs. Security is by Kaspersky ( Kaspersky Internet Security ) and Malwarebytes Free edition.
 
All the chromes use uBlock Origin Adblocker and Adobe Reader Extensions. My System uses Adguard and Internet Download Manager Extensions as well.
 
Please let me know if you need any extra information for sorting out the issue.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,296 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 14 July 2018 - 08:01 AM

It seems Windows 10 and Chrome do not get along. There have been issues with freezing and crashing. In your problem it may be notifications. See the below thread.

 

https://productforums.google.com/forum/#!topic/chrome/3OJC764nVQs



#3 Hareen

Hareen
  • Topic Starter

  • Members
  • 152 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hyderabad, India.
  • Local time:05:30 AM

Posted 15 July 2018 - 11:41 PM

It did not freeze and crash (till now!!), so freezing is not an issue.  The issue is just the first-page taking ages to load. Perhaps, I should move to better browser alternatives (Firefox).



#4 JohnC_21

JohnC_21

  • Members
  • 24,296 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 16 July 2018 - 08:16 AM

On my older laptop Chrome does seem to take longer than with the older versions. The newest firefox is faster according to some people.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users